about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorjopejoe1 <johannes@joens.email>2023-12-06 19:49:45 +0100
committerJörg Thalheim <Mic92@users.noreply.github.com>2023-12-13 21:28:44 +0100
commitb81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc (patch)
tree90a03de8ebe907e86b329b27a2c1ffde7dd0bb8a /pkgs/by-name
parent73aa85d1152f4143269245f0c2929a679c1028f2 (diff)
downloadnixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.tar
nixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.tar.gz
nixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.tar.bz2
nixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.tar.lz
nixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.tar.xz
nixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.tar.zst
nixlib-b81aeb09ae5ce9a2572b1ee2a9982e81add1a1bc.zip
noto-fonts-cjk-sans: move out of noto-fonts file
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/no/noto-fonts-cjk-sans/package.nix49
1 files changed, 49 insertions, 0 deletions
diff --git a/pkgs/by-name/no/noto-fonts-cjk-sans/package.nix b/pkgs/by-name/no/noto-fonts-cjk-sans/package.nix
new file mode 100644
index 000000000000..5c7ab7684b62
--- /dev/null
+++ b/pkgs/by-name/no/noto-fonts-cjk-sans/package.nix
@@ -0,0 +1,49 @@
+{ lib
+, stdenvNoCC
+, fetchFromGitHub
+, nixosTests
+, gitUpdater
+}:
+
+stdenvNoCC.mkDerivation rec {
+  pname = "noto-fonts-cjk-sans";
+  version = "2.004";
+
+  src = fetchFromGitHub {
+    owner = "notofonts";
+    repo = "noto-cjk";
+    rev = "Sans${version}";
+    hash = "sha256-IgalJkiOAVjNxKaPAQWfb5hKeqclliR4qVXCq63FGWY=";
+    sparseCheckout = [ "Sans/Variable/OTC" ];
+  };
+
+  installPhase = ''
+    install -m444 -Dt $out/share/fonts/opentype/noto-cjk Sans/Variable/OTC/*.otf.ttc
+  '';
+
+  passthru.tests.noto-fonts = nixosTests.noto-fonts;
+
+  passthru.updateScript = gitUpdater {
+    rev-prefix = "Sans";
+  };
+
+  meta = {
+    description = "Beautiful and free fonts for CJK languages";
+    homepage = "https://www.google.com/get/noto/help/cjk/";
+    longDescription = ''
+      Noto Sans CJK is a sans typeface designed as
+      an intermediate style between the modern and traditional. It is
+      intended to be a multi-purpose digital font for user interface
+      designs, digital content, reading on laptops, mobile devices, and
+      electronic books. Noto Sans CJK comprehensively covers
+      Simplified Chinese, Traditional Chinese, Japanese, and Korean in a
+      unified font family. It supports regional variants of ideographic
+      characters for each of the four languages. In addition, it supports
+      Japanese kana, vertical forms, and variant characters (itaiji); it
+      supports Korean hangeul — both contemporary and archaic.
+    '';
+    license = lib.licenses.ofl;
+    platforms = lib.platforms.all;
+    maintainers = with lib.maintainers; [ mathnerd314 emily ];
+  };
+}