about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorFabian Affolter <fabian@affolter-engineering.ch>2023-12-14 11:23:07 +0100
committerGitHub <noreply@github.com>2023-12-14 11:23:07 +0100
commitce56066476ad0ea6b59488d764b7987933a2ab98 (patch)
tree165c3dc2c38822442bde2beb77a6d53402bfdc69 /pkgs/by-name
parent5e18fcf4e1696e142eee03f66c6dc5050c1b0a0e (diff)
parent13d8ffa26f0f8ba2429b88a4cda7a247a8557934 (diff)
downloadnixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.tar
nixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.tar.gz
nixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.tar.bz2
nixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.tar.lz
nixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.tar.xz
nixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.tar.zst
nixlib-ce56066476ad0ea6b59488d764b7987933a2ab98.zip
Merge pull request #236929 from fabaff/koodousfinder
koodousfinder: init at 0.1.0
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/ko/koodousfinder/package.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/by-name/ko/koodousfinder/package.nix b/pkgs/by-name/ko/koodousfinder/package.nix
new file mode 100644
index 000000000000..669783657081
--- /dev/null
+++ b/pkgs/by-name/ko/koodousfinder/package.nix
@@ -0,0 +1,42 @@
+{ lib
+, python3
+, fetchFromGitHub
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "koodousfinder";
+  version = "0.1.0";
+  pyproject = true;
+
+  src = fetchFromGitHub {
+    owner = "teixeira0xfffff";
+    repo = "KoodousFinder";
+    # Not properly tagged, https://github.com/teixeira0xfffff/KoodousFinder/issues/7
+    #rev = "refs/tags/v${version}";
+    rev = "d9dab5572f44e5cd45c04e6fcda38956897855d1";
+    hash = "sha256-skCbt2lDKgSyZdHY3WImbr6CF0icrDPTIXNV1736gKk=";
+  };
+
+  nativeBuildInputs = with python3.pkgs; [
+    poetry-core
+  ];
+
+  propagatedBuildInputs = with python3.pkgs; [
+    keyring
+    requests
+  ];
+
+  # Project has no tests, re-check with next release
+  doCheck = false;
+
+  pythonImportsCheck = [
+    "koodousfinder"
+  ];
+
+  meta = with lib; {
+    description = "Tool to allows users to search for and analyze Android apps";
+    homepage = "https://github.com/teixeira0xfffff/KoodousFinder";
+    license = with licenses; [ mit ];
+    maintainers = with maintainers; [ fab ];
+  };
+}