about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorFabian Affolter <mail@fabian-affolter.ch>2023-12-14 08:36:55 +0100
committerFabian Affolter <mail@fabian-affolter.ch>2023-12-14 08:36:55 +0100
commit13d8ffa26f0f8ba2429b88a4cda7a247a8557934 (patch)
tree8caf727c210dcc8f3426077b7b3f4c432b5d0f7e /pkgs/by-name
parentaa9d4729cbc99dabacb50e3994dcefb3ea0f7447 (diff)
downloadnixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.tar
nixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.tar.gz
nixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.tar.bz2
nixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.tar.lz
nixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.tar.xz
nixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.tar.zst
nixlib-13d8ffa26f0f8ba2429b88a4cda7a247a8557934.zip
koodousfinder: init at 0.1.0
Tool to allows users to search for and analyze Android apps

https://github.com/teixeira0xfffff/KoodousFinder
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/ko/koodousfinder/package.nix42
1 files changed, 42 insertions, 0 deletions
diff --git a/pkgs/by-name/ko/koodousfinder/package.nix b/pkgs/by-name/ko/koodousfinder/package.nix
new file mode 100644
index 000000000000..669783657081
--- /dev/null
+++ b/pkgs/by-name/ko/koodousfinder/package.nix
@@ -0,0 +1,42 @@
+{ lib
+, python3
+, fetchFromGitHub
+}:
+
+python3.pkgs.buildPythonApplication rec {
+  pname = "koodousfinder";
+  version = "0.1.0";
+  pyproject = true;
+
+  src = fetchFromGitHub {
+    owner = "teixeira0xfffff";
+    repo = "KoodousFinder";
+    # Not properly tagged, https://github.com/teixeira0xfffff/KoodousFinder/issues/7
+    #rev = "refs/tags/v${version}";
+    rev = "d9dab5572f44e5cd45c04e6fcda38956897855d1";
+    hash = "sha256-skCbt2lDKgSyZdHY3WImbr6CF0icrDPTIXNV1736gKk=";
+  };
+
+  nativeBuildInputs = with python3.pkgs; [
+    poetry-core
+  ];
+
+  propagatedBuildInputs = with python3.pkgs; [
+    keyring
+    requests
+  ];
+
+  # Project has no tests, re-check with next release
+  doCheck = false;
+
+  pythonImportsCheck = [
+    "koodousfinder"
+  ];
+
+  meta = with lib; {
+    description = "Tool to allows users to search for and analyze Android apps";
+    homepage = "https://github.com/teixeira0xfffff/KoodousFinder";
+    license = with licenses; [ mit ];
+    maintainers = with maintainers; [ fab ];
+  };
+}