about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorpiegames <git@piegames.de>2024-03-14 14:32:47 +0000
committerGitHub <noreply@github.com>2024-03-14 14:32:47 +0000
commit50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b (patch)
tree7c0a55ab4a0f356206b30c7582033cbabe8e2f9e /pkgs/by-name
parent656c67320e6ccf24fd7b779769c578877eac3173 (diff)
parent6f72b441414cc60710c02ed8c0d2684143af688b (diff)
downloadnixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.tar
nixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.tar.gz
nixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.tar.bz2
nixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.tar.lz
nixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.tar.xz
nixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.tar.zst
nixlib-50ce7fc6361e7a57a2fbf235ba5b82e5bbfc697b.zip
Merge pull request #243032: g3kb-switch: init at 1.3
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/g3/g3kb-switch/package.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/by-name/g3/g3kb-switch/package.nix b/pkgs/by-name/g3/g3kb-switch/package.nix
new file mode 100644
index 000000000000..625cd6ef9a3d
--- /dev/null
+++ b/pkgs/by-name/g3/g3kb-switch/package.nix
@@ -0,0 +1,33 @@
+{ lib
+, stdenv
+, cmake
+, pkg-config
+, glib
+, fetchFromGitHub
+}:
+stdenv.mkDerivation rec {
+  pname = "g3kb-switch";
+  version = "1.4";
+  src = fetchFromGitHub {
+    owner = "lyokha";
+    repo = "g3kb-switch";
+    rev = version;
+    sha256 = "sha256-mcZduHcteZ+nS0YEZG5DfmpA8xrnLhwxumq6hLuLPIs=";
+  };
+
+  nativeBuildInputs = [
+    cmake
+    pkg-config
+  ];
+  buildInputs = [
+    glib
+  ];
+
+  meta = with lib; {
+    homepage = "https://github.com/lyokha/g3kb-switch";
+    description = "CLI keyboard layout switcher for GNOME Shell";
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ Freed-Wu ];
+    platforms = platforms.unix;
+  };
+}