about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorWu, Zhenyu <wuzhenyu@ustc.edu>2024-03-14 10:44:25 +0800
committerWu, Zhenyu <wuzhenyu@ustc.edu>2024-03-14 10:44:25 +0800
commit6f72b441414cc60710c02ed8c0d2684143af688b (patch)
treebc23c186912a35ded94ea1639b0eaf9bac738ba7 /pkgs/by-name
parent1f80dd9f11cad193796216a8b9f5f06df036564c (diff)
downloadnixlib-6f72b441414cc60710c02ed8c0d2684143af688b.tar
nixlib-6f72b441414cc60710c02ed8c0d2684143af688b.tar.gz
nixlib-6f72b441414cc60710c02ed8c0d2684143af688b.tar.bz2
nixlib-6f72b441414cc60710c02ed8c0d2684143af688b.tar.lz
nixlib-6f72b441414cc60710c02ed8c0d2684143af688b.tar.xz
nixlib-6f72b441414cc60710c02ed8c0d2684143af688b.tar.zst
nixlib-6f72b441414cc60710c02ed8c0d2684143af688b.zip
g3kb-switch: init at 1.4
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/g3/g3kb-switch/package.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/by-name/g3/g3kb-switch/package.nix b/pkgs/by-name/g3/g3kb-switch/package.nix
new file mode 100644
index 000000000000..625cd6ef9a3d
--- /dev/null
+++ b/pkgs/by-name/g3/g3kb-switch/package.nix
@@ -0,0 +1,33 @@
+{ lib
+, stdenv
+, cmake
+, pkg-config
+, glib
+, fetchFromGitHub
+}:
+stdenv.mkDerivation rec {
+  pname = "g3kb-switch";
+  version = "1.4";
+  src = fetchFromGitHub {
+    owner = "lyokha";
+    repo = "g3kb-switch";
+    rev = version;
+    sha256 = "sha256-mcZduHcteZ+nS0YEZG5DfmpA8xrnLhwxumq6hLuLPIs=";
+  };
+
+  nativeBuildInputs = [
+    cmake
+    pkg-config
+  ];
+  buildInputs = [
+    glib
+  ];
+
+  meta = with lib; {
+    homepage = "https://github.com/lyokha/g3kb-switch";
+    description = "CLI keyboard layout switcher for GNOME Shell";
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ Freed-Wu ];
+    platforms = platforms.unix;
+  };
+}