about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authorWeijia Wang <9713184+wegank@users.noreply.github.com>2024-02-11 18:05:47 +0100
committerGitHub <noreply@github.com>2024-02-11 18:05:47 +0100
commit464391cb6d183c885ebaf60ed07349d9b79a850a (patch)
tree5b95d16c3ea1e45837614f080aa23a957bde1a64 /pkgs/by-name
parentc9541aced4042f3315b6fc86d27d3dbefea22e59 (diff)
parente0174c26688ee24472e238447f8a81bc8dc26ed9 (diff)
downloadnixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.tar
nixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.tar.gz
nixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.tar.bz2
nixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.tar.lz
nixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.tar.xz
nixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.tar.zst
nixlib-464391cb6d183c885ebaf60ed07349d9b79a850a.zip
Merge pull request #288038 from Aleksanaa/ghfetch
ghfetch: init at 0.0.19
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/gh/ghfetch/package.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/by-name/gh/ghfetch/package.nix b/pkgs/by-name/gh/ghfetch/package.nix
new file mode 100644
index 000000000000..07991723d5da
--- /dev/null
+++ b/pkgs/by-name/gh/ghfetch/package.nix
@@ -0,0 +1,26 @@
+{ lib
+, buildGoModule
+, fetchFromGitHub
+}:
+
+buildGoModule rec {
+  pname = "ghfetch";
+  version = "0.0.19";
+
+  src = fetchFromGitHub {
+    owner = "orangekame3";
+    repo = "ghfetch";
+    rev = "v${version}";
+    hash = "sha256-Cmyd/wrobHPyG9ExUSfSsTwFUfbo9iuvmAr0uqunWWw=";
+  };
+
+  vendorHash = "sha256-CPh9j5PJOSNvqgq/S9w+Kx3c5yIMHjc1AaqLwz9efeY=";
+
+  meta = with lib; {
+    description = "A CLI tool to fetch GitHub user information and show like neofetch";
+    homepage = "https://github.com/orangekame3/ghfetch";
+    license = licenses.mit;
+    mainProgram = "ghfetch";
+    maintainers = with maintainers; [ aleksana ];
+  };
+}