about summary refs log tree commit diff
path: root/pkgs/by-name
diff options
context:
space:
mode:
authoraleksana <me@aleksana.moe>2024-02-11 21:36:53 +0800
committeraleksana <me@aleksana.moe>2024-02-11 21:36:53 +0800
commite0174c26688ee24472e238447f8a81bc8dc26ed9 (patch)
tree74e11079cebcdb09c9dcab5f902a8a3066785d83 /pkgs/by-name
parent380761c2f5cbf9281c33e8b9c04ef8dbad4f9862 (diff)
downloadnixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.tar
nixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.tar.gz
nixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.tar.bz2
nixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.tar.lz
nixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.tar.xz
nixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.tar.zst
nixlib-e0174c26688ee24472e238447f8a81bc8dc26ed9.zip
ghfetch: init at 0.0.19
Diffstat (limited to 'pkgs/by-name')
-rw-r--r--pkgs/by-name/gh/ghfetch/package.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/by-name/gh/ghfetch/package.nix b/pkgs/by-name/gh/ghfetch/package.nix
new file mode 100644
index 000000000000..07991723d5da
--- /dev/null
+++ b/pkgs/by-name/gh/ghfetch/package.nix
@@ -0,0 +1,26 @@
+{ lib
+, buildGoModule
+, fetchFromGitHub
+}:
+
+buildGoModule rec {
+  pname = "ghfetch";
+  version = "0.0.19";
+
+  src = fetchFromGitHub {
+    owner = "orangekame3";
+    repo = "ghfetch";
+    rev = "v${version}";
+    hash = "sha256-Cmyd/wrobHPyG9ExUSfSsTwFUfbo9iuvmAr0uqunWWw=";
+  };
+
+  vendorHash = "sha256-CPh9j5PJOSNvqgq/S9w+Kx3c5yIMHjc1AaqLwz9efeY=";
+
+  meta = with lib; {
+    description = "A CLI tool to fetch GitHub user information and show like neofetch";
+    homepage = "https://github.com/orangekame3/ghfetch";
+    license = licenses.mit;
+    mainProgram = "ghfetch";
+    maintainers = with maintainers; [ aleksana ];
+  };
+}