about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorPeter Simons <simons@cryp.to>2013-06-15 03:26:10 -0700
committerPeter Simons <simons@cryp.to>2013-06-15 03:26:10 -0700
commitfc165c0db99c68277b7eef19b571c0d676082cb3 (patch)
tree5d3f3ee91bdaa611b22c091b608f31cc8adaad8d /pkgs/applications
parentbc73915b7238e08b6033f3807f65e7f9b0e8bdfc (diff)
parentd0d9470519dd686c114b796ac84cf9c7cd030a58 (diff)
downloadnixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.tar
nixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.tar.gz
nixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.tar.bz2
nixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.tar.lz
nixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.tar.xz
nixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.tar.zst
nixlib-fc165c0db99c68277b7eef19b571c0d676082cb3.zip
Merge pull request #626 from lovek323/sup
sup: add required gems and separate dependencies
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/mailreaders/sup/default.nix29
1 files changed, 10 insertions, 19 deletions
diff --git a/pkgs/applications/networking/mailreaders/sup/default.nix b/pkgs/applications/networking/mailreaders/sup/default.nix
index 163a32bfa88a..8852e9491732 100644
--- a/pkgs/applications/networking/mailreaders/sup/default.nix
+++ b/pkgs/applications/networking/mailreaders/sup/default.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl, ruby, rake, rubygems, makeWrapper, ncursesw_sup
-, xapian_full_alaveteli, gpgme, libiconvOrEmpty }:
+, xapian_full_alaveteli, gpgme, libiconvOrEmpty, rmail, mime_types, chronic
+, trollop, lockfile, gettext, iconv }:
 
 stdenv.mkDerivation {
   name = "sup-d21f027afcd6a4031de9619acd8dacbd2f2f4fd4";
@@ -34,30 +35,20 @@ stdenv.mkDerivation {
     GEM_PATH="$GEM_PATH:${ncursesw_sup}/${ruby.gemPath}"
     GEM_PATH="$GEM_PATH:${xapian_full_alaveteli}/${ruby.gemPath}"
     GEM_PATH="$GEM_PATH:${gpgme}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${rmail}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${mime_types}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${chronic}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${trollop}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${lockfile}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${gettext}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${iconv}/${ruby.gemPath}"
 
     # Don't install some dependencies -- we have already installed
-    # ncursesw-sup, xapian-full-alaveteli and gpgme, but gem doesn't acknowledge
-    # this
+    # the dependencies but gem doesn't acknowledge this
     gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
         --bindir "$out/bin" --no-rdoc --no-ri pkg/sup-999.gem \
         --ignore-dependencies
 
-    # Now install the dependencies that will work out of the box
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri rmail
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri trollop
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri lockfile
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri mime-types
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri gettext
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri chronic
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri iconv
-
     for prog in $out/bin/*; do
       wrapProgram "$prog" --prefix GEM_PATH : "$GEM_PATH"
     done