about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorJason "Don" O'Conal <lovek323@gmail.com>2013-06-14 18:06:14 +1000
committerJason "Don" O'Conal <lovek323@gmail.com>2013-06-14 18:06:14 +1000
commitd0d9470519dd686c114b796ac84cf9c7cd030a58 (patch)
treeba318a38c50649f1a1cd41de63559c1a49ff2788 /pkgs/applications
parent7346eb64bfb636a30a3987e3365d99763ffb4347 (diff)
downloadnixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.tar
nixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.tar.gz
nixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.tar.bz2
nixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.tar.lz
nixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.tar.xz
nixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.tar.zst
nixlib-d0d9470519dd686c114b796ac84cf9c7cd030a58.zip
sup: add required gems and separate dependencies
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/mailreaders/sup/default.nix29
1 files changed, 10 insertions, 19 deletions
diff --git a/pkgs/applications/networking/mailreaders/sup/default.nix b/pkgs/applications/networking/mailreaders/sup/default.nix
index 163a32bfa88a..8852e9491732 100644
--- a/pkgs/applications/networking/mailreaders/sup/default.nix
+++ b/pkgs/applications/networking/mailreaders/sup/default.nix
@@ -1,5 +1,6 @@
 { stdenv, fetchurl, ruby, rake, rubygems, makeWrapper, ncursesw_sup
-, xapian_full_alaveteli, gpgme, libiconvOrEmpty }:
+, xapian_full_alaveteli, gpgme, libiconvOrEmpty, rmail, mime_types, chronic
+, trollop, lockfile, gettext, iconv }:
 
 stdenv.mkDerivation {
   name = "sup-d21f027afcd6a4031de9619acd8dacbd2f2f4fd4";
@@ -34,30 +35,20 @@ stdenv.mkDerivation {
     GEM_PATH="$GEM_PATH:${ncursesw_sup}/${ruby.gemPath}"
     GEM_PATH="$GEM_PATH:${xapian_full_alaveteli}/${ruby.gemPath}"
     GEM_PATH="$GEM_PATH:${gpgme}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${rmail}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${mime_types}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${chronic}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${trollop}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${lockfile}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${gettext}/${ruby.gemPath}"
+    GEM_PATH="$GEM_PATH:${iconv}/${ruby.gemPath}"
 
     # Don't install some dependencies -- we have already installed
-    # ncursesw-sup, xapian-full-alaveteli and gpgme, but gem doesn't acknowledge
-    # this
+    # the dependencies but gem doesn't acknowledge this
     gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
         --bindir "$out/bin" --no-rdoc --no-ri pkg/sup-999.gem \
         --ignore-dependencies
 
-    # Now install the dependencies that will work out of the box
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri rmail
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri trollop
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri lockfile
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri mime-types
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri gettext
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri chronic
-    gem install --no-verbose --install-dir "$out/${ruby.gemPath}" \
-        --bindir "$out/bin" --no-rdoc --no-ri iconv
-
     for prog in $out/bin/*; do
       wrapProgram "$prog" --prefix GEM_PATH : "$GEM_PATH"
     done