about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTheMaxMur <muravjev.mak@yandex.ru>2024-03-11 16:39:12 +0300
committerTheMaxMur <muravjev.mak@yandex.ru>2024-03-11 19:28:24 +0300
commitd57dbbe36843f071bd54f0e57a29245ee00ca473 (patch)
tree79a1f315c3fab06ed206e8061db3eb4a00d22150 /pkgs/applications
parent71fce2227a77e22d27761c3636aa389daf27f7d1 (diff)
downloadnixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.tar
nixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.tar.gz
nixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.tar.bz2
nixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.tar.lz
nixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.tar.xz
nixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.tar.zst
nixlib-d57dbbe36843f071bd54f0e57a29245ee00ca473.zip
vscode-extensions.visualstudioexptteam.intellicode-api-usage-examples: init 0.2.8
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vscode/extensions/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/applications/editors/vscode/extensions/default.nix b/pkgs/applications/editors/vscode/extensions/default.nix
index 0f2d1d718683..91ef18147c65 100644
--- a/pkgs/applications/editors/vscode/extensions/default.nix
+++ b/pkgs/applications/editors/vscode/extensions/default.nix
@@ -4287,6 +4287,22 @@ let
         };
       };
 
+      visualstudioexptteam.intellicode-api-usage-examples = buildVscodeMarketplaceExtension {
+        mktplcRef = {
+          name = "intellicode-api-usage-examples";
+          publisher = "VisualStudioExptTeam";
+          version = "0.2.8";
+          sha256 = "sha256-aXAS3QX+mrX0kJqf1LUsvguqRxxC0o+jj1bKQteXPNA=";
+        };
+        meta = {
+          description = "See relevant code examples from GitHub for over 100K different APIs right in your editor.";
+          downloadPage = "https://marketplace.visualstudio.com/items?itemName=VisualStudioExptTeam.intellicode-api-usage-examples";
+          homepage = "https://github.com/MicrosoftDocs/intellicode";
+          license = lib.licenses.cc-by-40;
+          maintainers = [ lib.maintainers.themaxmur ];
+        };
+      };
+
       vlanguage.vscode-vlang = buildVscodeMarketplaceExtension {
         mktplcRef = {
           name = "vscode-vlang";