about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorTheMaxMur <muravjev.mak@yandex.ru>2024-03-11 16:37:46 +0300
committerTheMaxMur <muravjev.mak@yandex.ru>2024-03-11 19:28:16 +0300
commit71fce2227a77e22d27761c3636aa389daf27f7d1 (patch)
treef231f5b0ae683e9293319ccdfda544bad3a145cd /pkgs/applications
parentf9fc4dd23bea2b42f70f35e82fef8668530f1e75 (diff)
downloadnixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.tar
nixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.tar.gz
nixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.tar.bz2
nixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.tar.lz
nixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.tar.xz
nixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.tar.zst
nixlib-71fce2227a77e22d27761c3636aa389daf27f7d1.zip
vscode-extensions.ms-vscode.cpptools-extension-pack: init 1.3.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/vscode/extensions/default.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/applications/editors/vscode/extensions/default.nix b/pkgs/applications/editors/vscode/extensions/default.nix
index b870394aee0e..0f2d1d718683 100644
--- a/pkgs/applications/editors/vscode/extensions/default.nix
+++ b/pkgs/applications/editors/vscode/extensions/default.nix
@@ -2951,6 +2951,22 @@ let
 
       ms-vscode.cpptools = callPackage ./ms-vscode.cpptools { };
 
+      ms-vscode.cpptools-extension-pack = buildVscodeMarketplaceExtension {
+        mktplcRef = {
+          name = "cpptools-extension-pack";
+          publisher = "ms-vscode";
+          version = "1.3.0";
+          sha256 = "sha256-rHST7CYCVins3fqXC+FYiS5Xgcjmi7QW7M4yFrUR04U=";
+        };
+        meta = {
+          description = "Popular extensions for C++ development in Visual Studio Code.";
+          downloadPage = "https://marketplace.visualstudio.com/items?itemName=ms-vscode.cpptools-extension-pack";
+          homepage = "https://github.com/microsoft/vscode-cpptools";
+          license = lib.licenses.mit;
+          maintainers = [ lib.maintainers.themaxmur ];
+        };
+      };
+
       ms-vscode.hexeditor = buildVscodeMarketplaceExtension {
         mktplcRef = {
           name = "hexeditor";