about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorAnderson Torres <torres.anderson.85@protonmail.com>2020-12-31 16:44:02 -0300
committerGitHub <noreply@github.com>2020-12-31 16:44:02 -0300
commitd50923ab2d308a1ddb21594ba6ae064cab65d8ae (patch)
treeb836fbe6ab1c8abdacac37c8e4a50ef081fe142d /pkgs/applications
parent30ec6cf329bc18c10942e814390fbdfebc645c4b (diff)
parent7b34fb70f7309634079f3f104efbcf2a0e9fe99d (diff)
downloadnixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.tar
nixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.tar.gz
nixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.tar.bz2
nixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.tar.lz
nixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.tar.xz
nixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.tar.zst
nixlib-d50923ab2d308a1ddb21594ba6ae064cab65d8ae.zip
Merge pull request #107892 from wishfort36/herbe
herbe: init at 1.0.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/herbe/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/applications/misc/herbe/default.nix b/pkgs/applications/misc/herbe/default.nix
new file mode 100644
index 000000000000..0d05228b63eb
--- /dev/null
+++ b/pkgs/applications/misc/herbe/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, lib, fetchFromGitHub, libX11, libXft, freetype, patches ? [ ],
+  extraLibs ? [ ] }:
+
+stdenv.mkDerivation rec {
+  pname = "herbe";
+  version = "1.0.0";
+
+  src = fetchFromGitHub {
+    owner = "dudik";
+    repo = pname;
+    rev = version;
+    sha256 = "0358i5jmmlsvy2j85ij7m1k4ar2jr5lsv7y1c58dlf9710h186cv";
+  };
+
+  inherit patches;
+
+  postPatch = ''
+    sed -i 's_/usr/include/freetype2_${freetype.dev}/include/freetype2_' Makefile
+  '';
+
+  buildInputs = [ libX11 libXft freetype ] ++ extraLibs;
+
+  makeFlags = [ "PREFIX=$(out)" ];
+
+  meta = with lib; {
+    description = "Daemon-less notifications without D-Bus";
+    homepage = "https://github.com/dudik/herbe";
+    license = licenses.mit;
+    # NOTE: Could also work on 'unix'.
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ wishfort36 ];
+  };
+}