about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorwishfort36 <42300264+wishfort36@users.noreply.github.com>2020-12-29 17:33:46 +0100
committerwishfort36 <42300264+wishfort36@users.noreply.github.com>2020-12-31 18:48:26 +0100
commit7b34fb70f7309634079f3f104efbcf2a0e9fe99d (patch)
treee3f6027b9e1574ab6a0f4dca037197ccb924ecb6 /pkgs/applications
parent75513fb361477a5289a78e1a5c64a0ea13a7b535 (diff)
downloadnixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.tar
nixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.tar.gz
nixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.tar.bz2
nixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.tar.lz
nixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.tar.xz
nixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.tar.zst
nixlib-7b34fb70f7309634079f3f104efbcf2a0e9fe99d.zip
herbe: init at 1.0.0
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/misc/herbe/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/applications/misc/herbe/default.nix b/pkgs/applications/misc/herbe/default.nix
new file mode 100644
index 000000000000..0d05228b63eb
--- /dev/null
+++ b/pkgs/applications/misc/herbe/default.nix
@@ -0,0 +1,33 @@
+{ stdenv, lib, fetchFromGitHub, libX11, libXft, freetype, patches ? [ ],
+  extraLibs ? [ ] }:
+
+stdenv.mkDerivation rec {
+  pname = "herbe";
+  version = "1.0.0";
+
+  src = fetchFromGitHub {
+    owner = "dudik";
+    repo = pname;
+    rev = version;
+    sha256 = "0358i5jmmlsvy2j85ij7m1k4ar2jr5lsv7y1c58dlf9710h186cv";
+  };
+
+  inherit patches;
+
+  postPatch = ''
+    sed -i 's_/usr/include/freetype2_${freetype.dev}/include/freetype2_' Makefile
+  '';
+
+  buildInputs = [ libX11 libXft freetype ] ++ extraLibs;
+
+  makeFlags = [ "PREFIX=$(out)" ];
+
+  meta = with lib; {
+    description = "Daemon-less notifications without D-Bus";
+    homepage = "https://github.com/dudik/herbe";
+    license = licenses.mit;
+    # NOTE: Could also work on 'unix'.
+    platforms = platforms.linux;
+    maintainers = with maintainers; [ wishfort36 ];
+  };
+}