about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2018-11-23 22:30:29 +0000
committerGitHub <noreply@github.com>2018-11-23 22:30:29 +0000
commit5e159d463b641e8c66a8244030e5e33081a1907b (patch)
treef90adf63c5ec7f5bb6f17d340d5fe0dd81275eac /pkgs/applications
parentf11297acb904beea02d587dba4db609fa36effb7 (diff)
parent0483ce0eeeb7c859e58a287d6f1a0d4e959efffb (diff)
downloadnixlib-5e159d463b641e8c66a8244030e5e33081a1907b.tar
nixlib-5e159d463b641e8c66a8244030e5e33081a1907b.tar.gz
nixlib-5e159d463b641e8c66a8244030e5e33081a1907b.tar.bz2
nixlib-5e159d463b641e8c66a8244030e5e33081a1907b.tar.lz
nixlib-5e159d463b641e8c66a8244030e5e33081a1907b.tar.xz
nixlib-5e159d463b641e8c66a8244030e5e33081a1907b.tar.zst
nixlib-5e159d463b641e8c66a8244030e5e33081a1907b.zip
Merge pull request #49228 from Ekleog/rss2email-module
rss2email module: init 
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/feedreaders/rss2email/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/applications/networking/feedreaders/rss2email/default.nix b/pkgs/applications/networking/feedreaders/rss2email/default.nix
index 4152c2772e10..4d17cc8bddd1 100644
--- a/pkgs/applications/networking/feedreaders/rss2email/default.nix
+++ b/pkgs/applications/networking/feedreaders/rss2email/default.nix
@@ -1,11 +1,13 @@
-{ pythonPackages, fetchurl, lib }:
+{ pythonPackages, fetchurl, lib, nixosTests }:
 
 with pythonPackages;
 
 buildPythonApplication rec {
   name = "${pname}-${version}";
   pname = "rss2email";
-  version = "3.9";
+  version = "3.9"; # TODO: on next bump, the manpage will be updated.
+  # Update nixos/modules/services/mail/rss2email.nix to point to it instead of
+  # to the online r2e.1
 
   propagatedBuildInputs = [ feedparser beautifulsoup4 html2text ];
 
@@ -44,4 +46,7 @@ buildPythonApplication rec {
     license = licenses.gpl2;
     maintainers = with maintainers; [ jb55 Profpatsch ];
   };
+  passthru.tests = {
+    smoke-test = nixosTests.rss2email;
+  };
 }