about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorLéo Gaspard <leo@gaspard.io>2018-10-27 18:33:43 +0900
committerLéo Gaspard <leo@gaspard.io>2018-11-15 23:44:16 +0900
commit0483ce0eeeb7c859e58a287d6f1a0d4e959efffb (patch)
tree0e359369726917b9476f310a8a185b3a4570e378 /pkgs/applications
parent4b5ffcb964b48c2754aa8964699b339840f507d3 (diff)
downloadnixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.tar
nixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.tar.gz
nixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.tar.bz2
nixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.tar.lz
nixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.tar.xz
nixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.tar.zst
nixlib-0483ce0eeeb7c859e58a287d6f1a0d4e959efffb.zip
rss2email module: init
Also adding `system-sendmail` package for sharing the code with other
modules or packages needing it.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/networking/feedreaders/rss2email/default.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/applications/networking/feedreaders/rss2email/default.nix b/pkgs/applications/networking/feedreaders/rss2email/default.nix
index 4152c2772e10..4d17cc8bddd1 100644
--- a/pkgs/applications/networking/feedreaders/rss2email/default.nix
+++ b/pkgs/applications/networking/feedreaders/rss2email/default.nix
@@ -1,11 +1,13 @@
-{ pythonPackages, fetchurl, lib }:
+{ pythonPackages, fetchurl, lib, nixosTests }:
 
 with pythonPackages;
 
 buildPythonApplication rec {
   name = "${pname}-${version}";
   pname = "rss2email";
-  version = "3.9";
+  version = "3.9"; # TODO: on next bump, the manpage will be updated.
+  # Update nixos/modules/services/mail/rss2email.nix to point to it instead of
+  # to the online r2e.1
 
   propagatedBuildInputs = [ feedparser beautifulsoup4 html2text ];
 
@@ -44,4 +46,7 @@ buildPythonApplication rec {
     license = licenses.gpl2;
     maintainers = with maintainers; [ jb55 Profpatsch ];
   };
+  passthru.tests = {
+    smoke-test = nixosTests.rss2email;
+  };
 }