about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2015-07-30 23:36:14 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2015-08-10 23:12:03 +0200
commit0bbaba47e9a45d7cb802031461be8caaf0f3a03d (patch)
treef75f5de439645da0b821e9dea8d8bec804bdb9ef /pkgs/applications
parent4134d6b5b96355cb07848ea5aba5558a72b415df (diff)
downloadnixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.tar
nixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.tar.gz
nixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.tar.bz2
nixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.tar.lz
nixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.tar.xz
nixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.tar.zst
nixlib-0bbaba47e9a45d7cb802031461be8caaf0f3a03d.zip
eclipses: do not recurse into plugins.nix
It does not really make sense to install the plugin packages directly as
they are intended for use with `eclipseWithPlugins`. Therefore it is
best not to present them to users as such.
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/eclipse/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/applications/editors/eclipse/default.nix b/pkgs/applications/editors/eclipse/default.nix
index b3b9d2732576..7d543c4ed55f 100644
--- a/pkgs/applications/editors/eclipse/default.nix
+++ b/pkgs/applications/editors/eclipse/default.nix
@@ -3,7 +3,7 @@
 , glib, gtk, libXtst, jre
 , webkitgtk2 ? null  # for internal web browser
 , buildEnv, writeText, runCommand
-, recurseIntoAttrs, callPackage
+, callPackage
 }:
 
 assert stdenv ? glibc;
@@ -388,6 +388,6 @@ in {
         ln -s ${eclipse}/share $out/
       '';
 
-  plugins = recurseIntoAttrs (callPackage ./plugins.nix { });
+  plugins = callPackage ./plugins.nix { };
 
 }