about summary refs log tree commit diff
path: root/pkgs/applications
diff options
context:
space:
mode:
authorRobert Helgesson <robert@rycee.net>2015-07-30 23:31:57 +0200
committerBjørn Forsman <bjorn.forsman@gmail.com>2015-08-10 23:12:03 +0200
commit4134d6b5b96355cb07848ea5aba5558a72b415df (patch)
treee99465cd816af314c4bb75c102c816cb843cdf8b /pkgs/applications
parentb253f95529daf82a81aab046a3781d3748499211 (diff)
downloadnixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.tar
nixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.tar.gz
nixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.tar.bz2
nixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.tar.lz
nixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.tar.xz
nixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.tar.zst
nixlib-4134d6b5b96355cb07848ea5aba5558a72b415df.zip
eclipse-acejump: init at 1.0.0.201501181511
Diffstat (limited to 'pkgs/applications')
-rw-r--r--pkgs/applications/editors/eclipse/plugins.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/applications/editors/eclipse/plugins.nix b/pkgs/applications/editors/eclipse/plugins.nix
index 1bd8b39ec625..0f2c37b9b6ac 100644
--- a/pkgs/applications/editors/eclipse/plugins.nix
+++ b/pkgs/applications/editors/eclipse/plugins.nix
@@ -62,6 +62,30 @@ rec {
       '';
     };
 
+  acejump = buildEclipsePlugin rec {
+    name = "acejump-${version}";
+    version = "1.0.0.201501181511";
+    javaName = "acejump";
+
+    srcFeature = fetchurl {
+      url = "https://tobiasmelcher.github.io/acejumpeclipse/features/${javaName}.feature_${version}.jar";
+      sha256 = "127xqrnns4h96g21c9zg0iblxprx3fg6fg0w5f413rf84415z884";
+    };
+
+    srcPlugin = fetchurl {
+      url = "https://tobiasmelcher.github.io/acejumpeclipse/plugins/${javaName}_${version}.jar";
+      sha256 = "0mz79ca32yryidd1wijirvnmfg4j5q4g84vdspdi56z0r4xrja13";
+    };
+
+    meta = with stdenv.lib; {
+      homepage = https://github.com/tobiasmelcher/EclipseAceJump;
+      description = "Provides fast jumps to text based on initial letter";
+      license = licenses.mit;
+      platforms = platforms.all;
+      maintainers = [ maintainers.rycee ];
+    };
+  };
+
   anyedittools = buildEclipsePlugin rec {
     name = "anyedit-${version}";
     version = "2.4.15.201504172030";