about summary refs log tree commit diff
path: root/nixos/tests/grsecurity.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-07-23 02:29:09 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2016-07-24 12:54:07 +0200
commit88138d43fa3a07bc99d29c857b69730165d8f403 (patch)
tree4a765233308e44caf519da560e2dca774dadcbc3 /nixos/tests/grsecurity.nix
parent8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0 (diff)
downloadnixlib-88138d43fa3a07bc99d29c857b69730165d8f403.tar
nixlib-88138d43fa3a07bc99d29c857b69730165d8f403.tar.gz
nixlib-88138d43fa3a07bc99d29c857b69730165d8f403.tar.bz2
nixlib-88138d43fa3a07bc99d29c857b69730165d8f403.tar.lz
nixlib-88138d43fa3a07bc99d29c857b69730165d8f403.tar.xz
nixlib-88138d43fa3a07bc99d29c857b69730165d8f403.tar.zst
nixlib-88138d43fa3a07bc99d29c857b69730165d8f403.zip
grsecurity test: add note explaining what the tcc -run test accomplishes
Diffstat (limited to 'nixos/tests/grsecurity.nix')
-rw-r--r--nixos/tests/grsecurity.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/nixos/tests/grsecurity.nix b/nixos/tests/grsecurity.nix
index ed0101621520..e585a7402d34 100644
--- a/nixos/tests/grsecurity.nix
+++ b/nixos/tests/grsecurity.nix
@@ -32,6 +32,8 @@ import ./make-test.nix ({ pkgs, ...} : {
       $machine->succeed("${pkgs.paxtest}/lib/paxtest/mprotstack") =~ /Killed/ or die;
     };
 
+    # tcc -run executes run-time generated code and so allows us to test whether
+    # paxmark actually works (otherwise, the process should be terminated)
     subtest "tcc", sub {
       $machine->execute("echo -e '#include <stdio.h>\nint main(void) { puts(\"hello\"); return 0; }' >main.c");
       $machine->succeed("${pkgs.tinycc.bin}/bin/tcc -run main.c");