about summary refs log tree commit diff
path: root/nixos/tests/grsecurity.nix
diff options
context:
space:
mode:
authorJoachim Fasting <joachifm@fastmail.fm>2016-07-17 21:38:11 +0200
committerJoachim Fasting <joachifm@fastmail.fm>2016-07-24 12:54:07 +0200
commit8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0 (patch)
tree348d3f96ceb12d703920259b10e10c6388df7c72 /nixos/tests/grsecurity.nix
parent96542a1b003aa52f58eb2aa5fd099d0141b83a4d (diff)
downloadnixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.tar
nixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.tar.gz
nixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.tar.bz2
nixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.tar.lz
nixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.tar.xz
nixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.tar.zst
nixlib-8c8d6b4053f76e692b8a3c010d0d56f2a6974cd0.zip
grsecurity test: verify that the grsec device node is created
Diffstat (limited to 'nixos/tests/grsecurity.nix')
-rw-r--r--nixos/tests/grsecurity.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/nixos/tests/grsecurity.nix b/nixos/tests/grsecurity.nix
index aadbfd8371ff..ed0101621520 100644
--- a/nixos/tests/grsecurity.nix
+++ b/nixos/tests/grsecurity.nix
@@ -9,7 +9,6 @@ import ./make-test.nix ({ pkgs, ...} : {
   machine = { config, pkgs, ... }:
     { security.grsecurity.enable = true;
       boot.kernel.sysctl."kernel.grsecurity.deter_bruteforce" = 0;
-      security.apparmor.enable = true;
     };
 
   testScript = ''
@@ -37,5 +36,9 @@ import ./make-test.nix ({ pkgs, ...} : {
       $machine->execute("echo -e '#include <stdio.h>\nint main(void) { puts(\"hello\"); return 0; }' >main.c");
       $machine->succeed("${pkgs.tinycc.bin}/bin/tcc -run main.c");
     };
+
+    subtest "RBAC", sub {
+      $machine->succeed("[ -c /dev/grsec ]");
+    };
   '';
 })