about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/peertube.nix
diff options
context:
space:
mode:
authorIzorkin <izorkin@elven.pw>2023-02-27 14:14:54 +0300
committerIzorkin <izorkin@elven.pw>2023-05-08 23:49:03 +0300
commit1afcb4c6ef456e33279a16c3a21be1e85ad6ef01 (patch)
tree3c1ec9abf350202860ae7183eb31f9105e1ebbff /nixos/modules/services/web-apps/peertube.nix
parent8d76c0b6fb552bc61d9e7708c182dd41b4349e44 (diff)
downloadnixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.tar
nixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.tar.gz
nixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.tar.bz2
nixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.tar.lz
nixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.tar.xz
nixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.tar.zst
nixlib-1afcb4c6ef456e33279a16c3a21be1e85ad6ef01.zip
nixos/peertube: update nginx configuration
Diffstat (limited to 'nixos/modules/services/web-apps/peertube.nix')
-rw-r--r--nixos/modules/services/web-apps/peertube.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/web-apps/peertube.nix b/nixos/modules/services/web-apps/peertube.nix
index 3d99b535b76a..4ef2d7dce532 100644
--- a/nixos/modules/services/web-apps/peertube.nix
+++ b/nixos/modules/services/web-apps/peertube.nix
@@ -490,7 +490,7 @@ in {
     services.nginx = lib.mkIf cfg.configureNginx {
       enable = true;
       virtualHosts."${cfg.localDomain}" = {
-        root = "/var/lib/peertube";
+        root = "/var/lib/peertube/www";
 
         # Application
         locations."/" = {
@@ -593,7 +593,7 @@ in {
 
         # Bypass PeerTube for performance reasons.
         locations."~ ^/client/(assets/images/(icons/icon-36x36\.png|icons/icon-48x48\.png|icons/icon-72x72\.png|icons/icon-96x96\.png|icons/icon-144x144\.png|icons/icon-192x192\.png|icons/icon-512x512\.png|logo\.svg|favicon\.png|default-playlist\.jpg|default-avatar-account\.png|default-avatar-account-48x48\.png|default-avatar-video-channel\.png|default-avatar-video-channel-48x48\.png))$" = {
-          tryFiles = "/www/client-overrides/$1 /www/client/$1 $1";
+          tryFiles = "/client-overrides/$1 /client/$1 $1";
           priority = 1310;
         };