about summary refs log tree commit diff
path: root/nixos/modules/services/web-apps/peertube.nix
diff options
context:
space:
mode:
authorIzorkin <izorkin@elven.pw>2023-02-27 14:13:14 +0300
committerIzorkin <izorkin@elven.pw>2023-05-08 23:48:32 +0300
commit8d76c0b6fb552bc61d9e7708c182dd41b4349e44 (patch)
tree693889c1eebdd3a2718312573fa7016e8ed35ddc /nixos/modules/services/web-apps/peertube.nix
parent0767f800e062c1ae78c9ad0a41b86be28c01b9ad (diff)
downloadnixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.tar
nixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.tar.gz
nixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.tar.bz2
nixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.tar.lz
nixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.tar.xz
nixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.tar.zst
nixlib-8d76c0b6fb552bc61d9e7708c182dd41b4349e44.zip
peertube: 5.0.0 -> 5.1.0
Diffstat (limited to 'nixos/modules/services/web-apps/peertube.nix')
-rw-r--r--nixos/modules/services/web-apps/peertube.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/nixos/modules/services/web-apps/peertube.nix b/nixos/modules/services/web-apps/peertube.nix
index 65b3b70c48ad..3d99b535b76a 100644
--- a/nixos/modules/services/web-apps/peertube.nix
+++ b/nixos/modules/services/web-apps/peertube.nix
@@ -429,7 +429,7 @@ in {
 
       environment = env;
 
-      path = with pkgs; [ bashInteractive ffmpeg nodejs_16 openssl yarn python3 ];
+      path = with pkgs; [ bashInteractive ffmpeg nodejs_18 openssl yarn python3 ];
 
       script = ''
         #!/bin/sh
@@ -859,7 +859,7 @@ in {
           home = cfg.package;
         };
       })
-      (lib.attrsets.setAttrByPath [ cfg.user "packages" ] [ cfg.package peertubeEnv peertubeCli pkgs.ffmpeg pkgs.nodejs_16 pkgs.yarn ])
+      (lib.attrsets.setAttrByPath [ cfg.user "packages" ] [ cfg.package peertubeEnv peertubeCli pkgs.ffmpeg pkgs.nodejs_18 pkgs.yarn ])
       (lib.mkIf cfg.redis.enableUnixSocket {${config.services.peertube.user}.extraGroups = [ "redis-peertube" ];})
     ];