about summary refs log tree commit diff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorAlyssa Ross <hi@alyssa.is>2021-02-14 11:57:45 +0000
committerAlyssa Ross <hi@alyssa.is>2021-02-17 15:16:29 +0000
commit6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4 (patch)
tree5955257a31295586dd2203137736693ae01068d9 /Cargo.toml
downloadpr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.tar
pr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.tar.gz
pr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.tar.bz2
pr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.tar.lz
pr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.tar.xz
pr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.tar.zst
pr-tracker-6f9ccf054b8af59243e50b24d2c8b36e22ab3ac4.zip
Initial commit
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml37
1 files changed, 37 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..ec985e4
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,37 @@
+# SPDX-License-Identifier: CC0-1.0
+# SPDX-FileCopyrightText: 2021 Alyssa Ross <hi@alyssa.is>
+
+[package]
+name = "pr-tracker"
+version = "0.1.0"
+authors = ["Alyssa Ross <hi@alyssa.is>"]
+edition = "2018"
+license = "AGPL-3.0-or-later WITH GPL-3.0-linking-exception"
+
+[build-dependencies]
+pkg-config = "0.3.19"
+
+[dependencies]
+http-types = "*"
+once_cell = "1.5"
+regex = "1.4"
+surf = "2.1"
+serde_json = "1.0"
+graphql_client = "0.8.0"
+serde = "1.0"
+askama = "0.10.5"
+structopt = "0.3.21"
+futures-util = "0.3.12"
+
+[dependencies.async-std]
+version = "*" # Use whatever tide uses.
+features = ["attributes"]
+
+[dependencies.tide]
+version = "0.16.0"
+default-features = false
+features = ["h1-server", "logger"]
+
+[patch.crates-io]
+# https://github.com/djc/askama/pull/447
+askama = { git = "https://github.com/djc/askama", branch = "main" }