about summary refs log tree commit diff
path: root/sys/mbp.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/mbp.nix')
-rw-r--r--sys/mbp.nix91
1 files changed, 91 insertions, 0 deletions
diff --git a/sys/mbp.nix b/sys/mbp.nix
new file mode 100644
index 000000000000..17a0e979fb5f
--- /dev/null
+++ b/sys/mbp.nix
@@ -0,0 +1,91 @@
+{ pkgs, ... }:
+
+{
+  imports = [
+    ../modules/nixos-apple-silicon/apple-silicon-support
+    ../modules/persistence
+    ../modules/workstation/audio
+    ../modules/workstation/hardware/bluetooth
+    ../modules/workstation/physical
+  ];
+
+  hardware.enableRedistributableFirmware = true;
+
+  boot.loader.systemd-boot.enable = true;
+
+  boot.initrd.postDeviceCommands = ''
+    mkdir /mnt
+    mount /dev/mapper/root /mnt
+    btrfs subvolume delete /mnt/boot
+    btrfs subvolume create /mnt/boot
+    umount /mnt
+  '';
+
+  boot.initrd.luks.devices."root".device = "/dev/disk/by-uuid/dc106480-a643-4f32-a63d-931f53e8baae";
+
+  boot.kernelPatches = [
+    # Causes gnulib tests to fail.
+    {
+      name = "revert-asahi-libwebp-hack.patch";
+      patch = pkgs.fetchpatch {
+        url = "https://github.com/AsahiLinux/linux/commit/a5e95f77e7133c7e5f9c0999fae23ebf59d645d3.patch";
+        revert = true;
+        hash = "sha256-3Vl6SzGFt1+fCvYf9Gnw9XNudiixQHcbhPSRJ14bwhc=";
+      };
+    }
+  ];
+
+  fileSystems."/" = {
+    device = "/dev/disk/by-uuid/e5821c99-7507-421d-9280-de09a055d926";
+    fsType = "btrfs";
+    options = [ "subvol=boot" ];
+  };
+
+  fileSystems."/home" = {
+    device = "/dev/disk/by-uuid/e5821c99-7507-421d-9280-de09a055d926";
+    fsType = "btrfs";
+    options = [ "subvol=persist/safe/home" ];
+  };
+
+  fileSystems."/nix" = {
+    device = "/dev/disk/by-uuid/e5821c99-7507-421d-9280-de09a055d926";
+    fsType = "btrfs";
+    options = [ "subvol=persist/local/nix" ];
+  };
+
+  fileSystems."/boot" = {
+    device = "/dev/disk/by-uuid/472D-1D13";
+    fsType = "vfat";
+  };
+
+  fileSystems."/persist" = {
+    device = "/dev/disk/by-uuid/e5821c99-7507-421d-9280-de09a055d926";
+    fsType = "btrfs";
+    options = [ "subvol=persist" ];
+    neededForBoot = true;
+  };
+
+  fileSystems."/srv" = {
+    device = "/dev/disk/by-uuid/e5821c99-7507-421d-9280-de09a055d926";
+    fsType = "btrfs";
+    options = [ "subvol=persist/safe/srv" ];
+  };
+
+  fileSystems."/var/lib/machines" = {
+    device = "/dev/disk/by-uuid/e5821c99-7507-421d-9280-de09a055d926";
+    fsType = "btrfs";
+    options = [ "subvol=persist/safe/var/lib/machines" ];
+  };
+
+  networking.hostName = "mbp";
+
+  users.users.qyliss.hashedPassword = "$y$j9T$qdvgrHPyvZpqjUQXuagxD1$dq5yygUTVhVqpgG9.zWaihmtED437Cl.fllqJBEWSo4";
+
+  hardware.opengl.enable = true;
+
+  programs.sway.extraConfig = ''
+    output Unknown-1 scale 2
+  '';
+
+  system.stateVersion = "23.11";
+}