about summary refs log tree commit diff
path: root/sys/eve.nix
diff options
context:
space:
mode:
Diffstat (limited to 'sys/eve.nix')
-rw-r--r--sys/eve.nix47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys/eve.nix b/sys/eve.nix
deleted file mode 100644
index 2c0cb44d5a4a..000000000000
--- a/sys/eve.nix
+++ /dev/null
@@ -1,47 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-{
-  imports = [
-    ../modules/workstation/physical
-    ../modules/workstation/hardware/pixelbook
-  ];
-
-  hardware.enableRedistributableFirmware = true;
-
-  boot.kernelPackages = config.boot.zfs.package.latestCompatibleLinuxPackages;
-  boot.zfs.enableUnstable = true;
-
-  boot.initrd.availableKernelModules = [ "nvme" "usb_storage" "sdhci_pci" ];
-  boot.kernelModules = [ "kvm-intel" ];
-
-  boot.loader.systemd-boot.enable = true;
-
-  fileSystems."/" = { fsType = "zfs"; device = "rpool/local/root"; };
-  fileSystems."/tmp" = { fsType = "zfs"; device = "rpool/local/tmp"; };
-  fileSystems."/nix" = { fsType = "zfs"; device = "rpool/local/nix"; };
-  fileSystems."/home" = { fsType = "zfs"; device = "rpool/data/home"; };
-  fileSystems."/state" = { fsType = "zfs"; device = "rpool/data/state"; };
-  fileSystems."/boot" = {
-    fsType = "vfat";
-    device = "/dev/disk/by-path/pci-0000:02:00.0-nvme-1-part2";
-  };
-
-  # TODO: do this with ZFS
-  boot.tmp.cleanOnBoot = true;
-
-  networking.hostName = "eve";
-  networking.hostId = "c00b7876";
-
-  nix.settings.max-jobs = 4;
-
-  console.font = "${pkgs.terminus_font}/share/consolefonts/ter-u32n.psf.gz";
-  console.earlySetup = true;
-  programs.sway.extraConfig = ''
-    output eDP-1 scale 2
-  '';
-
-  users.users.qyliss.hashedPassword = "$5$rounds=2000000$FPrRi1TT.rCn$8MhcwE7JL8yTKI.fSRe4ZgJP3eumStDCNl5Pb.IN9i5";
-  users.users.qyliss.home = "/home";
-
-  system.stateVersion = "20.03";
-}