about summary refs log tree commit diff
path: root/shells/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shells/linux.nix')
-rw-r--r--shells/linux.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shells/linux.nix b/shells/linux.nix
new file mode 100644
index 000000000000..35d3532a1c16
--- /dev/null
+++ b/shells/linux.nix
@@ -0,0 +1,15 @@
+{ pkgs ? import ../. {} }:
+with pkgs;
+
+mkShell {
+  buildInputs = [
+    bison flex bc libelf openssl
+
+    # For make {n,menu}config
+    ncurses pkgconfig
+
+    # For documentation
+    graphviz imagemagick python3Packages.sphinx python3Packages.sphinx_rtd_theme
+    texlive.combined.scheme-minimal
+  ];
+}