about summary refs log tree commit diff
path: root/shells/linux.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shells/linux.nix')
-rw-r--r--shells/linux.nix19
1 files changed, 6 insertions, 13 deletions
diff --git a/shells/linux.nix b/shells/linux.nix
index 8b5eb976e344..1cdbbc50baa1 100644
--- a/shells/linux.nix
+++ b/shells/linux.nix
@@ -1,23 +1,16 @@
-{ pkgs ? import ../. {} }:
+{ pkgs ? import ../. {} } @ args:
 with pkgs;
 
-stdenv.mkDerivation {
+(import ./c.nix args).overrideAttrs ({ buildInputs ? [], ... }: {
   name = "linux-shell";
-  buildInputs = [
-    bison flex bc elfutils openssl
+  buildInputs = buildInputs ++ [
+    elfutils openssl
 
     # For make {n,menu}config
-    ncurses pkgconfig
-
-    # For LSP
-    clang-tools
+    ncurses
 
     # For documentation
     graphviz imagemagick python3Packages.sphinx python3Packages.sphinx_rtd_theme
     texlive.combined.scheme-minimal
   ];
-
-  buildCommand = ''
-    printf "%s\n" $buildInputs > $out
-  '';
-}
+})