about summary refs log tree commit diff
path: root/pkgs/top-level
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/top-level')
-rw-r--r--pkgs/top-level/perl-packages.nix8
-rw-r--r--pkgs/top-level/python-packages.nix358
-rw-r--r--pkgs/top-level/release-lib.nix8
3 files changed, 366 insertions, 8 deletions
diff --git a/pkgs/top-level/perl-packages.nix b/pkgs/top-level/perl-packages.nix
index ec3a07918029..be1ca9511749 100644
--- a/pkgs/top-level/perl-packages.nix
+++ b/pkgs/top-level/perl-packages.nix
@@ -3953,13 +3953,13 @@ rec {
   };
 
   TestWarn = buildPerlPackage rec {
-    name = "Test-Warn-0.23";
+    name = "Test-Warn-0.24";
     src = fetchurl {
       url = "mirror://cpan/modules/by-module/Test/${name}.tar.gz";
-      sha256 = "1733s39s4pm0hsshvvjsv1vbri09l4g0g7yyg64y65yqcyanfdf0";
+      sha256 = "12r1mcwrm6cgc3ppgawwv265vmrighj4bl6xc5c41f4c2l6bdxml";
     };
-    propagatedBuildInputs = [TestSimple TestException ArrayCompare TreeDAGNode];
-    buildInputs = [TestPod];
+    propagatedBuildInputs = [ TestSimple TestException ArrayCompare TreeDAGNode ];
+    buildInputs = [ TestPod ];
   };
 
   TestWWWMechanize = buildPerlPackage rec {
diff --git a/pkgs/top-level/python-packages.nix b/pkgs/top-level/python-packages.nix
index f5a5a579e877..dd0719747ad1 100644
--- a/pkgs/top-level/python-packages.nix
+++ b/pkgs/top-level/python-packages.nix
@@ -352,6 +352,22 @@ let pythonPackages = python.modules // rec {
   # });
 
 
+  buildout = buildPythonPackage rec {
+    name = "buildout-${version}";
+    version = "1.7.0";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/z/zc.buildout/zc.${name}.tar.gz";
+      md5 = "4e3b521600e475c56a0a66459a5fc7bb";
+    };
+
+   meta = {
+      homepage = http://www.buildout.org/;
+      description = "A software build and configuration system";
+    };
+  };
+
+
   carrot = buildPythonPackage rec {
     name = "carrot-0.10.7";
 
@@ -486,6 +502,18 @@ let pythonPackages = python.modules // rec {
     };
   };
 
+  covCore = buildPythonPackage rec {
+    name = "cov-core-1.7";
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/c/cov-core/cov-core-1.7.tar.gz";
+      md5 = "59c1e22e636633e10120beacbf45b28c";
+    };
+    meta = {
+      description = "plugin core for use by pytest-cov, nose-cov and nose2-cov";
+    };
+    propagatedBuildInputs = [ coverage ];
+  };
+
   cssselect = buildPythonPackage rec {
     name = "cssselect-0.7.1";
     src = fetchurl {
@@ -604,6 +632,29 @@ let pythonPackages = python.modules // rec {
   });
 
 
+  distutils2  = buildPythonPackage rec {
+    name = "distutils2-${version}";
+    version = "1.0a4";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/D/Distutils2/Distutils2-${version}.tar.gz";
+      md5 = "52bc9dffb394970c27e02853ae3a3241";
+    };
+
+    patchPhase = ''
+      sed -e "s#html.entities#htmlentitydefs#g" -i distutils2/pypi/simple.py
+    '';
+
+    doCheck = false;
+
+    meta = {
+      description = "A Python Packaging Library";
+      homepage = http://pypi.python.org/pypi/Distutils2;
+      license = "PSF";
+    };
+  };
+
+
   distutils_extra = buildPythonPackage rec {
     name = "distutils-extra-2.26";
 
@@ -1255,6 +1306,23 @@ let pythonPackages = python.modules // rec {
     };
   };
 
+  manuel = buildPythonPackage rec {
+    name = "manuel-${version}";
+    version = "1.6.0";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/m/manuel/${name}.tar.gz";
+      md5 = "53d6a6905301a20f6095e41d11968fff";
+    };
+
+    propagatedBuildInputs = [ six zope_testing ];
+
+    meta = {
+      description = "A documentation builder";
+      homepage = http://pypi.python.org/pypi/manuel;
+      license = "ZPL";
+    };
+  };
 
   markdown = buildPythonPackage rec {
     version = "2.0.3";
@@ -1368,6 +1436,26 @@ let pythonPackages = python.modules // rec {
   };
 
 
+  mrbob = buildPythonPackage rec {
+    name = "mrbob-${version}";
+    version = "0.1a6";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/m/mr.bob/mr.bob-${version}.zip";
+      md5 = "361c8ac7a31953ab94a95cf34d9a0b2b";
+    };
+
+    buildInputs = [ pkgs.unzip ];
+
+    propagatedBuildInputs = [ argparse jinja2 ];
+
+    meta = {
+      homepage = https://github.com/iElectric/mr.bob.git;
+      description = "A tool to generate code skeletons from templates";
+    };
+  };
+
+
   mutagen = buildPythonPackage (rec {
     name = "mutagen-1.20";
 
@@ -1516,6 +1604,32 @@ let pythonPackages = python.modules // rec {
     buildInputs = [ coverage ];
   };
 
+  nose2 = buildPythonPackage rec {
+    name = "nose2-0.4.5";
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/n/nose2/${name}.tar.gz";
+      md5 = "d7e51c848227488e3cc0424faf5511cd";
+    };
+    meta = {
+      description = "nose2 is the next generation of nicer testing for Python";
+    };
+    propagatedBuildInputs = [ six ];
+    # AttributeError: 'module' object has no attribute 'collector'
+    doCheck = false;
+  };
+
+  nose2Cov = buildPythonPackage rec {
+    name = "nose2-cov-1.0a4";
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/n/nose2-cov/nose2-cov-1.0a4.tar.gz";
+      md5 = "6442f03e2ea732b0e38eb5b00fbe0b31";
+    };
+    meta = {
+      description = "nose2 plugin for coverage reporting, including subprocesses and multiprocessing";
+    };
+    buildInputs = [ covCore nose2 ];
+  };
+
   notify = pkgs.stdenv.mkDerivation (rec {
     name = "python-notify-0.1.1";
 
@@ -1524,7 +1638,7 @@ let pythonPackages = python.modules // rec {
       sha256 = "1kh4spwgqxm534qlzzf2ijchckvs0pwjxl1irhicjmlg7mybnfvx";
     };
 
-    buildInputs = [ python pkgs.pkgconfig pkgs.libnotify pkgs.pygobject pkgs.pygtk pkgs.glib pkgs.gtk pkgs.dbus_glib ];
+    buildInputs = [ python pkgs.pkgconfig pkgs.libnotify pygobject pygtk pkgs.glib pkgs.gtk pkgs.dbus_glib ];
 
     postInstall = "cd $out/lib/python*/site-packages && ln -s gtk-*/pynotify .";
 
@@ -1838,6 +1952,21 @@ let pythonPackages = python.modules // rec {
   };
 
 
+  psutil = buildPythonPackage rec {
+    name = "psutil-0.6.1";
+
+    src = fetchurl {
+      url = "http://psutil.googlecode.com/files/${name}.tar.gz";
+      sha256 = "0vqarv63jqzghr4fi1fqdbvg847fq2gqdj8dzc3x59f9b36a8rfn";
+    };
+
+    meta = {
+      description = "Process and system utilization information interface for python";
+      homepage = http://code.google.com/p/psutil/;
+    };
+  };
+
+
   psycopg2 = buildPythonPackage rec {
     name = "psycopg2-2.0.13";
 
@@ -2759,7 +2888,7 @@ let pythonPackages = python.modules // rec {
     # error: invalid command 'test'
     doCheck = false;
 
-    propagatedBuildInputs = [ pkgs.xlibs.libX11 pkgs.pythonDBus pkgs.pygobject ];
+    propagatedBuildInputs = [ pkgs.xlibs.libX11 pkgs.pythonDBus pygobject ];
 
     meta = {
       description = "High-level, platform independent Skype API wrapper for Python";
@@ -2859,6 +2988,24 @@ let pythonPackages = python.modules // rec {
   });
 
 
+  subunit = buildPythonPackage rec {
+    name = "subunit-${version}";
+    version = "0.0.9";
+
+    src = fetchurl {
+      url = "https://launchpad.net/subunit/trunk/0.0.9/+download/python-${name}.tar.gz";
+      sha256 = "0g3bk8lfd52zjzg43h47h2kckchm3xyv1gcr85nca2i50rcrpj56";
+    };
+
+    propagatedBuildInputs = [ testtools ];
+
+    meta = {
+      description = "A streaming protocol for test results";
+      homepage = https://launchpad.net/subunit;
+      license = pkgs.lib.licenses.asl20;
+    };
+  };
+
   # XXX: ValueError: ZIP does not support timestamps before 1980
   # svneverever =  buildPythonPackage rec {
   #   name = "svneverever-778489a8";
@@ -2920,6 +3067,23 @@ let pythonPackages = python.modules // rec {
   };
 
 
+  testtools = buildPythonPackage rec {
+    name = "testtools-${version}";
+    version = "0.9.24";
+
+    src = fetchurl {
+      url = "https://launchpad.net/testtools/0.9/0.9.24/+download/${name}.tar.gz";
+      sha256 = "0mgkvd7c1aw34nlnz2nmll5k01aqhixxiikbs2nfyk3xfa4221x7";
+    };
+
+    meta = {
+      description = "A set of extensions to the Python standard library's unit testing framework";
+      homepage = http://pypi.python.org/pypi/testtools;
+      license = pkgs.lib.licenses.mit;
+    };
+  };
+
+
   trac = buildPythonPackage {
     name = "trac-0.12.2";
 
@@ -2942,6 +3106,44 @@ let pythonPackages = python.modules // rec {
     };
   };
 
+
+  transaction = buildPythonPackage rec {
+    name = "transaction-${version}";
+    version = "1.4.0";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/t/transaction/${name}.tar.gz";
+      md5 = "b7c2ff135939f605a8c54e1c13cd5d66";
+    };
+
+    propagatedBuildInputs = [ zopeInterface ];
+
+    meta = {
+      description = "Transaction management";
+      homepage = http://pypi.python.org/pypi/transaction;
+      license = "ZPL";
+    };
+  };
+
+
+  eggdeps  = buildPythonPackage rec {
+     name = "eggdeps-${version}";
+     version = "0.4";
+
+     src = fetchurl {
+       url = "http://pypi.python.org/packages/source/t/tl.eggdeps/tl.${name}.tar.gz";
+       md5 = "2472204a2abd0d8cd4d11ff0fbf36ae7";
+     };
+
+     propagatedBuildInputs = [ zopeInterface zope_testing ];
+     meta = {
+       description = "A tool which computes a dependency graph between active Python eggs";
+       homepage = http://thomas-lotze.de/en/software/eggdeps/;
+       license = "ZPL";
+     };
+   };
+
+
   turses = buildPythonPackage (rec {
     name = "turses-0.2.9";
 
@@ -3260,6 +3462,62 @@ let pythonPackages = python.modules // rec {
     };
   });
 
+
+  zconfig = buildPythonPackage rec {
+    name = "zconfig-${version}";
+    version = "2.9.3";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/Z/ZConfig/ZConfig-${version}.tar.gz";
+      md5 = "2c5f73c216140a705be3d9c44b988722";
+    };
+
+    propagatedBuildInputs = [ zope_testrunner ];
+
+    meta = {
+      description = "Structured Configuration Library";
+      homepage = http://pypi.python.org/pypi/ZConfig;
+      license = "ZPL";
+    };
+  };
+
+
+  zc_lockfile = buildPythonPackage rec {
+    name = "zc_lockfile-${version}";
+    version = "1.0.2";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/z/zc.lockfile/zc.lockfile-${version}.tar.gz";
+      md5 = "f099d4cf2583a0c7bea0146a44dc4d59";
+    };
+
+    meta = {
+      description = "Inter-process locks";
+      homepage =  http://www.python.org/pypi/zc.lockfile;
+      license = "ZPL";
+    };
+  };
+
+
+  zdaemon = buildPythonPackage rec {
+    name = "zdaemon-${version}";
+    version = "3.0.5";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/z/zdaemon/${name}.tar.gz";
+      md5 = "975f770544bb4352c5cf32fec22e63c9";
+    };
+
+    propagatedBuildInputs  = [ zconfig ];
+
+    meta = {
+      description = "A daemon process control library and tools for Unix-based systems";
+      homepage = http://pypi.python.org/pypi/zdaemon;
+      license = "ZPL";
+    };
+  };
+
+
   zfec = buildPythonPackage (rec {
     name = "zfec-1.4.7";
 
@@ -3289,6 +3547,102 @@ let pythonPackages = python.modules // rec {
     };
   });
 
+
+  zodb3 = buildPythonPackage rec {
+    name = "zodb3-${version}";
+    version = "3.10.5";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/Z/ZODB3/ZODB3-${version}.tar.gz";
+      md5 = "6f180c6897a1820948fee2a6290503cd";
+    };
+
+    propagatedBuildInputs = [ manuel transaction zc_lockfile zconfig zdaemon zopeInterface zope_event ];
+
+    meta = {
+      description = "An object-oriented database for Python";
+      homepage = http://pypi.python.org/pypi/ZODB3;
+      license = "ZPL";
+    };
+  };
+
+
+  zope_event = buildPythonPackage rec {
+    name = "zope_event-${version}";
+    version = "4.0.2";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/z/zope.event/zope.event-${version}.tar.gz";
+      md5 = "e08dd299d428d77a1cfcbfe841b81872";
+    };
+
+    meta = {
+      description = "An event publishing system";
+      homepage = http://pypi.python.org/pypi/zope.event;
+      license = "ZPL";
+    };
+  };
+
+
+  zope_exceptions = buildPythonPackage rec {
+     name = "zopeexceptions-${version}";
+     version = "4.0.5";
+
+     src = fetchurl {
+       url = "http://pypi.python.org/packages/source/z/zope.exceptions/zope.exceptions-${version}.tar.gz";
+       md5 = "c95569fcb444ae541777de7ae5297492";
+     };
+
+     propagatedBuildInputs = [ zopeInterface ];
+
+     meta = {
+       description = "Exception interfaces and implementations";
+       homepage = http://pypi.python.org/pypi/zope.exceptions;
+       license = "ZPL";
+     };
+   };
+
+
+  zope_testing = buildPythonPackage rec {
+    name = "zope_testing-${version}";
+    version = "4.1.1";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/z/zope.testing/zope.testing-${version}.tar.gz";
+      md5 = "2e3829841090d6adff718b8b73c87b6b";
+    };
+
+    propagatedBuildInputs = [ zopeInterface zope_exceptions ];
+
+    meta = {
+      description = "Zope testing helpers";
+      homepage =  http://pypi.python.org/pypi/zope.testing;
+      license = "ZPL";
+    };
+  };
+
+
+  zope_testrunner = buildPythonPackage rec {
+    name = "zope_testrunner-${version}";
+    version = "4.0.4";
+
+    src = fetchurl {
+      url = "http://pypi.python.org/packages/source/z/zope.testrunner/zope.testrunner-${version}.zip";
+      md5 = "cd648fc865a79aa0950e73342836dd4c";
+    };
+
+    buildInputs = [ pkgs.unzip ];
+
+    propagatedBuildInputs = [ subunit zopeInterface zope_exceptions zope_testing ];
+
+    meta = {
+      description = "A flexible test runner with layer support";
+      homepage = http://pypi.python.org/pypi/zope.testrunner;
+      license = "ZPL";
+    };
+  };
+
+
   zopeInterface = buildPythonPackage {
     name = "zope-interface-3.6.1";
     src = fetchurl {
diff --git a/pkgs/top-level/release-lib.nix b/pkgs/top-level/release-lib.nix
index 3509cf7f31f0..fed9a1d673ba 100644
--- a/pkgs/top-level/release-lib.nix
+++ b/pkgs/top-level/release-lib.nix
@@ -1,7 +1,11 @@
 rec {
-  allPackages = import ./all-packages.nix;
 
-  pkgs = allPackages {};
+  # Ensure that we don't build packages marked as unfree.
+  allPackages = args: import ./all-packages.nix (args // {
+    config.allowUnfree = false;
+  });
+
+  pkgs = allPackages { };
 
   /* !!! Hack: poor man's memoisation function.  Necessary for prevent
      Nixpkgs from being evaluated again and again for every