about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/X11/xosview2/default.nix6
-rw-r--r--pkgs/tools/admin/aws-rotate-key/default.nix4
-rw-r--r--pkgs/tools/cd-dvd/mdf2iso/default.nix6
-rw-r--r--pkgs/tools/filesystems/davfs2/default.nix4
-rw-r--r--pkgs/tools/filesystems/rdfind/default.nix4
-rw-r--r--pkgs/tools/graphics/appleseed/default.nix4
-rw-r--r--pkgs/tools/inputmethods/fusuma/Gemfile2
-rw-r--r--pkgs/tools/inputmethods/fusuma/Gemfile.lock13
-rw-r--r--pkgs/tools/inputmethods/fusuma/default.nix22
-rw-r--r--pkgs/tools/inputmethods/fusuma/gemset.nix10
-rw-r--r--pkgs/tools/misc/doitlive/default.nix4
-rw-r--r--pkgs/tools/networking/amass/default.nix42
-rw-r--r--pkgs/tools/networking/amass/deps.nix101
-rw-r--r--pkgs/tools/networking/curl/7_59.nix14
-rw-r--r--pkgs/tools/networking/curl/default.nix14
-rw-r--r--pkgs/tools/networking/tcpreplay/default.nix4
-rw-r--r--pkgs/tools/networking/twa/default.nix4
-rw-r--r--pkgs/tools/package-management/morph/default.nix37
-rw-r--r--pkgs/tools/package-management/morph/deps.nix66
-rw-r--r--pkgs/tools/security/hashcat/default.nix9
-rw-r--r--pkgs/tools/security/hashcat/use-installed-xxhash.patch22
-rw-r--r--pkgs/tools/security/shc/default.nix6
-rw-r--r--pkgs/tools/system/datefudge/default.nix4
-rw-r--r--pkgs/tools/system/sleuthkit/default.nix4
-rw-r--r--pkgs/tools/system/tree/default.nix4
-rw-r--r--pkgs/tools/typesetting/git-latexdiff/default.nix10
-rw-r--r--pkgs/tools/typesetting/git-latexdiff/shebang.patch10
-rw-r--r--pkgs/tools/typesetting/git-latexdiff/version-test.patch6
28 files changed, 372 insertions, 64 deletions
diff --git a/pkgs/tools/X11/xosview2/default.nix b/pkgs/tools/X11/xosview2/default.nix
index c8b658d4350e..ae11cb4f4238 100644
--- a/pkgs/tools/X11/xosview2/default.nix
+++ b/pkgs/tools/X11/xosview2/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "xosview2-${version}";
-  version = "2.2.2";
+  version = "2.3.0";
 
   src = fetchurl {
     url = "mirror://sourceforge/xosview/${name}.tar.gz";
-    sha256 = "3502e119a5305ff2396f559340132910807351c7d4e375f13b5c338404990406";
+    sha256 = "0a588aryjn3397p7d3sp3nblnsg3v8affib1kfk3k8x0x75vgpal";
   };
 
   # The software failed to buid with this enabled; it seemed tests were not implemented
@@ -34,7 +34,7 @@ stdenv.mkDerivation rec {
       monitor what is going on.
     '';
     homepage = "http://xosview.sourceforge.net/index.html";
-    license = licenses.gpl1;
+    license = with licenses; [ gpl2 bsdOriginal ];
     maintainers = [ maintainers.SeanZicari ];
     platforms = platforms.all;
   };
diff --git a/pkgs/tools/admin/aws-rotate-key/default.nix b/pkgs/tools/admin/aws-rotate-key/default.nix
index a8c00cf0eefa..e03e7f345351 100644
--- a/pkgs/tools/admin/aws-rotate-key/default.nix
+++ b/pkgs/tools/admin/aws-rotate-key/default.nix
@@ -2,7 +2,7 @@
 
 buildGoPackage rec {
   name = "aws-rotate-key-${version}";
-  version = "1.0.3";
+  version = "1.0.4";
 
   goPackagePath = "github.com/Fullscreen/aws-rotate-key";
 
@@ -10,7 +10,7 @@ buildGoPackage rec {
     rev = "v${version}";
     owner = "Fullscreen";
     repo = "aws-rotate-key";
-    sha256 = "15na7flc0vp14amaq3116a5glqlb4ydvdlzv0q7mwl73pc38zxn3";
+    sha256 = "14bcs434646qdywws55r1a1v8ncwz8n0yljaa8zb5796pv4445wf";
   };
 
   goDeps = ./deps.nix;
diff --git a/pkgs/tools/cd-dvd/mdf2iso/default.nix b/pkgs/tools/cd-dvd/mdf2iso/default.nix
index c87d5783ff6f..f33ba31beee8 100644
--- a/pkgs/tools/cd-dvd/mdf2iso/default.nix
+++ b/pkgs/tools/cd-dvd/mdf2iso/default.nix
@@ -5,9 +5,9 @@ stdenv.mkDerivation rec {
   version = "0.3.1";
 
   src = fetchgit {
-    url    = https://anonscm.debian.org/cgit/collab-maint/mdf2iso.git;
-    rev    = "5a8acaf3645bff863f9f16ea1d3632c312f01523";
-    sha256 = "0f2jx8dg1sxc8y0sisqhqsqg7pj1j84fp08nahp0lfcq522pqbhl";
+    url    = "https://salsa.debian.org/debian/mdf2iso";
+    rev    = "c6a5b588318d43bc8af986bbe48d0a06e92f4280";
+    sha256 = "0xg43jlvrk8adfjgbjir15nxwcj0nhz4gxpqx7jdfvhg0kwliq0n";
   };
 
   meta = with stdenv.lib; {
diff --git a/pkgs/tools/filesystems/davfs2/default.nix b/pkgs/tools/filesystems/davfs2/default.nix
index 38933c524cc0..37ee611f0547 100644
--- a/pkgs/tools/filesystems/davfs2/default.nix
+++ b/pkgs/tools/filesystems/davfs2/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl, neon, zlib }:
 
 stdenv.mkDerivation rec {
-  name = "davfs2-1.5.3";
+  name = "davfs2-1.5.4";
 
   src = fetchurl {
     url = "mirror://savannah/davfs2/${name}.tar.gz";
-    sha256 = "1x9ri19995ika89cmc56za7z3ipiizhh6zdhi4mf4p7chxzdnhrw";
+    sha256 = "1q4ngkzbkq0rfxikvkwg7ccpzi1nkkmlf8bb46326y1aj7qf1i69";
   };
 
   buildInputs = [ neon zlib ];
diff --git a/pkgs/tools/filesystems/rdfind/default.nix b/pkgs/tools/filesystems/rdfind/default.nix
index b421a768b3dc..2457ac59a213 100644
--- a/pkgs/tools/filesystems/rdfind/default.nix
+++ b/pkgs/tools/filesystems/rdfind/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "rdfind-${version}";
-  version = "1.3.5";
+  version = "1.4.1";
 
   src = fetchurl {
     url = "https://rdfind.pauldreik.se/${name}.tar.gz";
-    sha256 = "0i63f2lwwkiq5m8shi3wwi59i1s25r6dx6flsgqxs1jvlcg0lvn3";
+    sha256 = "132y3wwgnbpdx6f90q0yahd3nkr4cjzcy815ilc8p97b4vn17iih";
   };
 
   buildInputs = [ nettle ];
diff --git a/pkgs/tools/graphics/appleseed/default.nix b/pkgs/tools/graphics/appleseed/default.nix
index 0fe6dcfbfd30..7ac9a2016611 100644
--- a/pkgs/tools/graphics/appleseed/default.nix
+++ b/pkgs/tools/graphics/appleseed/default.nix
@@ -1,5 +1,5 @@
 { stdenv, fetchFromGitHub, cmake, boost165, pkgconfig, guile,
-eigen3_3, libpng, python, libGLU, qt4, openexr, openimageio,
+eigen, libpng, python, libGLU, qt4, openexr, openimageio,
 opencolorio, xercesc, ilmbase, osl, seexpr
 }:
 
@@ -19,7 +19,7 @@ in stdenv.mkDerivation rec {
     sha256 = "0m7zvfkdjfn48zzaxh2wa1bsaj4l876a05bzgmjlfq5dz3202anr";
   };
   buildInputs = [
-    cmake pkgconfig boost_static guile eigen3_3 libpng python
+    cmake pkgconfig boost_static guile eigen libpng python
     libGLU qt4 openexr openimageio opencolorio xercesc
     osl seexpr
   ];
diff --git a/pkgs/tools/inputmethods/fusuma/Gemfile b/pkgs/tools/inputmethods/fusuma/Gemfile
new file mode 100644
index 000000000000..9aa2c3ac71a8
--- /dev/null
+++ b/pkgs/tools/inputmethods/fusuma/Gemfile
@@ -0,0 +1,2 @@
+source 'https://rubygems.org'
+gem "fusuma"
diff --git a/pkgs/tools/inputmethods/fusuma/Gemfile.lock b/pkgs/tools/inputmethods/fusuma/Gemfile.lock
new file mode 100644
index 000000000000..4038b50b44fe
--- /dev/null
+++ b/pkgs/tools/inputmethods/fusuma/Gemfile.lock
@@ -0,0 +1,13 @@
+GEM
+  remote: https://rubygems.org/
+  specs:
+    fusuma (0.10.2)
+
+PLATFORMS
+  ruby
+
+DEPENDENCIES
+  fusuma
+
+BUNDLED WITH
+   1.16.3
diff --git a/pkgs/tools/inputmethods/fusuma/default.nix b/pkgs/tools/inputmethods/fusuma/default.nix
new file mode 100644
index 000000000000..2630ab0fc81f
--- /dev/null
+++ b/pkgs/tools/inputmethods/fusuma/default.nix
@@ -0,0 +1,22 @@
+{ lib, bundlerApp, makeWrapper, libinput }:
+
+bundlerApp {
+  pname = "fusuma";
+  gemdir = ./.;
+  exes = [ "fusuma" ];
+
+  buildInputs = [ makeWrapper ];
+
+  postBuild = ''
+    wrapProgram "$out/bin/fusuma" \
+      --prefix PATH : ${lib.makeBinPath [ libinput ]}
+  '';
+
+  meta = with lib; {
+    description = "Multitouch gestures with libinput driver on X11, Linux";
+    homepage    = https://github.com/iberianpig/fusuma;
+    license     = licenses.mit;
+    maintainers = with maintainers; [ jfrankenau ];
+    platforms   = platforms.linux;
+  };
+}
diff --git a/pkgs/tools/inputmethods/fusuma/gemset.nix b/pkgs/tools/inputmethods/fusuma/gemset.nix
new file mode 100644
index 000000000000..2edf9c0886f0
--- /dev/null
+++ b/pkgs/tools/inputmethods/fusuma/gemset.nix
@@ -0,0 +1,10 @@
+{
+  fusuma = {
+    source = {
+      remotes = ["https://rubygems.org"];
+      sha256 = "0hj64kafxj29gk53vj2syhs3vdywl3h9cpiknaqqm4srjx9g04a0";
+      type = "gem";
+    };
+    version = "0.10.2";
+  };
+}
\ No newline at end of file
diff --git a/pkgs/tools/misc/doitlive/default.nix b/pkgs/tools/misc/doitlive/default.nix
index d322a19c98a3..f18874e4f44a 100644
--- a/pkgs/tools/misc/doitlive/default.nix
+++ b/pkgs/tools/misc/doitlive/default.nix
@@ -2,11 +2,11 @@
 
 python3Packages.buildPythonApplication rec {
   pname = "doitlive";
-  version = "4.1.0";
+  version = "4.2.0";
 
   src = python3Packages.fetchPypi {
     inherit pname version;
-    sha256 = "0zkvmnv6adz0gyqiql8anpxnh8zzpqk0p2n0pf2kxy55010qs4wz";
+    sha256 = "0yabw2gqsjdivivlwsc2q7p3qq72cccx3xzfc1a4gd8d74f84nrw";
   };
 
   propagatedBuildInputs = with python3Packages; [ click click-completion click-didyoumean ];
diff --git a/pkgs/tools/networking/amass/default.nix b/pkgs/tools/networking/amass/default.nix
new file mode 100644
index 000000000000..adb43c4aa086
--- /dev/null
+++ b/pkgs/tools/networking/amass/default.nix
@@ -0,0 +1,42 @@
+{ buildGoPackage
+, fetchFromGitHub
+, lib
+}:
+
+buildGoPackage rec {
+  name = "amass-${version}";
+  version = "2.8.3";
+
+  goPackagePath = "github.com/OWASP/Amass";
+
+  src = fetchFromGitHub {
+    owner = "OWASP";
+    repo = "Amass";
+    rev = version;
+    sha256 = "1pidi7bpg5z04l6ryfd7rqxshayvkqmgav0f6f1fxz4jwrmx9nnc";
+  };
+
+  # NOTE: this must be removed once amass > 2.8.3 is released. This version has
+  # a broken import caused by the project migrating to a new home.
+  preBuild = ''
+    sed -e 's:github.com/caffix/amass/amass/core:github.com/OWASP/Amass/amass/core:g' -i "go/src/${goPackagePath}/cmd/amass.netdomains/main.go"
+  '';
+
+  goDeps = ./deps.nix;
+
+  meta = with lib; {
+    description = "In-Depth DNS Enumeration and Network Mapping";
+    longDescription = ''
+      The OWASP Amass tool suite obtains subdomain names by scraping data
+      sources, recursive brute forcing, crawling web archives,
+      permuting/altering names and reverse DNS sweeping. Additionally, Amass
+      uses the IP addresses obtained during resolution to discover associated
+      netblocks and ASNs. All the information is then used to build maps of the
+      target networks.
+      '';
+    homepage = https://www.owasp.org/index.php/OWASP_Amass_Project;
+    license = licenses.asl20;
+    maintainers = with maintainers; [ kalbasit ];
+    platforms = platforms.linux ++ platforms.darwin;
+  };
+}
diff --git a/pkgs/tools/networking/amass/deps.nix b/pkgs/tools/networking/amass/deps.nix
new file mode 100644
index 000000000000..711d64fd313e
--- /dev/null
+++ b/pkgs/tools/networking/amass/deps.nix
@@ -0,0 +1,101 @@
+[
+  {
+    goPackagePath = "github.com/PuerkitoBio/fetchbot";
+    fetch = {
+      type = "git";
+      url = "https://github.com/PuerkitoBio/fetchbot";
+      rev = "1f502d610659b899a007858812b601e715f531eb";
+      sha256 = "0yzv0xh3cwq87jv9whs5rmhaj8b2nqdm76vwppzn8mm34fg41n8s";
+    };
+  }
+  {
+    goPackagePath = "github.com/PuerkitoBio/goquery";
+    fetch = {
+      type = "git";
+      url = "https://github.com/PuerkitoBio/goquery";
+      rev = "2d2796f41742ece03e8086188fa4db16a3a0b458";
+      sha256 = "1fqf4rs66wy02nxz6w4mvs2qawf2j8srz17i294v64y8gvxisp56";
+    };
+  }
+  {
+    goPackagePath = "github.com/andybalholm/cascadia";
+    fetch = {
+      type = "git";
+      url = "https://github.com/andybalholm/cascadia";
+      rev = "680b6a57bda4f657485ad44bdea42342ead737bc";
+      sha256 = "0v95plagirbjlc4p00y9brhpvv4nm8q0gr63gcfs3shyh1a8xwbm";
+    };
+  }
+  {
+    goPackagePath = "github.com/asaskevich/EventBus";
+    fetch = {
+      type = "git";
+      url = "https://github.com/asaskevich/EventBus";
+      rev = "d46933a94f05c6657d7b923fcf5ac563ee37ec79";
+      sha256 = "130mjlsc6jf17zdx8ymhxis70a13l2zbjmjzgvjdr6pb0jzxsqha";
+    };
+  }
+  {
+    goPackagePath = "github.com/fatih/color";
+    fetch = {
+      type = "git";
+      url = "https://github.com/fatih/color";
+      rev = "3f9d52f7176a6927daacff70a3e8d1dc2025c53e";
+      sha256 = "165ww24x6ba47ji4j14mp3f006ksnmi53ws9280pgd2zcw91nbn8";
+    };
+  }
+  {
+    goPackagePath = "github.com/irfansharif/cfilter";
+    fetch = {
+      type = "git";
+      url = "https://github.com/irfansharif/cfilter";
+      rev = "d07d951ff29d52840ca5e798a17e80db4de8c820";
+      sha256 = "11gicb8jbpnsc7wylv7qs9dgc91qc3rld6ahsylb491knxr78yb2";
+    };
+  }
+  {
+    goPackagePath = "github.com/johnnadratowski/golang-neo4j-bolt-driver";
+    fetch = {
+      type = "git";
+      url = "https://github.com/johnnadratowski/golang-neo4j-bolt-driver";
+      rev = "6b24c0085aaeaf3b2844acd18066864e24b57387";
+      sha256 = "0dmfgy0ci0k0s4hxp9v5j4j0mab5x1nsc83icgq9ldb2446mn0fk";
+    };
+  }
+  {
+    goPackagePath = "github.com/miekg/dns";
+    fetch = {
+      type = "git";
+      url = "https://github.com/miekg/dns";
+      rev = "1c9c9bf4c93ee029810272d3e5b8a126aee5bf1f";
+      sha256 = "002z8l5crsipdn2zkavjkjzxrj6c4132yqgbg1zk7w7gkv40q7wr";
+    };
+  }
+  {
+    goPackagePath = "github.com/temoto/robotstxt-go";
+    fetch = {
+      type = "git";
+      url = "https://github.com/temoto/robotstxt-go";
+      rev = "97ee4a9ee6ea01ed0bbf0325dd789f74cac6cb94";
+      sha256 = "1nfnwz5lm9dgicsjh99gs4gh4gbrxdl16srz505f04mab51kd51r";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/net";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/net";
+      rev = "adae6a3d119ae4890b46832a2e88a95adc62b8e7";
+      sha256 = "1fx860zsgzqk28j7lmp96qsfrgb0kzbfjvr294hywswcbwdwkb01";
+    };
+  }
+  {
+    goPackagePath = "golang.org/x/sys";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/sys";
+      rev = "93218def8b18e66adbdab3eca8ec334700329f1f";
+      sha256 = "0v0zdnsi0vw03dcfir7b228g02ag7jr7mgbgv6lnjwbbccxv07pz";
+    };
+  }
+]
diff --git a/pkgs/tools/networking/curl/7_59.nix b/pkgs/tools/networking/curl/7_59.nix
index 508b357e3fde..272c38a99586 100644
--- a/pkgs/tools/networking/curl/7_59.nix
+++ b/pkgs/tools/networking/curl/7_59.nix
@@ -2,11 +2,11 @@
 , http2Support ? true, nghttp2
 , idnSupport ? false, libidn ? null
 , ldapSupport ? false, openldap ? null
-, zlibSupport ? false, zlib ? null
-, sslSupport ? false, openssl ? null
+, zlibSupport ? true, zlib ? null
+, sslSupport ? zlibSupport, openssl ? null
 , gnutlsSupport ? false, gnutls ? null
-, scpSupport ? false, libssh2 ? null
-, gssSupport ? false, kerberos ? null
+, scpSupport ? zlibSupport && !stdenv.isSunOS && !stdenv.isCygwin, libssh2 ? null
+, gssSupport ? !stdenv.hostPlatform.isWindows, libkrb5 ? null
 , c-aresSupport ? false, c-ares ? null
 , brotliSupport ? false, brotli ? null
 }:
@@ -21,7 +21,7 @@ assert gnutlsSupport -> gnutls != null;
 assert scpSupport -> libssh2 != null;
 assert c-aresSupport -> c-ares != null;
 assert brotliSupport -> brotli != null;
-assert gssSupport -> kerberos != null;
+assert gssSupport -> libkrb5 != null;
 
 stdenv.mkDerivation rec {
   name = "curl-7.59.0";
@@ -49,7 +49,7 @@ stdenv.mkDerivation rec {
     optional idnSupport libidn ++
     optional ldapSupport openldap ++
     optional zlibSupport zlib ++
-    optional gssSupport kerberos ++
+    optional gssSupport libkrb5 ++
     optional c-aresSupport c-ares ++
     optional sslSupport openssl ++
     optional gnutlsSupport gnutls ++
@@ -74,7 +74,7 @@ stdenv.mkDerivation rec {
       ( if brotliSupport then "--with-brotli" else "--without-brotli" )
     ]
     ++ stdenv.lib.optional c-aresSupport "--enable-ares=${c-ares}"
-    ++ stdenv.lib.optional gssSupport "--with-gssapi=${kerberos.dev}"
+    ++ stdenv.lib.optional gssSupport "--with-gssapi=${libkrb5.dev}"
        # For the 'urandom', maybe it should be a cross-system option
     ++ stdenv.lib.optional (stdenv.hostPlatform != stdenv.buildPlatform)
        "--with-random=/dev/urandom"
diff --git a/pkgs/tools/networking/curl/default.nix b/pkgs/tools/networking/curl/default.nix
index c362f9fcf2e4..dac92f98223c 100644
--- a/pkgs/tools/networking/curl/default.nix
+++ b/pkgs/tools/networking/curl/default.nix
@@ -2,11 +2,11 @@
 , http2Support ? true, nghttp2
 , idnSupport ? false, libidn ? null
 , ldapSupport ? false, openldap ? null
-, zlibSupport ? false, zlib ? null
-, sslSupport ? false, openssl ? null
+, zlibSupport ? true, zlib ? null
+, sslSupport ? zlibSupport, openssl ? null
 , gnutlsSupport ? false, gnutls ? null
-, scpSupport ? false, libssh2 ? null
-, gssSupport ? false, kerberos ? null
+, scpSupport ? zlibSupport && !stdenv.isSunOS && !stdenv.isCygwin, libssh2 ? null
+, gssSupport ? !stdenv.hostPlatform.isWindows, libkrb5 ? null
 , c-aresSupport ? false, c-ares ? null
 , brotliSupport ? false, brotli ? null
 }:
@@ -21,7 +21,7 @@ assert gnutlsSupport -> gnutls != null;
 assert scpSupport -> libssh2 != null;
 assert c-aresSupport -> c-ares != null;
 assert brotliSupport -> brotli != null;
-assert gssSupport -> kerberos != null;
+assert gssSupport -> libkrb5 != null;
 
 stdenv.mkDerivation rec {
   name = "curl-7.62.0";
@@ -49,7 +49,7 @@ stdenv.mkDerivation rec {
     optional idnSupport libidn ++
     optional ldapSupport openldap ++
     optional zlibSupport zlib ++
-    optional gssSupport kerberos ++
+    optional gssSupport libkrb5 ++
     optional c-aresSupport c-ares ++
     optional sslSupport openssl ++
     optional gnutlsSupport gnutls ++
@@ -78,7 +78,7 @@ stdenv.mkDerivation rec {
       ( if brotliSupport then "--with-brotli" else "--without-brotli" )
     ]
     ++ stdenv.lib.optional c-aresSupport "--enable-ares=${c-ares}"
-    ++ stdenv.lib.optional gssSupport "--with-gssapi=${kerberos.dev}"
+    ++ stdenv.lib.optional gssSupport "--with-gssapi=${libkrb5.dev}"
        # For the 'urandom', maybe it should be a cross-system option
     ++ stdenv.lib.optional (stdenv.hostPlatform != stdenv.buildPlatform)
        "--with-random=/dev/urandom"
diff --git a/pkgs/tools/networking/tcpreplay/default.nix b/pkgs/tools/networking/tcpreplay/default.nix
index 11500a51d92a..23f061445021 100644
--- a/pkgs/tools/networking/tcpreplay/default.nix
+++ b/pkgs/tools/networking/tcpreplay/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   name = "tcpreplay-${version}";
-  version = "4.2.6";
+  version = "4.3.0";
 
   src = fetchurl {
     url = "https://github.com/appneta/tcpreplay/releases/download/v${version}/tcpreplay-${version}.tar.gz";
-    sha256 = "07aklkc1s13hwrd098bqj8izfh8kdgs7wl9swcmkxffs6b2mcdq4";
+    sha256 = "17y7ga2r9pc0xi2lwg82r4xlmhg5gdn5n1ddlpazzw59hda9yp4k";
   };
 
   buildInputs = [ libpcap ];
diff --git a/pkgs/tools/networking/twa/default.nix b/pkgs/tools/networking/twa/default.nix
index 7d2e17af3880..8f462dc41b49 100644
--- a/pkgs/tools/networking/twa/default.nix
+++ b/pkgs/tools/networking/twa/default.nix
@@ -12,13 +12,13 @@
 
 stdenv.mkDerivation rec {
   name = "twa-${version}";
-  version = "1.6.0";
+  version = "1.6.2";
 
   src = fetchFromGitHub {
     owner = "trailofbits";
     repo = "twa";
     rev = version;
-    sha256 = "19jn4wp4f0vp2bxvrbyhjrwqgbphr5y1l17qawy8vdv3yswbyw46";
+    sha256 = "0b3wg6ia4dbf47baz3c6jinsi31n8iq7jrlsq86jr2ncggq7hlhj";
   };
 
   dontBuild = true;
diff --git a/pkgs/tools/package-management/morph/default.nix b/pkgs/tools/package-management/morph/default.nix
new file mode 100644
index 000000000000..27dbad884132
--- /dev/null
+++ b/pkgs/tools/package-management/morph/default.nix
@@ -0,0 +1,37 @@
+{ buildGoPackage, fetchFromGitHub, go-bindata, lib }:
+
+buildGoPackage rec {
+  name = "morph-${version}";
+  version = "1.1.0";
+
+  src = fetchFromGitHub {
+    owner = "dbcdk";
+    repo = "morph";
+    rev = "v${version}";
+    sha256 = "0pixm48is9if9d2b4qc5mwwa4lzma6snkib6z2a1d4pmdx1lmpmm";
+  };
+
+  goPackagePath = "github.com/dbcdk/morph";
+  goDeps = ./deps.nix;
+
+  buildInputs = [ go-bindata ];
+
+  prePatch = ''
+    go-bindata -pkg assets -o assets/assets.go data/
+  '';
+
+  postInstall = ''
+    mkdir -p $lib
+    cp -v $src/data/*.nix $lib
+  '';
+
+  outputs = [ "out" "bin" "lib" ];
+
+  meta = with lib; {
+    description = "Morph is a NixOS host manager written in Golang.";
+    license = licenses.mit;
+    homepage = "https://github.com/dbcdk/morph";
+    maintainers = with maintainers; [adamt johanot];
+    platforms = platforms.unix;
+  };
+}
diff --git a/pkgs/tools/package-management/morph/deps.nix b/pkgs/tools/package-management/morph/deps.nix
new file mode 100644
index 000000000000..fdae5ef39ee2
--- /dev/null
+++ b/pkgs/tools/package-management/morph/deps.nix
@@ -0,0 +1,66 @@
+# file generated from Gopkg.lock using dep2nix (https://github.com/nixcloud/dep2nix)
+[
+  {
+    goPackagePath  = "github.com/dbcdk/kingpin";
+    fetch = {
+      type = "git";
+      url = "https://github.com/dbcdk/kingpin";
+      rev =  "8554767bc91254c59c7297a99e9867c770e4eadb";
+      sha256 = "05hfpgylv5mfnjz2mdd3jl8p3psmczvdbs4ydf9xvvc17c9mlrpq";
+    };
+  }
+  {
+    goPackagePath  = "github.com/alecthomas/template";
+    fetch = {
+      type = "git";
+      url = "https://github.com/alecthomas/template";
+      rev =  "a0175ee3bccc567396460bf5acd36800cb10c49c";
+      sha256 = "0qjgvvh26vk1cyfq9fadyhfgdj36f1iapbmr5xp6zqipldz8ffxj";
+    };
+  }
+  {
+    goPackagePath  = "github.com/alecthomas/units";
+    fetch = {
+      type = "git";
+      url = "https://github.com/alecthomas/units";
+      rev =  "2efee857e7cfd4f3d0138cc3cbb1b4966962b93a";
+      sha256 = "1j65b91qb9sbrml9cpabfrcf07wmgzzghrl7809hjjhrmbzri5bl";
+    };
+  }
+  {
+    goPackagePath  = "github.com/gobwas/glob";
+    fetch = {
+      type = "git";
+      url = "https://github.com/gobwas/glob";
+      rev =  "5ccd90ef52e1e632236f7326478d4faa74f99438";
+      sha256 = "0jxk1x806zn5x86342s72dq2qy64ksb3zrvrlgir2avjhwb18n6z";
+    };
+  }
+  {
+    goPackagePath  = "golang.org/x/crypto";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/crypto";
+      rev =  "0e37d006457bf46f9e6692014ba72ef82c33022c";
+      sha256 = "1fj8rvrhgv5j8pmckzphvm3sqkzhcqp3idkxvgv13qrjdfycsa5r";
+    };
+  }
+  {
+    goPackagePath  = "golang.org/x/sys";
+    fetch = {
+      type = "git";
+      url = "https://go.googlesource.com/sys";
+      rev =  "ee1b12c67af419cf5a9be3bdbeea7fc1c5f32f11";
+      sha256 = "0cgp0xzbhg3fr77n2qrfmmsvhc287srnwi4mghwcjdxp6rx0s988";
+    };
+  }
+  {
+    goPackagePath  = "gopkg.in/mattes/go-expand-tilde.v1";
+    fetch = {
+      type = "git";
+      url = "https://github.com/mattes/go-expand-tilde";
+      rev =  "cb884138e64c9a8bf5c7d6106d74b0fca082df0c";
+      sha256 = "06xrp05njwam4sn031fkmd4gym5wfsw5q0v24nqhs4883lsx9dwq";
+    };
+  }
+]
diff --git a/pkgs/tools/security/hashcat/default.nix b/pkgs/tools/security/hashcat/default.nix
index 9bac2d6c8035..68866a8cad4f 100644
--- a/pkgs/tools/security/hashcat/default.nix
+++ b/pkgs/tools/security/hashcat/default.nix
@@ -1,16 +1,17 @@
-{ stdenv, fetchurl, makeWrapper, opencl-headers, ocl-icd }:
+{ stdenv, fetchurl, makeWrapper, opencl-headers, ocl-icd, xxHash }:
 
 stdenv.mkDerivation rec {
   name    = "hashcat-${version}";
-  version = "4.2.1";
+  version = "5.0.0";
 
   src = fetchurl {
     url = "https://hashcat.net/files/hashcat-${version}.tar.gz";
-    sha256 = "082k5srjwkfvnvz0bfcg5r12m9c2qjyfhnp135mparkf831p7bbx";
+    sha256 = "13xh1lmzdppvx8wr8blqhdr8vpa24j099kz2xzb9pcnqy26dk4kh";
   };
+  patches = [ ./use-installed-xxhash.patch ];
 
   nativeBuildInputs = [ makeWrapper ];
-  buildInputs = [ opencl-headers ];
+  buildInputs = [ opencl-headers xxHash ];
 
   makeFlags = [
     "OPENCL_HEADERS_KHRONOS=${opencl-headers}/include"
diff --git a/pkgs/tools/security/hashcat/use-installed-xxhash.patch b/pkgs/tools/security/hashcat/use-installed-xxhash.patch
new file mode 100644
index 000000000000..d02303558ebb
--- /dev/null
+++ b/pkgs/tools/security/hashcat/use-installed-xxhash.patch
@@ -0,0 +1,22 @@
+diff --git a/src/Makefile b/src/Makefile
+index 3a1cd680..576353fe 100644
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -189,7 +189,7 @@ endif
+ # brain and xxHash
+ ifeq ($(ENABLE_BRAIN),1)
+ CFLAGS                  += -DWITH_BRAIN
+-CFLAGS                  += -Ideps/git/xxHash
++LFLAGS                  += -lxxhash
+ endif
+ 
+ ##
+@@ -313,7 +313,7 @@ WIN_32_OBJS             := $(foreach OBJ,$(OBJS_ALL),obj/$(OBJ).WIN.32.o)
+ WIN_64_OBJS             := $(foreach OBJ,$(OBJS_ALL),obj/$(OBJ).WIN.64.o)
+ 
+ ifeq ($(ENABLE_BRAIN),1)
+-OBJS_XXHASH             := xxhash
++OBJS_XXHASH             :=
+ 
+ NATIVE_STATIC_OBJS      += $(foreach OBJ,$(OBJS_XXHASH),obj/$(OBJ).NATIVE.STATIC.o)
+ NATIVE_SHARED_OBJS      += $(foreach OBJ,$(OBJS_XXHASH),obj/$(OBJ).NATIVE.SHARED.o)
diff --git a/pkgs/tools/security/shc/default.nix b/pkgs/tools/security/shc/default.nix
index 9c7b24be69c9..c32addd8ffcc 100644
--- a/pkgs/tools/security/shc/default.nix
+++ b/pkgs/tools/security/shc/default.nix
@@ -2,18 +2,18 @@
 
 stdenv.mkDerivation rec {
   name = "shc-${version}";
-  version = "3.9.6";
+  version = "4.0.0";
   rev = "${version}";
 
   src = fetchFromGitHub {
     inherit rev;
     owner = "neurobin";
     repo = "shc";
-    sha256 = "07l6m24ivjnvbglxkx9mvarpzc453qrlq5ybkyz7jdilh481aj33";
+    sha256 = "1ghvggrygvs1nxjbmq4pqskfr3mzjhcprql9qfkyhz6ii6si75v8";
   };
 
   meta = with stdenv.lib; {
-    homepage = http://neurobin.github.io/shc;
+    homepage = https://neurobin.org/projects/softwares/unix/shc/;
     description = "Shell Script Compiler";
     platforms = stdenv.lib.platforms.linux;
     license = licenses.gpl3;
diff --git a/pkgs/tools/system/datefudge/default.nix b/pkgs/tools/system/datefudge/default.nix
index 2c2d778697a4..ca389a8e1b48 100644
--- a/pkgs/tools/system/datefudge/default.nix
+++ b/pkgs/tools/system/datefudge/default.nix
@@ -6,9 +6,9 @@ stdenv.mkDerivation rec {
   name = "${pname}-${version}";
 
   src = fetchgit {
-    sha256 = "1fmd05r00wx4zc90lbi804jl7xwdl11jq2a1kp5lqimk3yyvfw4c";
-    url = "git://anonscm.debian.org/users/robert/datefudge.git";
+    url = "https://salsa.debian.org/debian/datefudge.git";
     rev = "fe27db47a0f250fb56164114fff8ae8d5af47ab6";
+    sha256 = "1fmd05r00wx4zc90lbi804jl7xwdl11jq2a1kp5lqimk3yyvfw4c";
   };
 
   patchPhase = ''
diff --git a/pkgs/tools/system/sleuthkit/default.nix b/pkgs/tools/system/sleuthkit/default.nix
index 23696651a634..a7d749204b7a 100644
--- a/pkgs/tools/system/sleuthkit/default.nix
+++ b/pkgs/tools/system/sleuthkit/default.nix
@@ -1,14 +1,14 @@
 { stdenv, fetchFromGitHub, autoreconfHook, libewf, afflib, openssl, zlib }:
 
 stdenv.mkDerivation rec {
-  version = "4.6.3";
+  version = "4.6.4";
   name = "sleuthkit-${version}";
 
   src = fetchFromGitHub {
     owner = "sleuthkit";
     repo = "sleuthkit";
     rev = name;
-    sha256 = "1qaggb8day6idbafncslyaz7a475sq6p0xnjwc4c99f0z7i9cahp";
+    sha256 = "0c6cglc4877pw6069ph72s3rv6747ps4vzhs6l2qxxncsrdlbzv0";
   };
 
   postPatch = ''
diff --git a/pkgs/tools/system/tree/default.nix b/pkgs/tools/system/tree/default.nix
index e34bd5f8e133..d798c98679c5 100644
--- a/pkgs/tools/system/tree/default.nix
+++ b/pkgs/tools/system/tree/default.nix
@@ -1,7 +1,7 @@
 { stdenv, fetchurl }:
 
 let
-  version = "1.7.0";
+  version = "1.8.0";
 
   # These settings are found in the Makefile, but there seems to be no
   # way to select one ore the other setting other than editing the file
@@ -28,7 +28,7 @@ stdenv.mkDerivation {
 
   src = fetchurl {
     url = "http://mama.indstate.edu/users/ice/tree/src/tree-${version}.tgz";
-    sha256 = "04kviw799qxly08zb8n5mgxfd96gyis6x69q2qiw86jnh87c4mv9";
+    sha256 = "1hmpz6k0mr6salv0nprvm1g0rdjva1kx03bdf1scw8a38d5mspbi";
   };
 
   configurePhase = ''
diff --git a/pkgs/tools/typesetting/git-latexdiff/default.nix b/pkgs/tools/typesetting/git-latexdiff/default.nix
index 61c05666726e..a255779c08a3 100644
--- a/pkgs/tools/typesetting/git-latexdiff/default.nix
+++ b/pkgs/tools/typesetting/git-latexdiff/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchFromGitLab, git, bash }:
 
 stdenv.mkDerivation rec {
-  version = "1.1.2";
+  version = "1.3.0";
   name = "git-latexdiff-${version}";
 
   src = fetchFromGitLab {
-    sha256 = "1alnrjcf3f1qv7fk8h9yachmdz7mjgcynlgsvchfgcb2cpdavxjg";
+    sha256 = "05fnhr1pqvj8l25vi9hdccwfk4mv2f0pfhn05whbdvf66gyl4fs9";
     rev = "v${version}";
     repo = "git-latexdiff";
     owner = "git-latexdiff";
@@ -15,11 +15,12 @@ stdenv.mkDerivation rec {
 
   dontBuild = true;
 
-  patches = [ ./shebang.patch ./version-test.patch ];
+  patches = [ ./version-test.patch ];
 
   postPatch = ''
     substituteInPlace git-latexdiff \
       --replace "@GIT_LATEXDIFF_VERSION@" "v${version}"
+    patchShebangs git-latexdiff
   '';
 
   installPhase = ''
@@ -30,8 +31,9 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "View diff on LaTeX source files on the generated PDF files";
+    homepage = https://gitlab.com/git-latexdiff/git-latexdiff;
     maintainers = [ ];
-    license = licenses.free; # https://gitlab.com/git-latexdiff/git-latexdiff/issues/9
+    license = licenses.bsd3; # https://gitlab.com/git-latexdiff/git-latexdiff/issues/9
     platforms = platforms.unix;
   };
 }
diff --git a/pkgs/tools/typesetting/git-latexdiff/shebang.patch b/pkgs/tools/typesetting/git-latexdiff/shebang.patch
deleted file mode 100644
index 1d6d27c6e310..000000000000
--- a/pkgs/tools/typesetting/git-latexdiff/shebang.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Fix for https://gitlab.com/git-latexdiff/git-latexdiff/issues/8
----
---- src/git-latexdiff	2016-01-26 14:04:54.338568955 +0100
-+++ src/git-latexdiff	2016-01-26 14:40:23.700381943 +0100
-@@ -1,4 +1,4 @@
--#! /bin/bash
-+#!/usr/bin/env bash
- 
- # Main author: Matthieu Moy <Matthieu.Moy@imag.fr> (2012 - 2015)
- # (See the Git history for other contributors)
diff --git a/pkgs/tools/typesetting/git-latexdiff/version-test.patch b/pkgs/tools/typesetting/git-latexdiff/version-test.patch
index e116bbd2c24d..243bd90f9005 100644
--- a/pkgs/tools/typesetting/git-latexdiff/version-test.patch
+++ b/pkgs/tools/typesetting/git-latexdiff/version-test.patch
@@ -4,14 +4,14 @@ Fix for https://gitlab.com/git-latexdiff/git-latexdiff/issues/7
 +++ src/git-latexdiff	2016-01-26 14:40:23.700381943 +0100
 @@ -44,11 +44,7 @@
  git_latexdiff_version='@GIT_LATEXDIFF_VERSION@'
- 
+
  git_latexdiff_compute_version () {
--    if [ "$git_latexdiff_version" = '@GIT_LATEXDIFF_VERSION@' ]; then
+-    if [ "$git_latexdiff_version" = '@GIT_LATEXDIFF''_VERSION@' ]; then
 -	(cd "$(dirname "$0")" && git describe --tags HEAD 2>/dev/null || echo 'Unknown version')
 -    else
 -	echo "$git_latexdiff_version"
 -    fi
 +    echo "$git_latexdiff_version"
  }
- 
+
  usage () {