about summary refs log tree commit diff
path: root/pkgs/tools
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/tools')
-rw-r--r--pkgs/tools/misc/findutils/default.nix10
-rw-r--r--pkgs/tools/text/gnupatch/default.nix24
-rw-r--r--pkgs/tools/text/gnused/default.nix6
3 files changed, 18 insertions, 22 deletions
diff --git a/pkgs/tools/misc/findutils/default.nix b/pkgs/tools/misc/findutils/default.nix
index 80f5fbfc5d70..e9d707d74c7b 100644
--- a/pkgs/tools/misc/findutils/default.nix
+++ b/pkgs/tools/misc/findutils/default.nix
@@ -1,14 +1,14 @@
 {stdenv, fetchurl, coreutils}:
 
 stdenv.mkDerivation {
-  name = "findutils-4.2.27";
+  name = "findutils-4.2.28";
   src = fetchurl {
-    url = http://nix.cs.uu.nl/dist/tarballs/findutils-4.2.27.tar.gz;
-    md5 = "f1e0ddf09f28f8102ff3b90f3b5bc920";
+    url = http://ftp.gnu.org/pub/gnu/findutils/findutils-4.2.28.tar.gz;
+    md5 = "f5fb3349354ee3d94fceb81dab5c71fd";
   };
   buildInputs = [coreutils];
   patches = [./findutils-path.patch]
-    # Note: the dietlibc is just to get findutils to compile.  The
-    # locate command probably won't work though.
+    # Note: the dietlibc patch is just to get findutils to compile.
+    # The locate command probably won't work though.
     ++ (if stdenv ? isDietLibC then [./dietlibc-hack.patch] else []);
 }
diff --git a/pkgs/tools/text/gnupatch/default.nix b/pkgs/tools/text/gnupatch/default.nix
index b4f702fdf3c2..3206e1023fb3 100644
--- a/pkgs/tools/text/gnupatch/default.nix
+++ b/pkgs/tools/text/gnupatch/default.nix
@@ -1,19 +1,15 @@
-{stdenv, fetchurl}: stdenv.mkDerivation ({
+{stdenv, fetchurl}:
+
+stdenv.mkDerivation {
   name = "gnupatch-2.5.4";
   src = fetchurl {
     url = http://nix.cs.uu.nl/dist/tarballs/patch-2.5.4.tar.gz;
     md5 = "ee5ae84d115f051d87fcaaef3b4ae782";
   };
-} // 
-  # !!! hack
-  (if stdenv.system != "i686-linux" then {
-    patches = [./setmode.patch];
-    configureFlags = "dummy"; # doesn't build on Darwin unless a platform is specified
-  } else {})
-  // 
-  # !!! hack
-  (if stdenv ? isDietLibC then {
-    # !!! pass this on all platforms
-    configureFlags = "dummy"; # doesn't build unless a platform is specified
-  } else {})
-)
+
+  # Hack around ancient configure script: doesn't build on many newer
+  # platforms unless a platform is specified.
+  configureFlags = "dummy";
+  
+  patches = if stdenv.isDarwin then [./setmode.patch] else [];
+}
diff --git a/pkgs/tools/text/gnused/default.nix b/pkgs/tools/text/gnused/default.nix
index d560aabfbe0a..9395fcd1a401 100644
--- a/pkgs/tools/text/gnused/default.nix
+++ b/pkgs/tools/text/gnused/default.nix
@@ -1,11 +1,11 @@
 {stdenv, fetchurl}:
 
-stdenv.mkDerivation ({
+stdenv.mkDerivation {
   name = "gnused-4.1.5";
   src = fetchurl {
     url = http://nix.cs.uu.nl/dist/tarballs/sed-4.1.5.tar.gz;
     md5 = "7a1cbbbb3341287308e140bd4834c3ba";
   };
-} // 
   # !!! hack: this should go away in gnused > 4.1.5
-  (if stdenv.system != "i686-linux" then {patches = [./gettext-fix.patch];} else {}))
+  patches = [./gettext-fix.patch];
+}