about summary refs log tree commit diff
path: root/pkgs/test
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/test')
-rwxr-xr-xpkgs/test/simple/builder.sh9
-rw-r--r--pkgs/test/simple/default.nix2
2 files changed, 7 insertions, 4 deletions
diff --git a/pkgs/test/simple/builder.sh b/pkgs/test/simple/builder.sh
index 58bf16c43b34..cfc895ac1392 100755
--- a/pkgs/test/simple/builder.sh
+++ b/pkgs/test/simple/builder.sh
@@ -1,10 +1,15 @@
 #! /bin/sh
 
+set -x
+
 export NIX_DEBUG=1
 
 . $stdenv/setup
 
-export NIX_ENFORCE_PURITY=1
+#echo starting shell
+#/bin/sh < /dev/tty > /dev/tty 2>&1 
+
+#exit 1
 
 mkdir $out
 mkdir $out/bin
@@ -24,8 +29,6 @@ gcc -L /nix/store/abcd/lib -isystem /usr/lib hello.c -o $out/bin/hello
 
 $out/bin/hello
 
-exit 0
-
 cat > hello2.cc <<EOF
 #include <iostream>
 
diff --git a/pkgs/test/simple/default.nix b/pkgs/test/simple/default.nix
index 9374a6ede281..39b0416fc9a1 100644
--- a/pkgs/test/simple/default.nix
+++ b/pkgs/test/simple/default.nix
@@ -6,7 +6,7 @@ let {
     allPackages = import ../../system/all-packages-generic.nix;
   };
 
-  stdenv = stdenvs.stdenvLinuxBoot1;
+  stdenv = stdenvs.stdenvLinuxBoot2;
 
   test = derivation {
     name = "simple-test";