about summary refs log tree commit diff
path: root/pkgs/test/rpath
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/test/rpath')
-rw-r--r--pkgs/test/rpath/builder.sh79
-rw-r--r--pkgs/test/rpath/default.nix18
-rw-r--r--pkgs/test/rpath/src/hello1.c7
-rw-r--r--pkgs/test/rpath/src/hello2.cc7
-rw-r--r--pkgs/test/rpath/src/hello3.c9
-rw-r--r--pkgs/test/rpath/src/text.c4
6 files changed, 0 insertions, 124 deletions
diff --git a/pkgs/test/rpath/builder.sh b/pkgs/test/rpath/builder.sh
deleted file mode 100644
index 2bf624621468..000000000000
--- a/pkgs/test/rpath/builder.sh
+++ /dev/null
@@ -1,79 +0,0 @@
-export NIX_DEBUG=1
-
-source $stdenv/setup
-
-mkdir $out
-mkdir $out/bin
-
-
-# 1: link statically against glibc.
-res=$out/bin/hello1
-gcc -static $src/hello1.c -o $res
-
-case $(ldd $res) in
-  *"not a dynamic executable"*)
-        ;;
-  *)
-        echo "$res not statically linked!"
-        exit 1
-esac
-
-
-# 2: link dynamically against glibc.
-res=$out/bin/hello2
-gcc $src/hello1.c -o $res
-
-case $(ldd $res) in
-  */store/*glibc*/lib/libc.so*/store/*glibc*/lib/ld-linux.so*)
-        ;;
-  *)
-        echo "$res not dynamically linked / bad rpath!"
-        exit 1
-        ;;
-esac
-
-
-# 3: link C++ dynamically against glibc / libstdc++.
-res=$out/bin/hello3
-g++ $src/hello2.cc -o $res
-
-case $(ldd $res) in
-  */store/*gcc*/lib/*libstdc++*/store/*glibc*/lib/libm*/store/*gcc*/lib/libgcc_s*/store/*glibc*/lib/libc.so*/store/*glibc*/lib/ld-linux.so*)
-        ;;
-  *)
-        echo "$res not dynamically linked / bad rpath!"
-        exit 1
-        ;;
-esac
-
-
-# 4: build dynamic library locally, link against it, copy it.
-res=$out/bin/hello4
-mkdir bla
-gcc -shared $src/text.c -o bla/libtext.so 
-gcc $src/hello3.c -o $res -L$(pwd)/bla -ltext
-mkdir $out/lib
-
-case $(ldd $res) in
-  */tmp*)
-        echo "$res depends on file in /tmp!"
-        exit 1
-        ;;
-esac
-
-cp bla/libtext.so $out/lib
-
-case $(ldd $res) in
-  */store/*glibc*/lib/libc.so*/store/*glibc*/lib/ld-linux.so*)
-        ;;
-  *)
-        echo "$res not dynamically linked / bad rpath!"
-        exit 1
-        ;;
-esac
-
-
-# Run the programs we just made.
-for i in $out/bin/*; do
-    $i
-done
diff --git a/pkgs/test/rpath/default.nix b/pkgs/test/rpath/default.nix
deleted file mode 100644
index f0903420c96a..000000000000
--- a/pkgs/test/rpath/default.nix
+++ /dev/null
@@ -1,18 +0,0 @@
-let {
-  system = "i686-linux";
-
-  stdenvs = (import ../../system/stdenvs.nix) {
-    inherit system;
-    allPackages = import ../../system/all-packages-generic.nix;
-  };
-
-  stdenv = stdenvs.stdenvLinuxBoot2;
-
-  test = stdenv.mkDerivation {
-    name = "rpath-test";
-    builder = ./builder.sh;
-    src = ./src;
-  };
-
-  body = test;
-}
diff --git a/pkgs/test/rpath/src/hello1.c b/pkgs/test/rpath/src/hello1.c
deleted file mode 100644
index c44d7c4a936d..000000000000
--- a/pkgs/test/rpath/src/hello1.c
+++ /dev/null
@@ -1,7 +0,0 @@
-#include <stdio.h>
-
-int main(int argc, char * * argv)
-{
-    printf("Hello World!\n");
-    return 0;
-}
diff --git a/pkgs/test/rpath/src/hello2.cc b/pkgs/test/rpath/src/hello2.cc
deleted file mode 100644
index 0dc34766f5f1..000000000000
--- a/pkgs/test/rpath/src/hello2.cc
+++ /dev/null
@@ -1,7 +0,0 @@
-#include <iostream>
-
-int main(int argc, char * * argv)
-{
-    std::cout << "Hello World!\n";
-    return 0;
-}
diff --git a/pkgs/test/rpath/src/hello3.c b/pkgs/test/rpath/src/hello3.c
deleted file mode 100644
index 2b2308360da4..000000000000
--- a/pkgs/test/rpath/src/hello3.c
+++ /dev/null
@@ -1,9 +0,0 @@
-#include <stdio.h>
-
-char * text();
-
-int main(int argc, char * * argv)
-{
-    printf(text());
-    return 0;
-}
diff --git a/pkgs/test/rpath/src/text.c b/pkgs/test/rpath/src/text.c
deleted file mode 100644
index 3d85ca23f795..000000000000
--- a/pkgs/test/rpath/src/text.c
+++ /dev/null
@@ -1,4 +0,0 @@
-char * text()
-{
-    return "Hello World!\n";
-}