about summary refs log tree commit diff
path: root/pkgs/stdenv
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/stdenv')
-rw-r--r--pkgs/stdenv/linux/make-bootstrap-tools-cross.nix16
1 files changed, 16 insertions, 0 deletions
diff --git a/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix b/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix
index 3eb902c890db..1e488601276b 100644
--- a/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix
+++ b/pkgs/stdenv/linux/make-bootstrap-tools-cross.nix
@@ -68,9 +68,24 @@ let
     inherit (gcc) fpu;
   };
 
+  pogoplug4-crossSystem.crossSystem = {
+    arch = "armv5tel";
+    config = "armv5tel-softfloat-linux-gnueabi";
+    float = "soft";
+
+    platform = pkgsNoParams.platforms.pogoplug4;
+
+    inherit (pkgsNoParams.platforms.pogoplug4) gcc;
+    libc = "glibc";
+
+    withTLS = true;
+    openssl.system = "linux-generic32";
+  };
+
   selectedCrossSystem =
     if toolsArch == "armv5tel" then sheevaplugCrossSystem else
     if toolsArch == "scaleway" then scaleway-c1-crossSystem else
+    if toolsArch == "pogoplug4" then pogoplug4-crossSystem else
     if toolsArch == "armv6l" then raspberrypiCrossSystem else
     if toolsArch == "armv7l" then armv7l-hf-multiplatform-crossSystem else
     if toolsArch == "aarch64" then aarch64-multiplatform-crossSystem else null;
@@ -285,4 +300,5 @@ rec {
     armv7l = buildFor "armv7l";
     aarch64 = buildFor "aarch64";
     scaleway = buildFor "scaleway";
+    pogoplug4 = buildFor "pogoplug4";
 }