about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/any-nix-shell/default.nix4
-rw-r--r--pkgs/shells/bash/4.4.nix2
-rw-r--r--pkgs/shells/bash/5.0.nix2
-rw-r--r--pkgs/shells/bash/bash-completion/default.nix2
-rw-r--r--pkgs/shells/dash/default.nix2
-rw-r--r--pkgs/shells/dgsh/default.nix2
-rw-r--r--pkgs/shells/elvish/default.nix2
-rw-r--r--pkgs/shells/es/default.nix2
-rw-r--r--pkgs/shells/fish/default.nix2
-rw-r--r--pkgs/shells/jush/default.nix2
-rw-r--r--pkgs/shells/ksh/default.nix2
-rw-r--r--pkgs/shells/liquidprompt/default.nix2
-rw-r--r--pkgs/shells/mksh/default.nix2
-rw-r--r--pkgs/shells/pash/default.nix2
-rw-r--r--pkgs/shells/rc/default.nix2
-rw-r--r--pkgs/shells/rssh/default.nix18
-rw-r--r--pkgs/shells/rush/default.nix2
-rw-r--r--pkgs/shells/zsh/antigen/default.nix2
-rw-r--r--pkgs/shells/zsh/default.nix2
-rw-r--r--pkgs/shells/zsh/fzf-zsh/default.nix2
-rw-r--r--pkgs/shells/zsh/gradle-completion/default.nix2
-rw-r--r--pkgs/shells/zsh/grml-zsh-config/default.nix2
-rw-r--r--pkgs/shells/zsh/lambda-mod-zsh-theme/default.nix2
-rw-r--r--pkgs/shells/zsh/nix-zsh-completions/default.nix2
-rw-r--r--pkgs/shells/zsh/oh-my-zsh/default.nix2
-rw-r--r--pkgs/shells/zsh/spaceship-prompt/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-autosuggestions/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-command-time/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-completions/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-history-substring-search/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-history/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-powerlevel9k/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-prezto/default.nix2
-rw-r--r--pkgs/shells/zsh/zsh-you-should-use/default.nix2
34 files changed, 43 insertions, 43 deletions
diff --git a/pkgs/shells/any-nix-shell/default.nix b/pkgs/shells/any-nix-shell/default.nix
index d2b7a4929e1c..bab39aef2441 100644
--- a/pkgs/shells/any-nix-shell/default.nix
+++ b/pkgs/shells/any-nix-shell/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "fish and zsh support for nix-shell";
     license = licenses.mit;
-    homepage = https://github.com/haslersn/any-nix-shell;
+    homepage = "https://github.com/haslersn/any-nix-shell";
     maintainers = with maintainers; [ haslersn ];
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/shells/bash/4.4.nix b/pkgs/shells/bash/4.4.nix
index 7ca57ac01564..4cb3c14a9a0d 100644
--- a/pkgs/shells/bash/4.4.nix
+++ b/pkgs/shells/bash/4.4.nix
@@ -107,7 +107,7 @@ stdenv.mkDerivation rec {
     '';
 
   meta = with stdenv.lib; {
-    homepage = https://www.gnu.org/software/bash/;
+    homepage = "https://www.gnu.org/software/bash/";
     description =
       "GNU Bourne-Again Shell, the de facto standard shell on Linux" +
         (if interactive then " (for interactive use)" else "");
diff --git a/pkgs/shells/bash/5.0.nix b/pkgs/shells/bash/5.0.nix
index 05aaf39b3404..09030493fb60 100644
--- a/pkgs/shells/bash/5.0.nix
+++ b/pkgs/shells/bash/5.0.nix
@@ -98,7 +98,7 @@ stdenv.mkDerivation rec {
     '';
 
   meta = with stdenv.lib; {
-    homepage = https://www.gnu.org/software/bash/;
+    homepage = "https://www.gnu.org/software/bash/";
     description =
       "GNU Bourne-Again Shell, the de facto standard shell on Linux" +
         (if interactive then " (for interactive use)" else "");
diff --git a/pkgs/shells/bash/bash-completion/default.nix b/pkgs/shells/bash/bash-completion/default.nix
index a741633340d6..8efada3413aa 100644
--- a/pkgs/shells/bash/bash-completion/default.nix
+++ b/pkgs/shells/bash/bash-completion/default.nix
@@ -51,7 +51,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    homepage = https://github.com/scop/bash-completion;
+    homepage = "https://github.com/scop/bash-completion";
     description = "Programmable completion for the bash shell";
     license = licenses.gpl2Plus;
     platforms = platforms.unix;
diff --git a/pkgs/shells/dash/default.nix b/pkgs/shells/dash/default.nix
index f8d592748b3f..7aedd0189e44 100644
--- a/pkgs/shells/dash/default.nix
+++ b/pkgs/shells/dash/default.nix
@@ -11,7 +11,7 @@ stdenv.mkDerivation rec {
   hardeningDisable = [ "format" ];
 
   meta = with stdenv.lib; {
-    homepage = http://gondor.apana.org.au/~herbert/dash/;
+    homepage = "http://gondor.apana.org.au/~herbert/dash/";
     description = "A POSIX-compliant implementation of /bin/sh that aims to be as small as possible";
     platforms = platforms.unix;
     license = with licenses; [ bsd3 gpl2 ];
diff --git a/pkgs/shells/dgsh/default.nix b/pkgs/shells/dgsh/default.nix
index e2fd845c286e..0314180e2d55 100644
--- a/pkgs/shells/dgsh/default.nix
+++ b/pkgs/shells/dgsh/default.nix
@@ -37,7 +37,7 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     description = "The Directed Graph Shell";
-    homepage = http://www.dmst.aueb.gr/dds/sw/dgsh;
+    homepage = "http://www.dmst.aueb.gr/dds/sw/dgsh";
     license = with licenses; asl20;
     maintainers = with maintainers; [ vrthra ];
     platforms = with platforms; all;
diff --git a/pkgs/shells/elvish/default.nix b/pkgs/shells/elvish/default.nix
index 402b5a7ebca7..4b9e4817ee8d 100644
--- a/pkgs/shells/elvish/default.nix
+++ b/pkgs/shells/elvish/default.nix
@@ -27,7 +27,7 @@ buildGoModule rec {
       language. It runs on Linux, BSDs, macOS and Windows. Despite its pre-1.0
       status, it is already suitable for most daily interactive use.
     '';
-    homepage = https://elv.sh/;
+    homepage = "https://elv.sh/";
     license = licenses.bsd2;
     maintainers = with maintainers; [ vrthra AndersonTorres ];
     platforms = with platforms; linux ++ darwin;
diff --git a/pkgs/shells/es/default.nix b/pkgs/shells/es/default.nix
index 446f28ba6527..761846843fea 100644
--- a/pkgs/shells/es/default.nix
+++ b/pkgs/shells/es/default.nix
@@ -33,7 +33,7 @@ stdenv.mkDerivation {
         functional programming languages, such as Scheme,
         and the Tcl embeddable programming language.
       '';
-    homepage = http://wryun.github.io/es-shell/;
+    homepage = "http://wryun.github.io/es-shell/";
     license = licenses.publicDomain;
     maintainers = with maintainers; [ sjmackenzie ttuegel ];
     platforms = platforms.all;
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 013cebfd7ec5..0ea8dce44059 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -171,7 +171,7 @@ let
 
     meta = with stdenv.lib; {
       description = "Smart and user-friendly command line shell";
-      homepage = http://fishshell.com/;
+      homepage = "http://fishshell.com/";
       license = licenses.gpl2;
       platforms = platforms.unix;
       maintainers = with maintainers; [ ocharles ];
diff --git a/pkgs/shells/jush/default.nix b/pkgs/shells/jush/default.nix
index 833947a6ddb8..9894c90bb69e 100644
--- a/pkgs/shells/jush/default.nix
+++ b/pkgs/shells/jush/default.nix
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "just a useless shell";
-    homepage = https://github.com/troglobit/jush;
+    homepage = "https://github.com/troglobit/jush";
     license = licenses.isc;
     platforms = platforms.all;
     maintainers = with maintainers; [ dtzWill ];
diff --git a/pkgs/shells/ksh/default.nix b/pkgs/shells/ksh/default.nix
index 108d1a587580..e27732226f55 100644
--- a/pkgs/shells/ksh/default.nix
+++ b/pkgs/shells/ksh/default.nix
@@ -31,7 +31,7 @@ stdenv.mkDerivation rec {
       provides access to the UNIX system and to many other systems, on the
       many different computers and workstations on which it is implemented.
     '';
-    homepage = https://github.com/att/ast;
+    homepage = "https://github.com/att/ast";
     license = licenses.cpl10;
     maintainers = with maintainers; [ ];
     platforms = platforms.all;
diff --git a/pkgs/shells/liquidprompt/default.nix b/pkgs/shells/liquidprompt/default.nix
index 62efabb022ca..d6d655d1f17a 100644
--- a/pkgs/shells/liquidprompt/default.nix
+++ b/pkgs/shells/liquidprompt/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "A full-featured & carefully designed adaptive prompt for Bash & Zsh";
-    homepage = https://github.com/nojhan/liquidprompt;
+    homepage = "https://github.com/nojhan/liquidprompt";
     license = licenses.agpl3;
     platforms = platforms.all;
     maintainers = with maintainers; [ gerschtli ];
diff --git a/pkgs/shells/mksh/default.nix b/pkgs/shells/mksh/default.nix
index 9b48c5c68a1c..d817ade9eb61 100644
--- a/pkgs/shells/mksh/default.nix
+++ b/pkgs/shells/mksh/default.nix
@@ -29,7 +29,7 @@ stdenv.mkDerivation rec {
       also to be readily available under other UNIX(R)-like operating
       systems.
     '';
-    homepage = https://www.mirbsd.org/mksh.htm;
+    homepage = "https://www.mirbsd.org/mksh.htm";
     license = licenses.bsd3;
     maintainers = with maintainers; [ AndersonTorres joachifm ];
     platforms = platforms.unix;
diff --git a/pkgs/shells/pash/default.nix b/pkgs/shells/pash/default.nix
index 8b8601e326cc..c646c1c3f9bd 100644
--- a/pkgs/shells/pash/default.nix
+++ b/pkgs/shells/pash/default.nix
@@ -17,7 +17,7 @@ buildDotnetPackage {
 
   meta = with stdenv.lib; {
     description = "An open source implementation of Windows PowerShell";
-    homepage = https://github.com/Pash-Project/Pash;
+    homepage = "https://github.com/Pash-Project/Pash";
     maintainers = [ maintainers.fornever maintainers.vrthra ];
     platforms = platforms.all;
     license = with licenses; [ bsd3 gpl3 ];
diff --git a/pkgs/shells/rc/default.nix b/pkgs/shells/rc/default.nix
index a8a7d4f6e777..cd5ed860b2e6 100644
--- a/pkgs/shells/rc/default.nix
+++ b/pkgs/shells/rc/default.nix
@@ -34,7 +34,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "The Plan 9 shell";
     longDescription = "Byron Rakitzis' UNIX reimplementation of Tom Duff's Plan 9 shell.";
-    homepage = http://tobold.org/article/rc;
+    homepage = "http://tobold.org/article/rc";
     license = with licenses; zlib;
     maintainers = with maintainers; [ ramkromberg ];
     platforms = with platforms; all;
diff --git a/pkgs/shells/rssh/default.nix b/pkgs/shells/rssh/default.nix
index ecefbff7d22e..b2bec51a95ed 100644
--- a/pkgs/shells/rssh/default.nix
+++ b/pkgs/shells/rssh/default.nix
@@ -18,42 +18,42 @@ stdenv.mkDerivation rec {
 
     # Patches from AUR
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0001-fail-logging.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0001-fail-logging.patch?h=rssh";
       name = "0001-fail-logging.patch";
       sha256 = "d30f2f4fdb1b57f94773f5b0968a4da3356b14a040efe69ec1e976c615035c65";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0002-info-to-debug.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0002-info-to-debug.patch?h=rssh";
       name = "0002-info-to-debug.patch";
       sha256 = "86f6ecf34f62415b0d6204d4cbebc47322dc2ec71732d06aa27758e35d688fcd";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0003-man-page-spelling.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0003-man-page-spelling.patch?h=rssh";
       name = "0003-man-page-spelling.patch";
       sha256 = "455b3bbccddf1493999d00c2cd46e62930ef4fd8211e0b7d3a89d8010d6a5431";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0004-mkchroot.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0004-mkchroot.patch?h=rssh";
       name = "0004-mkchroot.patch";
       sha256 = "f7fd8723d2aa94e64e037c13c2f263a52104af680ab52bfcaea73dfa836457c2";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0005-mkchroot-arch.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0005-mkchroot-arch.patch?h=rssh";
       name = "0005-mkchroot-arch.patch";
       sha256 = "ac8894c4087a063ae8267d2fdfcde69c2fe6b67a8ff5917e4518b8f73f08ba3f";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0006-mkchroot-symlink.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0006-mkchroot-symlink.patch?h=rssh";
       name = "0006-mkchroot-symlink.patch";
       sha256 = "bce98728cb9b55c92182d4901c5f9adf49376a07c5603514b0004e3d1c85e9c7";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0007-destdir.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0007-destdir.patch?h=rssh";
       name = "0007-destdir.patch";
       sha256 = "7fa03644f81dc37d77cc7e2cad994f17f91b2b8a49b1a74e41030a4ac764385e";
     })
     (fetchurl {
-      url = https://aur.archlinux.org/cgit/aur.git/plain/0008-rsync-protocol.patch?h=rssh;
+      url = "https://aur.archlinux.org/cgit/aur.git/plain/0008-rsync-protocol.patch?h=rssh";
       name = "0008-rsync-protocol.patch";
       sha256 = "0c772afe9088eeded129ead86775ef18e58c318bbc58fc3e2585e7ff09cc5e91";
     })
@@ -80,7 +80,7 @@ stdenv.mkDerivation rec {
     longDescription = ''
       rssh also includes support for rsync and cvs. For example, if you have a server which you only want to allow users to copy files off of via scp, without providing shell access, you can use rssh to do that.
     '';
-    homepage = http://www.pizzashack.org/rssh/;
+    homepage = "http://www.pizzashack.org/rssh/";
     license = licenses.bsd2;
     platforms = platforms.linux;
     maintainers = with maintainers; [ arobyn ];
diff --git a/pkgs/shells/rush/default.nix b/pkgs/shells/rush/default.nix
index 9db36bc85fcb..f9e15d4a0b47 100644
--- a/pkgs/shells/rush/default.nix
+++ b/pkgs/shells/rush/default.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
          sftp-server or scp, that lack this ability.
       '';
 
-    homepage = https://www.gnu.org/software/rush/;
+    homepage = "https://www.gnu.org/software/rush/";
     license = stdenv.lib.licenses.gpl3Plus;
 
     maintainers = [ stdenv.lib.maintainers.bjg ];
diff --git a/pkgs/shells/zsh/antigen/default.nix b/pkgs/shells/zsh/antigen/default.nix
index c754d7bbe580..b4812428adff 100644
--- a/pkgs/shells/zsh/antigen/default.nix
+++ b/pkgs/shells/zsh/antigen/default.nix
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     description = "The plugin manager for zsh.";
-    homepage = http://antigen.sharats.me;
+    homepage = "http://antigen.sharats.me";
     license = stdenv.lib.licenses.mit;
   };
 }
diff --git a/pkgs/shells/zsh/default.nix b/pkgs/shells/zsh/default.nix
index 8e050acef1fd..3b346e4e44b2 100644
--- a/pkgs/shells/zsh/default.nix
+++ b/pkgs/shells/zsh/default.nix
@@ -81,7 +81,7 @@ EOF
       a host of other features.
     '';
     license = "MIT-like";
-    homepage = http://www.zsh.org/;
+    homepage = "http://www.zsh.org/";
     maintainers = with stdenv.lib.maintainers; [ pSub ];
     platforms = stdenv.lib.platforms.unix;
   };
diff --git a/pkgs/shells/zsh/fzf-zsh/default.nix b/pkgs/shells/zsh/fzf-zsh/default.nix
index e97ef1074f12..075707f425c4 100644
--- a/pkgs/shells/zsh/fzf-zsh/default.nix
+++ b/pkgs/shells/zsh/fzf-zsh/default.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    homepage = https://github.com/wyntau/fzf-zsh;
+    homepage = "https://github.com/wyntau/fzf-zsh";
     description = "wrap fzf to use in oh-my-zsh";
     license = licenses.mit;
     maintainers = with maintainers; [ ma27 ];
diff --git a/pkgs/shells/zsh/gradle-completion/default.nix b/pkgs/shells/zsh/gradle-completion/default.nix
index d13fd8aee00f..72667d862a89 100644
--- a/pkgs/shells/zsh/gradle-completion/default.nix
+++ b/pkgs/shells/zsh/gradle-completion/default.nix
@@ -28,7 +28,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Gradle tab completion for bash and zsh";
-    homepage = https://github.com/gradle/gradle-completion;
+    homepage = "https://github.com/gradle/gradle-completion";
     license = licenses.mit;
     maintainers = with maintainers; [ ];
   };
diff --git a/pkgs/shells/zsh/grml-zsh-config/default.nix b/pkgs/shells/zsh/grml-zsh-config/default.nix
index d23999abf3da..e76ca6842101 100644
--- a/pkgs/shells/zsh/grml-zsh-config/default.nix
+++ b/pkgs/shells/zsh/grml-zsh-config/default.nix
@@ -33,7 +33,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "grml's zsh setup";
-    homepage = http://grml.org/zsh/;
+    homepage = "http://grml.org/zsh/";
     license = licenses.gpl2;
     platforms = platforms.unix;
     maintainers = with maintainers; [ msteen rvolosatovs ];
diff --git a/pkgs/shells/zsh/lambda-mod-zsh-theme/default.nix b/pkgs/shells/zsh/lambda-mod-zsh-theme/default.nix
index 1794979bedf4..0f244c4d6866 100644
--- a/pkgs/shells/zsh/lambda-mod-zsh-theme/default.nix
+++ b/pkgs/shells/zsh/lambda-mod-zsh-theme/default.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     description = "A ZSH theme optimized for people who use Git & Unicode-compatible fonts and terminals";
-    homepage = https://github.com/halfo/lambda-mod-zsh-theme/;
+    homepage = "https://github.com/halfo/lambda-mod-zsh-theme/";
     license = licenses.mit;
     platforms = platforms.linux;
     maintainers = with maintainers; [ ma27 ];
diff --git a/pkgs/shells/zsh/nix-zsh-completions/default.nix b/pkgs/shells/zsh/nix-zsh-completions/default.nix
index 036c388fbda8..016cf7205bd6 100644
--- a/pkgs/shells/zsh/nix-zsh-completions/default.nix
+++ b/pkgs/shells/zsh/nix-zsh-completions/default.nix
@@ -22,7 +22,7 @@ stdenv.mkDerivation {
   '';
 
   meta = with stdenv.lib; {
-    homepage = https://github.com/spwhitt/nix-zsh-completions;
+    homepage = "https://github.com/spwhitt/nix-zsh-completions";
     description = "ZSH completions for Nix, NixOS, and NixOps";
     license = licenses.bsd3;
     platforms = platforms.all;
diff --git a/pkgs/shells/zsh/oh-my-zsh/default.nix b/pkgs/shells/zsh/oh-my-zsh/default.nix
index 5a61cd2e90a7..95cc597a57a0 100644
--- a/pkgs/shells/zsh/oh-my-zsh/default.nix
+++ b/pkgs/shells/zsh/oh-my-zsh/default.nix
@@ -66,7 +66,7 @@ stdenv.mkDerivation rec {
 
     $ cp -v $(nix-env -q --out-path oh-my-zsh | cut -d' ' -f3)/share/oh-my-zsh/templates/zshrc.zsh-template ~/.zshrc
   '';
-  homepage        = https://ohmyz.sh/;
+  homepage        = "https://ohmyz.sh/";
   license         = licenses.mit;
   platforms       = platforms.all;
   maintainers     = with maintainers; [ scolobb nequissimus ];
diff --git a/pkgs/shells/zsh/spaceship-prompt/default.nix b/pkgs/shells/zsh/spaceship-prompt/default.nix
index 0e7536b4fa17..e1839d5dd07f 100644
--- a/pkgs/shells/zsh/spaceship-prompt/default.nix
+++ b/pkgs/shells/zsh/spaceship-prompt/default.nix
@@ -25,7 +25,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Zsh prompt for Astronauts";
-    homepage = https://github.com/denysdovhan/spaceship-prompt/;
+    homepage = "https://github.com/denysdovhan/spaceship-prompt/";
     license = licenses.mit;
     platforms = platforms.linux;
     maintainers = with maintainers; [ nyanloutre ];
diff --git a/pkgs/shells/zsh/zsh-autosuggestions/default.nix b/pkgs/shells/zsh/zsh-autosuggestions/default.nix
index 8c9c65c24e44..58e560d2fa4d 100644
--- a/pkgs/shells/zsh/zsh-autosuggestions/default.nix
+++ b/pkgs/shells/zsh/zsh-autosuggestions/default.nix
@@ -22,7 +22,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     description = "Fish shell autosuggestions for Zsh";
-    homepage = https://github.com/zsh-users/zsh-autosuggestions;
+    homepage = "https://github.com/zsh-users/zsh-autosuggestions";
     license = licenses.mit;
     platforms = platforms.unix;
     maintainers = [ maintainers.loskutov ];
diff --git a/pkgs/shells/zsh/zsh-command-time/default.nix b/pkgs/shells/zsh/zsh-command-time/default.nix
index 6228b97685ab..3ef210a02818 100644
--- a/pkgs/shells/zsh/zsh-command-time/default.nix
+++ b/pkgs/shells/zsh/zsh-command-time/default.nix
@@ -27,7 +27,7 @@ stdenv.mkDerivation {
 
   meta = with stdenv.lib; {
     description = "Plugin that output time: xx after long commands";
-    homepage = https://github.com/popstas/zsh-command-time;
+    homepage = "https://github.com/popstas/zsh-command-time";
     license = licenses.mit;
     platforms = platforms.unix;
   };
diff --git a/pkgs/shells/zsh/zsh-completions/default.nix b/pkgs/shells/zsh/zsh-completions/default.nix
index 35355fe374df..03f6146df7c6 100644
--- a/pkgs/shells/zsh/zsh-completions/default.nix
+++ b/pkgs/shells/zsh/zsh-completions/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     description = "Additional completion definitions for zsh";
-    homepage = https://github.com/zsh-users/zsh-completions;
+    homepage = "https://github.com/zsh-users/zsh-completions";
     license = stdenv.lib.licenses.free;
 
     platforms = stdenv.lib.platforms.unix;
diff --git a/pkgs/shells/zsh/zsh-history-substring-search/default.nix b/pkgs/shells/zsh/zsh-history-substring-search/default.nix
index fcd294f4dce3..9890993eed64 100644
--- a/pkgs/shells/zsh/zsh-history-substring-search/default.nix
+++ b/pkgs/shells/zsh/zsh-history-substring-search/default.nix
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
 
   meta = with lib; {
     description = "Fish shell history-substring-search for Zsh";
-    homepage = https://github.com/zsh-users/zsh-history-substring-search;
+    homepage = "https://github.com/zsh-users/zsh-history-substring-search";
     license = licenses.bsd3;
     maintainers = with maintainers; [ qyliss ];
     platforms = platforms.unix;
diff --git a/pkgs/shells/zsh/zsh-history/default.nix b/pkgs/shells/zsh/zsh-history/default.nix
index ece3c87cb664..f839cf7cf2ed 100644
--- a/pkgs/shells/zsh/zsh-history/default.nix
+++ b/pkgs/shells/zsh/zsh-history/default.nix
@@ -25,7 +25,7 @@ buildGoModule rec {
   meta = with lib; {
     description = "A CLI to provide enhanced history for your ZSH shell";
     license = licenses.mit;
-    homepage = https://github.com/b4b4r07/history;
+    homepage = "https://github.com/b4b4r07/history";
     platforms = platforms.unix;
     maintainers = with maintainers; [ kampka ];
   };
diff --git a/pkgs/shells/zsh/zsh-powerlevel9k/default.nix b/pkgs/shells/zsh/zsh-powerlevel9k/default.nix
index c80ff0da60af..676f9458675b 100644
--- a/pkgs/shells/zsh/zsh-powerlevel9k/default.nix
+++ b/pkgs/shells/zsh/zsh-powerlevel9k/default.nix
@@ -20,7 +20,7 @@ stdenv.mkDerivation {
 
   meta = {
     description = "A beautiful theme for zsh";
-    homepage = https://github.com/bhilburn/powerlevel9k;
+    homepage = "https://github.com/bhilburn/powerlevel9k";
     license = stdenv.lib.licenses.mit;
 
     platforms = stdenv.lib.platforms.unix;
diff --git a/pkgs/shells/zsh/zsh-prezto/default.nix b/pkgs/shells/zsh/zsh-prezto/default.nix
index 383d19675314..ec6288a6e63c 100644
--- a/pkgs/shells/zsh/zsh-prezto/default.nix
+++ b/pkgs/shells/zsh/zsh-prezto/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation {
   '';
   meta = with stdenv.lib; {
     description = "Prezto is the configuration framework for Zsh; it enriches the command line interface environment with sane defaults, aliases, functions, auto completion, and prompt themes.";
-    homepage = https://github.com/sorin-ionescu/prezto;
+    homepage = "https://github.com/sorin-ionescu/prezto";
     license = licenses.mit;
     maintainers = with maintainers; [ ];
     platforms = with platforms; unix;
diff --git a/pkgs/shells/zsh/zsh-you-should-use/default.nix b/pkgs/shells/zsh/zsh-you-should-use/default.nix
index 91cf34268acd..13e3bbdc0383 100644
--- a/pkgs/shells/zsh/zsh-you-should-use/default.nix
+++ b/pkgs/shells/zsh/zsh-you-should-use/default.nix
@@ -18,7 +18,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    homepage = https://github.com/MichaelAquilina/zsh-you-should-use;
+    homepage = "https://github.com/MichaelAquilina/zsh-you-should-use";
     license = licenses.gpl3;
     description = "ZSH plugin that reminds you to use existing aliases for commands you just typed";
     maintainers = with maintainers; [ ma27 ];