about summary refs log tree commit diff
path: root/pkgs/shells
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/shells')
-rw-r--r--pkgs/shells/dash/default.nix4
-rw-r--r--pkgs/shells/es/default.nix4
-rw-r--r--pkgs/shells/fish/default.nix4
-rw-r--r--pkgs/shells/mksh/default.nix4
-rw-r--r--pkgs/shells/oh-my-zsh/default.nix8
-rw-r--r--pkgs/shells/pash/default.nix4
-rw-r--r--pkgs/shells/rush/default.nix4
-rw-r--r--pkgs/shells/tcsh/avoid-gcc5-wrong-optimisation.patch28
-rw-r--r--pkgs/shells/tcsh/default.nix44
-rw-r--r--pkgs/shells/xonsh/default.nix10
-rw-r--r--pkgs/shells/zsh/default.nix4
11 files changed, 100 insertions, 18 deletions
diff --git a/pkgs/shells/dash/default.nix b/pkgs/shells/dash/default.nix
index d3104439e578..1a95b4f42e6f 100644
--- a/pkgs/shells/dash/default.nix
+++ b/pkgs/shells/dash/default.nix
@@ -13,4 +13,8 @@ stdenv.mkDerivation rec {
     description = "A POSIX-compliant implementation of /bin/sh that aims to be as small as possible";
     hydraPlatforms = stdenv.lib.platforms.linux;
   };
+
+  passthru = {
+    shellPath = "/bin/dash";
+  };
 }
diff --git a/pkgs/shells/es/default.nix b/pkgs/shells/es/default.nix
index ba9fe29c33e6..037d1e1ec995 100644
--- a/pkgs/shells/es/default.nix
+++ b/pkgs/shells/es/default.nix
@@ -43,4 +43,8 @@ stdenv.mkDerivation {
     maintainers = [ maintainers.sjmackenzie ];
     platforms = platforms.all;
   };
+
+  passthru = {
+    shellPath = "/bin/es";
+  };
 }
diff --git a/pkgs/shells/fish/default.nix b/pkgs/shells/fish/default.nix
index 0124f914866c..353647f15b30 100644
--- a/pkgs/shells/fish/default.nix
+++ b/pkgs/shells/fish/default.nix
@@ -87,4 +87,8 @@ stdenv.mkDerivation rec {
     platforms = platforms.unix;
     maintainers = with maintainers; [ ocharles ];
   };
+
+  passthru = {
+    shellPath = "/bin/fish";
+  };
 }
diff --git a/pkgs/shells/mksh/default.nix b/pkgs/shells/mksh/default.nix
index 696777c7f1ff..dde890a022db 100644
--- a/pkgs/shells/mksh/default.nix
+++ b/pkgs/shells/mksh/default.nix
@@ -43,4 +43,8 @@ stdenv.mkDerivation rec {
     maintainers = with maintainers; [ AndersonTorres nckx ];
     platforms = platforms.unix;
   };
+
+  passthru = {
+    shellPath = "/bin/mksh";
+  };
 }
diff --git a/pkgs/shells/oh-my-zsh/default.nix b/pkgs/shells/oh-my-zsh/default.nix
index 473b364981b7..5191e7cd45cb 100644
--- a/pkgs/shells/oh-my-zsh/default.nix
+++ b/pkgs/shells/oh-my-zsh/default.nix
@@ -7,12 +7,12 @@
 
 stdenv.mkDerivation rec {
   name = "oh-my-zsh-git-${version}";
-  version = "2016-04-20";
+  version = "2016-06-18";
 
   src = fetchgit {
     url = "https://github.com/robbyrussell/oh-my-zsh";
-    rev = "1b1315a777328095cd8b5f364fd4345eeae7c4bf";
-    sha256 = "1bdh6k46kwggihw6iblm1q60x4hjxpbkhaqap0nfpapqvlba4nv6";
+    rev = "d012402dada1ec7d8796f2f4b04744d817137b4d";
+    sha256 = "1965k91jdhjpy2dkklzwcxmq6qqjc7cnwl8x670g51jr4ihawkx1";
   };
 
   phases = "installPhase";
@@ -25,7 +25,7 @@ stdenv.mkDerivation rec {
   cp -r $src/* $outdir
   cd $outdir
 
-  rm MIT-LICENSE.txt
+  rm LICENSE.txt
   rm -rf .git*
 
   chmod -R +w templates
diff --git a/pkgs/shells/pash/default.nix b/pkgs/shells/pash/default.nix
index b9a8397e3ba1..0b424c897771 100644
--- a/pkgs/shells/pash/default.nix
+++ b/pkgs/shells/pash/default.nix
@@ -22,4 +22,8 @@ buildDotnetPackage rec {
     platforms = platforms.all;
     license = with licenses; [ bsd3 gpl3 ];
   };
+
+  passthru = {
+    shellPath = "/bin/pash";
+  };
 }
diff --git a/pkgs/shells/rush/default.nix b/pkgs/shells/rush/default.nix
index 3232caf5848b..bbad1f8cdf47 100644
--- a/pkgs/shells/rush/default.nix
+++ b/pkgs/shells/rush/default.nix
@@ -35,4 +35,8 @@ stdenv.mkDerivation rec {
     maintainers = [ stdenv.lib.maintainers.bjg ];
     platforms = stdenv.lib.platforms.all;
   };
+
+  passthru = {
+    shellPath = "/bin/rush";
+  };
 }
diff --git a/pkgs/shells/tcsh/avoid-gcc5-wrong-optimisation.patch b/pkgs/shells/tcsh/avoid-gcc5-wrong-optimisation.patch
new file mode 100644
index 000000000000..b35d29680af4
--- /dev/null
+++ b/pkgs/shells/tcsh/avoid-gcc5-wrong-optimisation.patch
@@ -0,0 +1,28 @@
+From: christos <christos>
+Date: Thu, 28 May 2015 11:47:03 +0000
+Subject: [PATCH] avoid gcc-5 optimization malloc + memset = calloc (Fridolin
+Pokorny)
+
+---
+tc.alloc.c | 5 ++++-
+1 file changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/tc.alloc.c b/tc.alloc.c
+index b9aec63..c1cb330 100644
+--- a/tc.alloc.c
++++ b/tc.alloc.c
+@@ -348,10 +348,13 @@ calloc(size_t i, size_t j)
+ {
+ #ifndef lint
+     char *cp;
++    volatile size_t k;
+ 
+     i *= j;
+     cp = xmalloc(i);
+-    memset(cp, 0, i);
++    /* Stop gcc 5.x from optimizing malloc+memset = calloc */
++    k = i;
++    memset(cp, 0, k);
+ 
+     return ((memalign_t) cp);
+ #else
diff --git a/pkgs/shells/tcsh/default.nix b/pkgs/shells/tcsh/default.nix
index be182f87f1ee..419acd8d61d2 100644
--- a/pkgs/shells/tcsh/default.nix
+++ b/pkgs/shells/tcsh/default.nix
@@ -1,22 +1,44 @@
-{stdenv, fetchurl, ncurses}:
+{ stdenv, fetchurl
+, ncurses }:
 
 stdenv.mkDerivation rec {
-  name = "tcsh-6.18.01";
+  name = "tcsh-${version}";
+  version = "6.19.00";
   
   src = fetchurl {
-    url = "ftp://ftp.funet.fi/pub/unix/shells/tcsh/${name}.tar.gz";
-    sha256 = "1a4z9kwgx1iqqzvv64si34m60gj34p7lp6rrcrb59s7ka5wa476q";
+    urls = [ 
+             "http://ftp.funet.fi/pub/mirrors/ftp.astron.com/pub/tcsh/${name}.tar.gz" 
+             "ftp://ftp.astron.com/pub/tcsh/${name}.tar.gz" 
+             "ftp://ftp.funet.fi/pub/unix/shells/tcsh/${name}.tar.gz"
+             ];
+    sha256 = "0jaw51382pqyb6d1kgfg8ir0wd3p5qr2bmg8svcmjhlyp3h73qhj";
   };
+
+  patches = [ ./avoid-gcc5-wrong-optimisation.patch ];
   
-  buildInputs = [ncurses];
+  buildInputs = [ ncurses ];
 
-  postInstall =
-    ''
-      ln -s tcsh $out/bin/csh
+  meta = with stdenv.lib;{
+    description = "An enhanced version of the Berkeley UNIX C shell (csh)";
+    longDescription = ''
+      tcsh is an enhanced but completely compatible version of the
+      Berkeley UNIX C shell, csh. It is a command language interpreter
+      usable both as an interactive login shell and a shell script
+      command processor.
+      It includes:
+      - command-line editor
+      - programmable word completion
+      - spelling correction
+      - history mechanism
+      - job control
     '';
-
-  meta = {
     homepage = http://www.tcsh.org/;
-    description = "An enhanced version of the Berkeley UNIX C shell (csh)";
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ AndersonTorres ];
+    platforms = platforms.linux;
+  };
+
+  passthru = {
+    shellPath = "/bin/tcsh";
   };
 }
diff --git a/pkgs/shells/xonsh/default.nix b/pkgs/shells/xonsh/default.nix
index 395132bc2d82..92f7f20993f7 100644
--- a/pkgs/shells/xonsh/default.nix
+++ b/pkgs/shells/xonsh/default.nix
@@ -2,13 +2,13 @@
 
 python3Packages.buildPythonApplication rec {
   name = "xonsh-${version}";
-  version = "0.3.2";
+  version = "0.3.4";
 
   src = fetchFromGitHub {
     owner = "scopatz";
     repo = "xonsh";
     rev = version;
-    sha256= "0cqfrpvkgzk0q3dykavqxwfqrx61y8rbzixmwcv8pfa9r2sya24q";
+    sha256= "13inkj0vs8nqdghp3j19dardawfsdmcsfzsp77hlwavmw7sqjxzi";
   };
 
   ## The logo xonsh prints during build contains unicode characters, and this
@@ -31,7 +31,7 @@ python3Packages.buildPythonApplication rec {
     HOME=$TMPDIR nosetests -x
   '';
 
-  buildInputs = with python3Packages; [ glibcLocales nose pygments ];
+  buildInputs = with python3Packages; [ glibcLocales nose ];
   propagatedBuildInputs = with python3Packages; [ ply prompt_toolkit ];
 
   meta = with stdenv.lib; {
@@ -41,4 +41,8 @@ python3Packages.buildPythonApplication rec {
     maintainers = with maintainers; [ spwhitt garbas ];
     platforms = platforms.all;
   };
+
+  passthru = {
+    shellPath = "/bin/xonsh";
+  };
 }
diff --git a/pkgs/shells/zsh/default.nix b/pkgs/shells/zsh/default.nix
index fda3e77c61f4..261dbf12f8e5 100644
--- a/pkgs/shells/zsh/default.nix
+++ b/pkgs/shells/zsh/default.nix
@@ -80,4 +80,8 @@ EOF
     maintainers = with stdenv.lib.maintainers; [ chaoflow pSub ];
     platforms = stdenv.lib.platforms.unix;
   };
+
+  passthru = {
+    shellPath = "/bin/zsh";
+  };
 }