about summary refs log tree commit diff
path: root/pkgs/servers
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/servers')
-rw-r--r--pkgs/servers/dns/doh-proxy/default.nix30
-rw-r--r--pkgs/servers/misc/airsonic/default.nix4
-rw-r--r--pkgs/servers/monitoring/zabbix/proxy.nix5
-rw-r--r--pkgs/servers/plex/raw.nix4
-rw-r--r--pkgs/servers/varnish/default.nix18
-rw-r--r--pkgs/servers/varnish/dynamic.nix6
-rw-r--r--pkgs/servers/varnish/modules.nix13
-rw-r--r--pkgs/servers/varnish/rtstatus.nix6
8 files changed, 59 insertions, 27 deletions
diff --git a/pkgs/servers/dns/doh-proxy/default.nix b/pkgs/servers/dns/doh-proxy/default.nix
index ac44dbbf04d1..d94f34ebd21f 100644
--- a/pkgs/servers/dns/doh-proxy/default.nix
+++ b/pkgs/servers/dns/doh-proxy/default.nix
@@ -1,17 +1,35 @@
 { lib, python3Packages }:
 
-python3Packages.buildPythonApplication rec {
+with python3Packages;
+buildPythonApplication rec {
   pname = "doh-proxy";
-  version = "0.0.8";
+  version = "0.0.9";
 
   src = python3Packages.fetchPypi {
     inherit pname version;
-    sha256 = "0mfl84mcklby6cnsw29kpcxj7mh1cx5yw6mjs4sidr1psyni7x6c";
+    sha256 = "1fxzxipzdvk75yrcr78mpdz8lwpisba67lk4jcwxdnkv6997dwfp";
   };
 
-  propagatedBuildInputs = with python3Packages;
-    [ aioh2 dnspython aiohttp-remotes pytestrunner flake8 ];
-  doCheck = false; # Trouble packaging unittest-data-provider
+  nativeBuildInputs = [ pytestrunner flake8];
+
+  propagatedBuildInputs = [
+    aioh2
+    dnspython
+    aiohttp-remotes
+  ];
+
+  checkInputs = [
+    asynctest
+    unittest-data-provider
+    pytest
+    pytestcov
+    pytest-aiohttp
+  ];
+
+  # attempts to resolve address
+  checkPhase = ''
+    pytest -k 'not servers'
+  '';
 
   meta = with lib; {
     homepage = https://facebookexperimental.github.io/doh-proxy/;
diff --git a/pkgs/servers/misc/airsonic/default.nix b/pkgs/servers/misc/airsonic/default.nix
index 34601ed708bc..1afe1e8b9462 100644
--- a/pkgs/servers/misc/airsonic/default.nix
+++ b/pkgs/servers/misc/airsonic/default.nix
@@ -2,11 +2,11 @@
 
 stdenv.mkDerivation rec {
   pname = "airsonic";
-  version = "10.3.1";
+  version = "10.4.0";
 
   src = fetchurl {
     url = "https://github.com/airsonic/airsonic/releases/download/v${version}/airsonic.war";
-    sha256 = "15y56h7zy94408605cchvf2fqg3aicylpzgd1g8fxyl42h216816";
+    sha256 = "1m4l10hp5m010ljsvn2ba4bbh8i26d04xffw81gfgjw08gya2hh8";
   };
 
   buildCommand = ''
diff --git a/pkgs/servers/monitoring/zabbix/proxy.nix b/pkgs/servers/monitoring/zabbix/proxy.nix
index 2062dc6659f8..48b72dc0590d 100644
--- a/pkgs/servers/monitoring/zabbix/proxy.nix
+++ b/pkgs/servers/monitoring/zabbix/proxy.nix
@@ -63,7 +63,10 @@ in
         mkdir -p $out/share/zabbix/database/
       '' + optionalString sqliteSupport ''
         mkdir -p $out/share/zabbix/database/sqlite3
-        cp -prvd database/sqlite3/*.sql $out/share/zabbix/database/sqlite3/
+        cp -prvd database/sqlite3/schema.sql $out/share/zabbix/database/sqlite3/
+      '' + optionalString mysqlSupport ''
+        mkdir -p $out/share/zabbix/database/mysql
+        cp -prvd database/mysql/schema.sql $out/share/zabbix/database/mysql/
       '' + optionalString postgresqlSupport ''
         mkdir -p $out/share/zabbix/database/postgresql
         cp -prvd database/postgresql/schema.sql $out/share/zabbix/database/postgresql/
diff --git a/pkgs/servers/plex/raw.nix b/pkgs/servers/plex/raw.nix
index 588483b8343c..9f3cd508fb0f 100644
--- a/pkgs/servers/plex/raw.nix
+++ b/pkgs/servers/plex/raw.nix
@@ -8,13 +8,13 @@
 # server, and the FHS userenv and corresponding NixOS module should
 # automatically pick up the changes.
 stdenv.mkDerivation rec {
-  version = "1.16.3.1402-22929c8a2";
+  version = "1.16.4.1469-6d5612c2f";
   pname = "plexmediaserver";
 
   # Fetch the source
   src = fetchurl {
     url = "https://downloads.plex.tv/plex-media-server-new/${version}/redhat/plexmediaserver-${version}.x86_64.rpm";
-    sha256 = "0mb5y777mcyn8lv1afyi0xx0afyzjm67ccbbkyhk2j817k9diyg5";
+    sha256 = "16ifgqsxgpqyd1m0xmwrrv4cic1yccklv1jlv7fhq8wc6vz9l6lx";
   };
 
   outputs = [ "out" "basedb" ];
diff --git a/pkgs/servers/varnish/default.nix b/pkgs/servers/varnish/default.nix
index 2375e81ff9eb..8a63ed3ea7f1 100644
--- a/pkgs/servers/varnish/default.nix
+++ b/pkgs/servers/varnish/default.nix
@@ -1,8 +1,8 @@
 { stdenv, fetchurl, pcre, libxslt, groff, ncurses, pkgconfig, readline, libedit
-, python3, makeWrapper }:
+, python2, python3, makeWrapper }:
 
 let
-  common = { version, sha256, extraBuildInputs ? [] }:
+  common = { version, sha256, python, extraNativeBuildInputs ? [] }:
     stdenv.mkDerivation rec {
       pname = "varnish";
       inherit version;
@@ -12,11 +12,12 @@ let
         inherit sha256;
       };
 
-      nativeBuildInputs = [ pkgconfig ];
+      passthru.python = python;
+
+      nativeBuildInputs = with python.pkgs; [ pkgconfig docutils ] ++ extraNativeBuildInputs;
       buildInputs = [
-        pcre libxslt groff ncurses readline python3 libedit
-        python3.pkgs.docutils makeWrapper
-      ] ++ extraBuildInputs;
+        pcre libxslt groff ncurses readline libedit makeWrapper python
+      ];
 
       buildFlags = "localstatedir=/var/spool";
 
@@ -42,14 +43,17 @@ in
   varnish4 = common {
     version = "4.1.10";
     sha256 = "08kwx0il6cqxsx3897042plh1yxjaanbaqjbspfl0xgvyvxk6j1n";
+    python = python2;
   };
   varnish5 = common {
     version = "5.2.1";
     sha256 = "1cqlj12m426c1lak1hr1fx5zcfsjjvka3hfirz47hvy1g2fjqidq";
+    python = python2;
   };
   varnish6 = common {
     version = "6.2.0";
     sha256 = "0lwfk2gq99c653h5f51fs3j37r0gh2pf0p4w5z986nm2mi9z6yn3";
-    extraBuildInputs = [ python3.pkgs.sphinx ];
+    python = python3;
+    extraNativeBuildInputs = [ python3.pkgs.sphinx ];
   };
 }
diff --git a/pkgs/servers/varnish/dynamic.nix b/pkgs/servers/varnish/dynamic.nix
index 711bc1cf78f5..b3e86387ee32 100644
--- a/pkgs/servers/varnish/dynamic.nix
+++ b/pkgs/servers/varnish/dynamic.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, varnish, python, docutils }:
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, varnish, docutils }:
 
 stdenv.mkDerivation rec {
   version = "0.3";
@@ -11,8 +11,8 @@ stdenv.mkDerivation rec {
     sha256 = "12a42lbv0vf6fn3qnvngw893kmbd006f8pgab4ir7irc8855xjgf";
   };
 
-  nativeBuildInputs = [ pkgconfig docutils autoreconfHook ];
-  buildInputs = [ varnish python ];
+  nativeBuildInputs = [ pkgconfig docutils autoreconfHook varnish.python ];
+  buildInputs = [ varnish ];
   postPatch = ''
     substituteInPlace Makefile.am --replace "''${LIBVARNISHAPI_DATAROOTDIR}/aclocal" "${varnish.dev}/share/aclocal"
   '';
diff --git a/pkgs/servers/varnish/modules.nix b/pkgs/servers/varnish/modules.nix
index 7775221d1638..16c74956db7e 100644
--- a/pkgs/servers/varnish/modules.nix
+++ b/pkgs/servers/varnish/modules.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, varnish, python, docutils, removeReferencesTo }:
+{ stdenv, fetchFromGitHub, autoreconfHook, pkgconfig, varnish, docutils, removeReferencesTo }:
 
 stdenv.mkDerivation rec {
   version = "0.14.0";
@@ -11,8 +11,15 @@ stdenv.mkDerivation rec {
     sha256 = "17fkbr4i70qgdqsrx1x28ag20xkfyz1v3q3d3ywmv409aczqhm40";
   };
 
-  nativeBuildInputs = [ pkgconfig autoreconfHook docutils removeReferencesTo ];
-  buildInputs = [ varnish python ];
+  nativeBuildInputs = [
+    autoreconfHook
+    docutils
+    pkgconfig
+    removeReferencesTo
+    varnish.python  # use same python version as varnish server
+  ];
+
+  buildInputs = [ varnish ];
 
   postPatch = ''
     substituteInPlace bootstrap   --replace "''${dataroot}/aclocal"                  "${varnish.dev}/share/aclocal"
diff --git a/pkgs/servers/varnish/rtstatus.nix b/pkgs/servers/varnish/rtstatus.nix
index 99c0bb176597..c27633a2d333 100644
--- a/pkgs/servers/varnish/rtstatus.nix
+++ b/pkgs/servers/varnish/rtstatus.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, pkgconfig, varnish, python, docutils }:
+{ stdenv, fetchurl, pkgconfig, varnish, docutils }:
 
 stdenv.mkDerivation rec {
   version = "1.2.0";
@@ -9,8 +9,8 @@ stdenv.mkDerivation rec {
     sha256 = "0hll1aspgpv1daw5sdbn5w1d6birchxgapzb6zi1nhahjlimy4ly";
   };
 
-  nativeBuildInputs = [ pkgconfig docutils ];
-  buildInputs = [ varnish python ];
+  nativeBuildInputs = [ pkgconfig docutils varnish.python ];
+  buildInputs = [ varnish ];
   configureFlags = [ "VMOD_DIR=$(out)/lib/varnish/vmods" ];
 
   meta = with stdenv.lib; {