about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/drbd/default.nix2
-rw-r--r--pkgs/os-specific/linux/drbd/fix-glibc-compilation.patch24
-rw-r--r--pkgs/os-specific/linux/jfbview/default.nix5
-rw-r--r--pkgs/os-specific/linux/policycoreutils/default.nix2
-rw-r--r--pkgs/os-specific/linux/sysstat/default.nix4
-rw-r--r--pkgs/os-specific/linux/tiscamera/allow-pipeline-stop-in-trigger-mode.patch48
-rw-r--r--pkgs/os-specific/linux/tiscamera/default.nix25
-rw-r--r--pkgs/os-specific/linux/v4l-utils/default.nix4
8 files changed, 52 insertions, 62 deletions
diff --git a/pkgs/os-specific/linux/drbd/default.nix b/pkgs/os-specific/linux/drbd/default.nix
index 74f3430c2d89..02b8afa721f6 100644
--- a/pkgs/os-specific/linux/drbd/default.nix
+++ b/pkgs/os-specific/linux/drbd/default.nix
@@ -8,7 +8,7 @@ stdenv.mkDerivation rec {
     sha256 = "1w4889h1ak7gy9w33kd4fgjlfpgmp6hzfya16p1pkc13bjf22mm0";
   };
 
-  patches = [ ./pass-force.patch ];
+  patches = [ ./pass-force.patch ./fix-glibc-compilation.patch ];
 
   nativeBuildInputs = [ flex ];
   buildInputs = [ perl ];
diff --git a/pkgs/os-specific/linux/drbd/fix-glibc-compilation.patch b/pkgs/os-specific/linux/drbd/fix-glibc-compilation.patch
new file mode 100644
index 000000000000..621a2dd995db
--- /dev/null
+++ b/pkgs/os-specific/linux/drbd/fix-glibc-compilation.patch
@@ -0,0 +1,24 @@
+diff --git a/user/drbdadm_adjust.c b/user/drbdadm_adjust.c
+index cb23270..3a751ca 100644
+--- a/user/drbdadm_adjust.c
++++ b/user/drbdadm_adjust.c
+@@ -29,6 +29,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <sys/sysmacros.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ 
+diff --git a/user/legacy/drbdadm_adjust.c b/user/legacy/drbdadm_adjust.c
+index c79163c..6990ffb 100644
+--- a/user/legacy/drbdadm_adjust.c
++++ b/user/legacy/drbdadm_adjust.c
+@@ -27,6 +27,7 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <sys/wait.h>
++#include <sys/sysmacros.h>
+ #include <unistd.h>
+ #include <fcntl.h>
+ 
diff --git a/pkgs/os-specific/linux/jfbview/default.nix b/pkgs/os-specific/linux/jfbview/default.nix
index 97b1b94c6340..58e058196bd3 100644
--- a/pkgs/os-specific/linux/jfbview/default.nix
+++ b/pkgs/os-specific/linux/jfbview/default.nix
@@ -24,6 +24,11 @@ stdenv.mkDerivation rec {
     sha256 = "0ppns49hnmp04zdjw6wc28v0yvz31rkzvd5ylcj7arikx20llpxf";
   };
 
+  postPatch = ''
+    substituteInPlace main.cpp \
+      --replace "<stropts.h>" "<sys/ioctl.h>"
+  '';
+
   hardeningDisable = [ "format" ];
 
   buildInputs = [
diff --git a/pkgs/os-specific/linux/policycoreutils/default.nix b/pkgs/os-specific/linux/policycoreutils/default.nix
index 9d229c50000e..f9e3a7fb5d4f 100644
--- a/pkgs/os-specific/linux/policycoreutils/default.nix
+++ b/pkgs/os-specific/linux/policycoreutils/default.nix
@@ -15,6 +15,8 @@ stdenv.mkDerivation rec {
     substituteInPlace po/Makefile \
        --replace /usr/bin/install install --replace /usr/share /share
     substituteInPlace newrole/Makefile --replace /usr/share /share
+
+    sed -i -e '39i#include <crypt.h>' run_init/run_init.c
   '';
 
   nativeBuildInputs = [ gettext ];
diff --git a/pkgs/os-specific/linux/sysstat/default.nix b/pkgs/os-specific/linux/sysstat/default.nix
index 2ad7b21d451a..b3d4576ac3ab 100644
--- a/pkgs/os-specific/linux/sysstat/default.nix
+++ b/pkgs/os-specific/linux/sysstat/default.nix
@@ -1,11 +1,11 @@
 { stdenv, fetchurl, gettext, bzip2 }:
 
 stdenv.mkDerivation rec {
-  name = "sysstat-12.1.7";
+  name = "sysstat-12.2.0";
 
   src = fetchurl {
     url = "http://pagesperso-orange.fr/sebastien.godard/${name}.tar.xz";
-    sha256 = "1i0qy44krl1gj82izgmqa0zdw82f2gmqzlslvdg5v270vl7i24g7";
+    sha256 = "0xc3983ccr0dwab1px2jhbgj86pfmmr29k7ggnwjwm1qigmriak1";
   };
 
   buildInputs = [ gettext ];
diff --git a/pkgs/os-specific/linux/tiscamera/allow-pipeline-stop-in-trigger-mode.patch b/pkgs/os-specific/linux/tiscamera/allow-pipeline-stop-in-trigger-mode.patch
deleted file mode 100644
index 48a520f6ec3a..000000000000
--- a/pkgs/os-specific/linux/tiscamera/allow-pipeline-stop-in-trigger-mode.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff --git a/src/gstreamer-1.0/gsttcamsrc.cpp b/src/gstreamer-1.0/gsttcamsrc.cpp
-index d482e1e..e36afd8 100644
---- a/src/gstreamer-1.0/gsttcamsrc.cpp
-+++ b/src/gstreamer-1.0/gsttcamsrc.cpp
-@@ -1112,6 +1112,7 @@ bool gst_tcam_src_init_camera (GstTcamSrc* self)
- 
- static void gst_tcam_src_close_camera (GstTcamSrc* self)
- {
-+    GST_INFO("Closing device");
-     if (self->device != NULL)
-     {
-         self->device->dev->stop_stream();
-@@ -1156,7 +1157,7 @@ static gboolean gst_tcam_src_stop (GstBaseSrc* src)
- 
-     self->device->dev->stop_stream();
-     gst_element_send_event(GST_ELEMENT(self), gst_event_new_eos());
--    GST_DEBUG_OBJECT (self, "Stopped acquisition");
-+    GST_DEBUG("Stopped acquisition");
- 
-     return TRUE;
- }
-@@ -1556,6 +1557,18 @@ static void gst_tcam_src_get_property (GObject* object,
- }
- 
- 
-+static gboolean gst_tcam_src_unlock (GstBaseSrc* src)
-+{
-+    GstTcamSrc* self = GST_TCAM_SRC(src);
-+
-+    self->is_running = FALSE;
-+
-+    self->cv.notify_all();
-+
-+    return TRUE;
-+}
-+
-+
- static void gst_tcam_src_class_init (GstTcamSrcClass* klass)
- {
-     GObjectClass *gobject_class = G_OBJECT_CLASS (klass);
-@@ -1616,6 +1629,7 @@ static void gst_tcam_src_class_init (GstTcamSrcClass* klass)
-     gstbasesrc_class->fixate = gst_tcam_src_fixate_caps;
-     gstbasesrc_class->start = gst_tcam_src_start;
-     gstbasesrc_class->stop = gst_tcam_src_stop;
-+    gstbasesrc_class->unlock = gst_tcam_src_unlock;
-     gstbasesrc_class->negotiate = gst_tcam_src_negotiate;
-     gstbasesrc_class->get_times = gst_tcam_src_get_times;
- 
diff --git a/pkgs/os-specific/linux/tiscamera/default.nix b/pkgs/os-specific/linux/tiscamera/default.nix
index 387a3bcf2c6f..ebd17de892ab 100644
--- a/pkgs/os-specific/linux/tiscamera/default.nix
+++ b/pkgs/os-specific/linux/tiscamera/default.nix
@@ -11,17 +11,23 @@
 , gobject-introspection
 , gst_all_1
 , libwebcam
+, libunwind
+, gstreamer
+, elfutils
+, orc
+, python3
+, libuuid
 }:
 
 stdenv.mkDerivation rec {
   pname = "tiscamera";
-  version = "0.9.1";
+  version = "0.11.1";
 
   src = fetchFromGitHub {
     owner = "TheImagingSource";
     repo = pname;
     rev = "v-${pname}-${version}";
-    sha256 = "143yp6bpzj3rqfnrcnlrcwggay37fg6rkphh4w9y9v7v4wllzf87";
+    sha256 = "07vp6khgl6qd3a4519dmx1s5bfw7pld793p50pjn29fqh91fm93g";
   };
 
   nativeBuildInputs = [
@@ -39,6 +45,12 @@ stdenv.mkDerivation rec {
     gst_all_1.gstreamer
     gst_all_1.gst-plugins-base
     libwebcam
+    libunwind
+    gstreamer
+    elfutils
+    orc
+    python3
+    libuuid
   ];
 
 
@@ -50,13 +62,8 @@ stdenv.mkDerivation rec {
     "-DBUILD_LIBUSB=ON"
   ];
 
-
-  patches = [
-    ./allow-pipeline-stop-in-trigger-mode.patch # To be removed next release.
-  ];
-
   postPatch = ''
-    substituteInPlace ./data/udev/80-theimagingsource-cameras.rules \
+    substituteInPlace ./data/udev/80-theimagingsource-cameras.rules.in \
       --replace "/usr/bin/uvcdynctrl" "${libwebcam}/bin/uvcdynctrl" \
       --replace "/path/to/tiscamera/uvc-extensions" "$out/share/uvcdynctrl/data/199e"
 
@@ -94,4 +101,4 @@ stdenv.mkDerivation rec {
     platforms = platforms.linux;
     maintainers = with maintainers; [ jraygauthier ];
   };
-}
\ No newline at end of file
+}
diff --git a/pkgs/os-specific/linux/v4l-utils/default.nix b/pkgs/os-specific/linux/v4l-utils/default.nix
index 73db222d390c..050e7eaec473 100644
--- a/pkgs/os-specific/linux/v4l-utils/default.nix
+++ b/pkgs/os-specific/linux/v4l-utils/default.nix
@@ -12,11 +12,11 @@ let
 # we need to use stdenv.mkDerivation in order not to pollute the libv4l’s closure with Qt
 in stdenv.mkDerivation rec {
   pname = "v4l-utils";
-  version = "1.16.7";
+  version = "1.18.0";
 
   src = fetchurl {
     url = "https://linuxtv.org/downloads/${pname}/${pname}-${version}.tar.bz2";
-    sha256 = "1ng0x3wj3a1ckfd00yxa4za43xms92gdp7rdag060b7p39z7m4gf";
+    sha256 = "03c80acbv2znfxs1l32yx30znmjrqq7kxhiwl2309lpf5s10vdkc";
   };
 
   outputs = [ "out" ] ++ lib.optional withUtils "lib" ++ [ "dev" ];