about summary refs log tree commit diff
path: root/pkgs/os-specific
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2020-02-06 19:43:36 +0100
committerFrederik Rietdijk <fridh@fridh.nl>2020-02-06 19:43:36 +0100
commit38cf6eac193b89701cf25ffa734a2edf44ddb8e8 (patch)
tree3a058d099959112d2c8d732e340af1b191558088 /pkgs/os-specific
parent2016305d7a53388a5f84c14ba143f451267e92f6 (diff)
parent8f584be88642a29db3ef63be34aaa1b2353e004a (diff)
downloadnixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.tar
nixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.tar.gz
nixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.tar.bz2
nixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.tar.lz
nixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.tar.xz
nixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.tar.zst
nixlib-38cf6eac193b89701cf25ffa734a2edf44ddb8e8.zip
Merge master into staging-next
Diffstat (limited to 'pkgs/os-specific')
-rw-r--r--pkgs/os-specific/linux/firmware/fwupd/add-option-for-installation-sysconfdir.patch34
-rw-r--r--pkgs/os-specific/linux/firmware/fwupd/default.nix19
-rw-r--r--pkgs/os-specific/linux/firmware/fwupd/no-which.patch31
-rw-r--r--pkgs/os-specific/linux/jfbview/default.nix4
4 files changed, 24 insertions, 64 deletions
diff --git a/pkgs/os-specific/linux/firmware/fwupd/add-option-for-installation-sysconfdir.patch b/pkgs/os-specific/linux/firmware/fwupd/add-option-for-installation-sysconfdir.patch
index 81e82d68dbc4..262c2cbc4f17 100644
--- a/pkgs/os-specific/linux/firmware/fwupd/add-option-for-installation-sysconfdir.patch
+++ b/pkgs/os-specific/linux/firmware/fwupd/add-option-for-installation-sysconfdir.patch
@@ -1,10 +1,10 @@
 diff --git a/data/meson.build b/data/meson.build
-index 25db9509..f394eb25 100644
+index d59bdc88..4a4cfc35 100644
 --- a/data/meson.build
 +++ b/data/meson.build
-@@ -13,7 +13,7 @@
- if build_daemon
-   subdir('installed-tests')
+@@ -16,7 +16,7 @@
+ 
+ if build_standalone
    install_data(['daemon.conf'],
 -    install_dir : join_paths(sysconfdir, 'fwupd')
 +    install_dir : join_paths(sysconfdir_install, 'fwupd')
@@ -76,10 +76,10 @@ index 826a3c1d..b78db663 100644
 +  install_dir: join_paths(sysconfdir_install, 'fwupd', 'remotes.d'),
  )
 diff --git a/meson.build b/meson.build
-index 8e1de887..a5bb1fe6 100644
+index b1a523d2..aacb8e0a 100644
 --- a/meson.build
 +++ b/meson.build
-@@ -158,6 +158,12 @@
+@@ -169,6 +169,12 @@
  mandir = join_paths(prefix, get_option('mandir'))
  localedir = join_paths(prefix, get_option('localedir'))
  
@@ -89,14 +89,14 @@ index 8e1de887..a5bb1fe6 100644
 +  sysconfdir_install = sysconfdir
 +endif
 +
+ diffcmd = find_program('diff')
  gio = dependency('gio-2.0', version : '>= 2.45.8')
- giounix = dependency('gio-unix-2.0', version : '>= 2.45.8')
- if gio.version().version_compare ('>= 2.55.0')
+ giounix = dependency('gio-unix-2.0', version : '>= 2.45.8', required: false)
 diff --git a/meson_options.txt b/meson_options.txt
-index 71b50c6a..561c2031 100644
+index be0adfef..73983333 100644
 --- a/meson_options.txt
 +++ b/meson_options.txt
-@@ -24,6 +24,7 @@
+@@ -26,6 +26,7 @@
  option('systemd', type : 'boolean', value : true, description : 'enable systemd support')
  option('systemdunitdir', type: 'string', value: '', description: 'Directory for systemd units')
  option('elogind', type : 'boolean', value : false, description : 'enable elogind support')
@@ -105,10 +105,10 @@ index 71b50c6a..561c2031 100644
  option('udevdir', type: 'string', value: '', description: 'Directory for udev rules')
  option('efi-cc', type : 'string', value : 'gcc', description : 'the compiler to use for EFI modules')
 diff --git a/plugins/dell-esrt/meson.build b/plugins/dell-esrt/meson.build
-index cb9f4555..b972d7fb 100644
+index ed4eee70..76dbdb1d 100644
 --- a/plugins/dell-esrt/meson.build
 +++ b/plugins/dell-esrt/meson.build
-@@ -36,5 +36,5 @@
+@@ -37,5 +37,5 @@
    output : 'dell-esrt.conf',
    configuration : con2,
    install: true,
@@ -116,10 +116,10 @@ index cb9f4555..b972d7fb 100644
 +  install_dir: join_paths(sysconfdir_install, 'fwupd', 'remotes.d'),
  )
 diff --git a/plugins/redfish/meson.build b/plugins/redfish/meson.build
-index 5c88504e..7706da71 100644
+index 25fc5c7d..77eb9a83 100644
 --- a/plugins/redfish/meson.build
 +++ b/plugins/redfish/meson.build
-@@ -26,7 +26,7 @@
+@@ -27,7 +27,7 @@
  )
  
  install_data(['redfish.conf'],
@@ -129,7 +129,7 @@ index 5c88504e..7706da71 100644
  
  if get_option('tests')
 diff --git a/plugins/thunderbolt/meson.build b/plugins/thunderbolt/meson.build
-index 42718abf..bc815491 100644
+index 06ab34ee..297a9182 100644
 --- a/plugins/thunderbolt/meson.build
 +++ b/plugins/thunderbolt/meson.build
 @@ -46,7 +46,7 @@
@@ -142,10 +142,10 @@ index 42718abf..bc815491 100644
  # we use functions from 2.52 in the tests
  if get_option('tests') and umockdev.found() and gio.version().version_compare('>= 2.52')
 diff --git a/plugins/uefi/meson.build b/plugins/uefi/meson.build
-index 45b18d7d..ef8e0b04 100644
+index 39b5f566..0f904a22 100644
 --- a/plugins/uefi/meson.build
 +++ b/plugins/uefi/meson.build
-@@ -85,7 +85,7 @@
+@@ -87,7 +87,7 @@
  )
  
  install_data(['uefi.conf'],
diff --git a/pkgs/os-specific/linux/firmware/fwupd/default.nix b/pkgs/os-specific/linux/firmware/fwupd/default.nix
index aa2d99781786..280145a6838e 100644
--- a/pkgs/os-specific/linux/firmware/fwupd/default.nix
+++ b/pkgs/os-specific/linux/firmware/fwupd/default.nix
@@ -87,14 +87,14 @@ in
 
 stdenv.mkDerivation rec {
   pname = "fwupd";
-  version = "1.3.3";
+  version = "1.3.7";
 
   src = fetchurl {
     url = "https://people.freedesktop.org/~hughsient/releases/fwupd-${version}.tar.xz";
-    sha256 = "0nqzqvx8nzflhb4kzvkdcv7kixb50vh6h21kpkd7pjxp942ndzql";
+    sha256 = "02mzn3whk5mba4nxyrkypawr1gzjx79n4nrkhrp8vja6mxxgsf10";
   };
 
-  outputs = [ "out" "lib" "dev" "devdoc" "man" "installedTests" ];
+  outputs = [ "out" "dev" "devdoc" "man" "installedTests" ];
 
   nativeBuildInputs = [
     meson
@@ -148,10 +148,6 @@ stdenv.mkDerivation rec {
     ./fix-paths.patch
     ./add-option-for-installation-sysconfdir.patch
 
-    # do not require which
-    # https://github.com/fwupd/fwupd/pull/1568
-    ./no-which.patch
-
     # installed tests are installed to different output
     # we also cannot have fwupd-tests.conf in $out/etc since it would form a cycle
     (substituteAll {
@@ -163,7 +159,8 @@ stdenv.mkDerivation rec {
 
   postPatch = ''
     patchShebangs \
-      libfwupd/generate-version-script.py \
+      contrib/get-version.py \
+      contrib/generate-version-script.py \
       meson_post_install.sh \
       po/make-images \
       po/make-images.sh \
@@ -173,11 +170,6 @@ stdenv.mkDerivation rec {
     # https://github.com/NixOS/nix/issues/1846
     substituteInPlace data/installed-tests/meson.build --subst-var installedTests
 
-    # install plug-ins to out, they are not really part of the library
-    substituteInPlace meson.build \
-      --replace "plugin_dir = join_paths(libdir, 'fwupd-plugins-3')" \
-                "plugin_dir = join_paths('${placeholder "out"}', 'fwupd_plugins-3')"
-
     substituteInPlace data/meson.build --replace \
       "install_dir: systemd.get_pkgconfig_variable('systemdshutdowndir')" \
       "install_dir: '${placeholder "out"}/lib/systemd/system-shutdown'"
@@ -211,7 +203,6 @@ stdenv.mkDerivation rec {
     "--localstatedir=/var"
     "--sysconfdir=/etc"
     "-Dsysconfdir_install=${placeholder "out"}/etc"
-    "--libexecdir=${placeholder "out"}/libexec"
   ] ++ stdenv.lib.optionals (!haveDell) [
     "-Dplugin_dell=false"
     "-Dplugin_synaptics=false"
diff --git a/pkgs/os-specific/linux/firmware/fwupd/no-which.patch b/pkgs/os-specific/linux/firmware/fwupd/no-which.patch
deleted file mode 100644
index c0c65e42539d..000000000000
--- a/pkgs/os-specific/linux/firmware/fwupd/no-which.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/plugins/uefi/efi/generate_binary.sh
-+++ b/plugins/uefi/efi/generate_binary.sh
-@@ -1,9 +1,9 @@
- #!/bin/sh
- output=$2
--objcopy_cmd=$(which objcopy)
--genpeimg_cmd=$(which genpeimg)
-+objcopy_cmd=$(command -v objcopy)
-+genpeimg_cmd=$(command -v genpeimg)
- 
--$objcopy_cmd  -j .text \
-+"$objcopy_cmd"  -j .text \
-               -j .sdata \
-               -j .data \
-               -j .dynamic \
-@@ -11,7 +11,7 @@
-               -j .rel \
-               -j .rela \
-               -j .reloc \
--              $*
-+              "$@"
- 
- if [ -n "${genpeimg_cmd}" ]; then
-         $genpeimg_cmd -d \
-@@ -20,5 +20,5 @@
-                       +n \
-                       -d \
-                       +s \
--                      $output
-+                      "$output"
- fi
diff --git a/pkgs/os-specific/linux/jfbview/default.nix b/pkgs/os-specific/linux/jfbview/default.nix
index 84f2edc05fd3..58e058196bd3 100644
--- a/pkgs/os-specific/linux/jfbview/default.nix
+++ b/pkgs/os-specific/linux/jfbview/default.nix
@@ -15,13 +15,13 @@ in
 
 stdenv.mkDerivation rec {
   name = "${package}-${version}";
-  version = "0.5.6";
+  version = "0.5.7";
 
   src = fetchFromGitHub {
     repo = "JFBView";
     owner = "jichu4n";
     rev = version;
-    sha256 = "09rcmlf04aka0yzr25imadi0fl4nlbsxcahs7fhvzx4nql4halqw";
+    sha256 = "0ppns49hnmp04zdjw6wc28v0yvz31rkzvd5ylcj7arikx20llpxf";
   };
 
   postPatch = ''