about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/autotiling/default.nix14
1 files changed, 8 insertions, 6 deletions
diff --git a/pkgs/misc/autotiling/default.nix b/pkgs/misc/autotiling/default.nix
index b104f359363b..56e607c9d604 100644
--- a/pkgs/misc/autotiling/default.nix
+++ b/pkgs/misc/autotiling/default.nix
@@ -1,12 +1,14 @@
-{ lib, buildPythonApplication, fetchPypi, i3ipc, importlib-metadata }:
+{ lib, buildPythonApplication, fetchFromGitHub, i3ipc, importlib-metadata }:
 
 buildPythonApplication rec {
   pname = "autotiling";
-  version = "1.1";
+  version = "1.5";
 
-  src = fetchPypi {
-    inherit pname version;
-    sha256 = "0hwvy9bxwv9fakqqiyrkmpckxgm0z85c240p84ibdhja9sm086v0";
+  src = fetchFromGitHub {
+    owner = "nwg-piotr";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0ih8yd1gankjxn88gd88vxs6f1cniyi04z25jz4nsgqi9snz65v4";
   };
 
   propagatedBuildInputs = [ i3ipc importlib-metadata ];
@@ -16,7 +18,7 @@ buildPythonApplication rec {
     homepage = "https://github.com/nwg-piotr/autotiling";
     description = "Script for sway and i3 to automatically switch the horizontal / vertical window split orientation";
     license = licenses.gpl3Plus;
-    platforms= platforms.linux;
+    platforms = platforms.linux;
     maintainers = with maintainers; [ artturin ];
   };
 }