about summary refs log tree commit diff
path: root/pkgs/misc
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/misc')
-rw-r--r--pkgs/misc/drivers/foo2zjs/default.nix58
-rw-r--r--pkgs/misc/drivers/foomatic-filters/default.nix53
2 files changed, 111 insertions, 0 deletions
diff --git a/pkgs/misc/drivers/foo2zjs/default.nix b/pkgs/misc/drivers/foo2zjs/default.nix
new file mode 100644
index 000000000000..0f386d8ad899
--- /dev/null
+++ b/pkgs/misc/drivers/foo2zjs/default.nix
@@ -0,0 +1,58 @@
+x@{builderDefsPackage
+  , foomatic_filters, bc, unzip, ghostscript
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="foo2zjs";
+    version="20090908";
+    name="${baseName}-${version}";
+    url="http://ftp.de.debian.org/debian/pool/main/f/foo2zjs/foo2zjs_${version}dfsg.orig.tar.gz";
+    hash="1pg4dmckvlx94zxh4gcw7jfmyb10ada7f6vsp5bgz1z95fwwlqjz";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  phaseNames = ["fixMakefile" "doMakeInstall" "deployGetWeb"];
+  makeFlags = [
+    ''PREFIX=$out/''
+    ''UDEVBIN=$out/bin/''
+  ];
+  fixMakefile = a.fullDepEntry ''
+    touch all-test
+  '' ["doUnpack" "minInit"];
+
+  deployGetWeb = a.fullDepEntry ''
+    ensureDir "$out/bin"
+    cp ./getweb "$out/bin"
+  '' ["minInit" "defEnsureDir"];
+      
+  meta = {
+    description = "ZjStream printer drivers";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = a.lib.licenses.gpl2Plus;
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://packages.debian.org/sid/foo2zjs";
+    };
+  };
+}) x
diff --git a/pkgs/misc/drivers/foomatic-filters/default.nix b/pkgs/misc/drivers/foomatic-filters/default.nix
new file mode 100644
index 000000000000..59bdc6612a81
--- /dev/null
+++ b/pkgs/misc/drivers/foomatic-filters/default.nix
@@ -0,0 +1,53 @@
+x@{builderDefsPackage
+  , perl, cups
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="foomatic-filters";
+    version="4.0.6";
+    name="${baseName}-${version}";
+    url="http://www.openprinting.org/download/foomatic/${name}.tar.gz";
+    hash="0wa9hlq7s99sh50kl6bj8j0vxrz7pcbwdnqs1yfjjhqshfh7hsav";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  phaseNames = ["doConfigure" "fixPaths" "doMakeInstall"];
+
+  fixPaths = a.fullDepEntry ''
+    sed -e "s@= .*/store/[^/]\+/lib/cups/filter@= $out/lib/cups/filter@" -i Makefile
+    sed -e "s@= .*/store/[^/]\+/lib/cups/backend@= $out/lib/cups/backend@" -i Makefile
+    sed -e "s@= /usr/@= $out/@" -i Makefile
+  '' ["doConfigure" "minInit"];
+      
+  meta = {
+    description = "Foomatic printing filters";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = a.lib.licenses.gpl2Plus;
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://www.openprinting.org/download/foomatic/";
+    };
+  };
+}) x
+