about summary refs log tree commit diff
path: root/pkgs/lib/strings-with-deps.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/lib/strings-with-deps.nix')
-rw-r--r--pkgs/lib/strings-with-deps.nix2
1 files changed, 2 insertions, 0 deletions
diff --git a/pkgs/lib/strings-with-deps.nix b/pkgs/lib/strings-with-deps.nix
index 584afae9838d..78cded99ef71 100644
--- a/pkgs/lib/strings-with-deps.nix
+++ b/pkgs/lib/strings-with-deps.nix
@@ -42,6 +42,8 @@ rec {
 			(uniqList {inputList = textClosureDupList arg;}));
 	textClosure = arg: concatStringsSep "\n" (textClosureList arg);
 	
+	textClosureMap = f: arg: concatStringsSep "\n" (map f (textClosureList arg));
+
 	noDepEntry = text : {inherit text;deps = [];};
 	FullDepEntry = text : deps: {inherit text deps;};
 	PackEntry = deps: {inherit deps; text="";};