about summary refs log tree commit diff
path: root/pkgs/kde/gear/kdegraphics-thumbnailers/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/kde/gear/kdegraphics-thumbnailers/default.nix')
-rw-r--r--pkgs/kde/gear/kdegraphics-thumbnailers/default.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/pkgs/kde/gear/kdegraphics-thumbnailers/default.nix b/pkgs/kde/gear/kdegraphics-thumbnailers/default.nix
new file mode 100644
index 000000000000..bfb3ba1fc850
--- /dev/null
+++ b/pkgs/kde/gear/kdegraphics-thumbnailers/default.nix
@@ -0,0 +1,17 @@
+{
+  mkKdeDerivation,
+  substituteAll,
+  ghostscript,
+}:
+mkKdeDerivation {
+  pname = "kdegraphics-thumbnailers";
+
+  patches = [
+    # Hardcode patches to Ghostscript so PDF thumbnails work OOTB.
+    # Intentionally not doing the same for dvips because TeX is big.
+    (substituteAll {
+      gs = "${ghostscript}/bin/gs";
+      src = ./gs-paths.patch;
+    })
+  ];
+}