about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/steam/steamcmd.nix4
-rw-r--r--pkgs/games/steam/steamcmd.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/games/steam/steamcmd.nix b/pkgs/games/steam/steamcmd.nix
index 6a2c7fe01b4f..1ea7f0677877 100644
--- a/pkgs/games/steam/steamcmd.nix
+++ b/pkgs/games/steam/steamcmd.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, steam-run, bash
+{ stdenv, fetchurl, steam-run, bash, coreutils
 , steamRoot ? "~/.local/share/Steam"
 }:
 
@@ -29,8 +29,8 @@ stdenv.mkDerivation rec {
 
     mkdir -p $out/bin
     substitute ${./steamcmd.sh} $out/bin/steamcmd \
-      --subst-var shell \
       --subst-var out \
+      --subst-var-by coreutils ${coreutils} \
       --subst-var-by steamRoot "${steamRoot}" \
       --subst-var-by steamRun ${steam-run}
     chmod 0755 $out/bin/steamcmd
diff --git a/pkgs/games/steam/steamcmd.sh b/pkgs/games/steam/steamcmd.sh
index e092a4fedbe9..588badb41a1a 100644
--- a/pkgs/games/steam/steamcmd.sh
+++ b/pkgs/games/steam/steamcmd.sh
@@ -3,6 +3,9 @@
 # Always run steamcmd in the user's Steam root.
 STEAMROOT=@steamRoot@
 
+# Add coreutils to PATH for mkdir, ln and cp used below
+PATH=$PATH${PATH:+:}@coreutils@/bin
+
 # Create a facsimile Steam root if it doesn't exist.
 if [ ! -e "$STEAMROOT" ]; then
   mkdir -p "$STEAMROOT"/{appcache,config,logs,Steamapps/common}