about summary refs log tree commit diff
path: root/pkgs/games
diff options
context:
space:
mode:
authorSilvan Mosberger <infinisil@icloud.com>2019-04-06 16:34:18 +0200
committerGitHub <noreply@github.com>2019-04-06 16:34:18 +0200
commitc58c0792231739d754cae94313f5f4cdb5480cf8 (patch)
treed88263bf17313428bd546cb4587cf7afcf2491a4 /pkgs/games
parent4a985a67c51f04741e2445fcd8b0b8c1ccb778eb (diff)
parenta7b01d29badfd0a2d67704d68cecba6c5e8bfabd (diff)
downloadnixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.tar
nixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.tar.gz
nixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.tar.bz2
nixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.tar.lz
nixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.tar.xz
nixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.tar.zst
nixlib-c58c0792231739d754cae94313f5f4cdb5480cf8.zip
Merge pull request #58556 from Infinisil/fix/steamcmd
steamcmd: Add needed binaries to PATH
Diffstat (limited to 'pkgs/games')
-rw-r--r--pkgs/games/steam/steamcmd.nix4
-rw-r--r--pkgs/games/steam/steamcmd.sh3
2 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/games/steam/steamcmd.nix b/pkgs/games/steam/steamcmd.nix
index 6a2c7fe01b4f..1ea7f0677877 100644
--- a/pkgs/games/steam/steamcmd.nix
+++ b/pkgs/games/steam/steamcmd.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, steam-run, bash
+{ stdenv, fetchurl, steam-run, bash, coreutils
 , steamRoot ? "~/.local/share/Steam"
 }:
 
@@ -29,8 +29,8 @@ stdenv.mkDerivation rec {
 
     mkdir -p $out/bin
     substitute ${./steamcmd.sh} $out/bin/steamcmd \
-      --subst-var shell \
       --subst-var out \
+      --subst-var-by coreutils ${coreutils} \
       --subst-var-by steamRoot "${steamRoot}" \
       --subst-var-by steamRun ${steam-run}
     chmod 0755 $out/bin/steamcmd
diff --git a/pkgs/games/steam/steamcmd.sh b/pkgs/games/steam/steamcmd.sh
index e092a4fedbe9..588badb41a1a 100644
--- a/pkgs/games/steam/steamcmd.sh
+++ b/pkgs/games/steam/steamcmd.sh
@@ -3,6 +3,9 @@
 # Always run steamcmd in the user's Steam root.
 STEAMROOT=@steamRoot@
 
+# Add coreutils to PATH for mkdir, ln and cp used below
+PATH=$PATH${PATH:+:}@coreutils@/bin
+
 # Create a facsimile Steam root if it doesn't exist.
 if [ ! -e "$STEAMROOT" ]; then
   mkdir -p "$STEAMROOT"/{appcache,config,logs,Steamapps/common}