about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/argon2_cffi/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/argon2_cffi/default.nix b/pkgs/development/python-modules/argon2_cffi/default.nix
new file mode 100644
index 000000000000..80985f868c7a
--- /dev/null
+++ b/pkgs/development/python-modules/argon2_cffi/default.nix
@@ -0,0 +1,31 @@
+{ lib
+, cffi
+, six
+, hypothesis
+, pytest
+, wheel
+, buildPythonPackage
+, fetchPypi
+}:
+
+buildPythonPackage rec {
+  pname = "argon2_cffi";
+  version = "16.3.0";
+  name    = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1ap3il3j1pjyprrhpfyhc21izpmhzhfb5s69vlzc65zvd1nj99cr";
+  };
+
+  propagatedBuildInputs = [ cffi six ];
+  checkInputs = [ hypothesis pytest wheel ];
+  checkPhase = ''
+    pytest tests
+  '';
+
+  meta = {
+    description = "Secure Password Hashes for Python";
+    homepage    = https://argon2-cffi.readthedocs.io/;
+  };
+}