about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/haskell/cabal-cargs/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/libraries/haskell/cabal-cargs/default.nix b/pkgs/development/libraries/haskell/cabal-cargs/default.nix
new file mode 100644
index 000000000000..243dd2beb000
--- /dev/null
+++ b/pkgs/development/libraries/haskell/cabal-cargs/default.nix
@@ -0,0 +1,23 @@
+{ cabal, Cabal, cabalLenses, cmdargs, either, filepath, lens
+, strict, systemFileio, systemFilepath, tasty, tastyGolden, text
+, transformers, unorderedContainers
+}:
+
+cabal.mkDerivation (self: {
+  pname = "cabal-cargs";
+  version = "0.6.1";
+  sha256 = "1bf903kgs16f054crwq0yyp6ijch80qn3d5ksy4j0fnyxxrdqvsa";
+  isLibrary = true;
+  isExecutable = true;
+  buildDepends = [
+    Cabal cabalLenses cmdargs either lens strict systemFileio
+    systemFilepath text transformers unorderedContainers
+  ];
+  testDepends = [ filepath tasty tastyGolden ];
+  meta = {
+    description = "A command line program for extracting compiler arguments from a cabal file";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+    maintainers = [ self.stdenv.lib.maintainers.tomberek ];
+  };
+})