about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorThomas Bereknyei <tom@copilotlabs.com>2014-06-08 23:56:52 -0400
committerPeter Simons <simons@cryp.to>2014-06-09 10:27:00 +0200
commit766d934090f52adb9e932f04d9a90aa7c86b4ac7 (patch)
tree0c683bbd888f09bd6694892796cbb0b389a84d47 /pkgs/development
parent6071b304ef7fe8f848322ad4baf24889542483c2 (diff)
downloadnixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.tar
nixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.tar.gz
nixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.tar.bz2
nixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.tar.lz
nixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.tar.xz
nixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.tar.zst
nixlib-766d934090f52adb9e932f04d9a90aa7c86b4ac7.zip
haskell-cabal-cargs: add version 0.6.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/haskell/cabal-cargs/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/libraries/haskell/cabal-cargs/default.nix b/pkgs/development/libraries/haskell/cabal-cargs/default.nix
new file mode 100644
index 000000000000..243dd2beb000
--- /dev/null
+++ b/pkgs/development/libraries/haskell/cabal-cargs/default.nix
@@ -0,0 +1,23 @@
+{ cabal, Cabal, cabalLenses, cmdargs, either, filepath, lens
+, strict, systemFileio, systemFilepath, tasty, tastyGolden, text
+, transformers, unorderedContainers
+}:
+
+cabal.mkDerivation (self: {
+  pname = "cabal-cargs";
+  version = "0.6.1";
+  sha256 = "1bf903kgs16f054crwq0yyp6ijch80qn3d5ksy4j0fnyxxrdqvsa";
+  isLibrary = true;
+  isExecutable = true;
+  buildDepends = [
+    Cabal cabalLenses cmdargs either lens strict systemFileio
+    systemFilepath text transformers unorderedContainers
+  ];
+  testDepends = [ filepath tasty tastyGolden ];
+  meta = {
+    description = "A command line program for extracting compiler arguments from a cabal file";
+    license = self.stdenv.lib.licenses.bsd3;
+    platforms = self.ghc.meta.platforms;
+    maintainers = [ self.stdenv.lib.maintainers.tomberek ];
+  };
+})