about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libchewing/default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/pkgs/development/libraries/libchewing/default.nix b/pkgs/development/libraries/libchewing/default.nix
new file mode 100644
index 000000000000..0521ae8a0400
--- /dev/null
+++ b/pkgs/development/libraries/libchewing/default.nix
@@ -0,0 +1,21 @@
+{ stdenv, fetchurl, sqlite }:
+
+stdenv.mkDerivation rec{
+  name = "libchewing-${version}";
+  version = "0.4.0";
+
+  src = fetchurl {
+    url = "https://github.com/chewing/libchewing/releases/download/v${version}/libchewing-${version}.tar.bz2";
+    sha256 = "1j5g5j4w6yp73k03pmsq9n2r0p458hqriq0sd5kisj9xrssbynp5";
+  };
+
+  buildInputs = [ sqlite ];
+
+  meta = with stdenv.lib; {
+    description = "Intelligent Chinese phonetic input method";
+    homepage = http://chewing.im/;
+    license = licenses.lgpl21;
+    maintainers = [ maintainers.ericsagnes ];
+    platforms = platforms.linux;
+  };
+}