about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVladimír Čunát <vcunat@gmail.com>2015-11-26 09:17:52 +0100
committerVladimír Čunát <vcunat@gmail.com>2015-11-26 09:17:52 +0100
commit70d7cfdb8c4bb970daff73418389d7dbadf69005 (patch)
treec7d85c17dc53c753d51d1de3d735122655989f47 /pkgs/development
parent6ca51e30621c5daecdd3065444b913a6fb2c9366 (diff)
parent9d4a60f9cd1a15f4436cf8cf1691a46b47a24165 (diff)
downloadnixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.tar
nixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.tar.gz
nixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.tar.bz2
nixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.tar.lz
nixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.tar.xz
nixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.tar.zst
nixlib-70d7cfdb8c4bb970daff73418389d7dbadf69005.zip
Merge #11275: lisp: adding maintainer, small updates
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ccl/default.nix2
-rw-r--r--pkgs/development/compilers/cmucl/binary.nix1
-rw-r--r--pkgs/development/compilers/mkcl/default.nix1
-rw-r--r--pkgs/development/compilers/sbcl/bootstrap.nix2
-rw-r--r--pkgs/development/compilers/sbcl/default.nix6
-rw-r--r--pkgs/development/interpreters/gtk-server/default.nix1
-rw-r--r--pkgs/development/interpreters/picolisp/default.nix6
7 files changed, 10 insertions, 9 deletions
diff --git a/pkgs/development/compilers/ccl/default.nix b/pkgs/development/compilers/ccl/default.nix
index de6a041871ea..938361146e7a 100644
--- a/pkgs/development/compilers/ccl/default.nix
+++ b/pkgs/development/compilers/ccl/default.nix
@@ -73,7 +73,7 @@ stdenv.mkDerivation rec {
   meta = with stdenv.lib; {
     description = "Clozure Common Lisp";
     homepage    = http://ccl.clozure.com/;
-    maintainers = with maintainers; [ raskin muflax ];
+    maintainers = with maintainers; [ raskin muflax tohl ];
     platforms   = attrNames options;
     license     = licenses.lgpl21;
   };
diff --git a/pkgs/development/compilers/cmucl/binary.nix b/pkgs/development/compilers/cmucl/binary.nix
index 1276b1500a13..186cd908351f 100644
--- a/pkgs/development/compilers/cmucl/binary.nix
+++ b/pkgs/development/compilers/cmucl/binary.nix
@@ -37,5 +37,6 @@ stdenv.mkDerivation {
     '';
     license = stdenv.lib.licenses.free;		# public domain
     homepage = http://www.cons.org/cmucl/;
+    maintainers = [stdenv.lib.maintainers.tohl];
   };
 }
diff --git a/pkgs/development/compilers/mkcl/default.nix b/pkgs/development/compilers/mkcl/default.nix
index 6d17d5a8b25d..f6ab05bd29ba 100644
--- a/pkgs/development/compilers/mkcl/default.nix
+++ b/pkgs/development/compilers/mkcl/default.nix
@@ -27,6 +27,7 @@ stdenv.mkDerivation rec {
     homepage = https://common-lisp.net/project/mkcl/;
     license = stdenv.lib.licenses.lgpl2Plus;
     platforms = stdenv.lib.platforms.linux;
+    maintainers = [stdenv.lib.maintainers.tohl];
   };
 }
 
diff --git a/pkgs/development/compilers/sbcl/bootstrap.nix b/pkgs/development/compilers/sbcl/bootstrap.nix
index 43002aa72f57..d95e3e0cd897 100644
--- a/pkgs/development/compilers/sbcl/bootstrap.nix
+++ b/pkgs/development/compilers/sbcl/bootstrap.nix
@@ -57,7 +57,7 @@ stdenv.mkDerivation rec {
     description = "Lisp compiler";
     homepage = "http://www.sbcl.org";
     license = licenses.publicDomain; # and FreeBSD
-    maintainers = [maintainers.raskin];
+    maintainers = [maintainers.raskin maintainers.tohl];
     platforms = attrNames options;
   };
 }
diff --git a/pkgs/development/compilers/sbcl/default.nix b/pkgs/development/compilers/sbcl/default.nix
index c464d9856fc3..7b2cadc31d58 100644
--- a/pkgs/development/compilers/sbcl/default.nix
+++ b/pkgs/development/compilers/sbcl/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, sbclBootstrap, sbclBootstrapHost ? "${sbclBootstrap}/bin/sbcl --disable-debugger --no-userinit --no-sysinit", which }:
+{ stdenv, fetchurl, sbclBootstrap, sbclBootstrapHost ? "${sbclBootstrap}/bin/sbcl --disable-debugger --no-userinit --no-sysinit" }:
 
 stdenv.mkDerivation rec {
   name    = "sbcl-${version}";
@@ -9,8 +9,6 @@ stdenv.mkDerivation rec {
     sha256 = "1cwrmvbx8m7n7wkcm16yz7qwx221giz7jskzkvy42pj919may36n";
   };
 
-  buildInputs = [ which ];
-
   patchPhase = ''
     echo '"${version}.nixos"' > version.lisp-expr
     echo "
@@ -40,7 +38,7 @@ stdenv.mkDerivation rec {
       '/date defaulted-source/i(or (and (= 2208988801 (file-write-date defaulted-source-truename)) (= 2208988801 (file-write-date defaulted-fasl-truename)))'
 
     # Fix software version retrieval
-    sed -e "s@/bin/uname@$(which uname)@g" -i src/code/*-os.lisp
+    sed -e "s@/bin/uname@$(command -v uname)@g" -i src/code/*-os.lisp
 
     # Fix the tests
     sed -e '/deftest pwent/inil' -i contrib/sb-posix/posix-tests.lisp
diff --git a/pkgs/development/interpreters/gtk-server/default.nix b/pkgs/development/interpreters/gtk-server/default.nix
index 34ca504259eb..a318498ca645 100644
--- a/pkgs/development/interpreters/gtk-server/default.nix
+++ b/pkgs/development/interpreters/gtk-server/default.nix
@@ -17,5 +17,6 @@ stdenv.mkDerivation rec {
     description = "gtk-server for interpreted GUI programming";
     homepage = "http://www.gtk-server.org/";
     license = stdenv.lib.licenses.gpl2Plus;
+    maintainers = [stdenv.lib.maintainers.tohl];
   };
 }
diff --git a/pkgs/development/interpreters/picolisp/default.nix b/pkgs/development/interpreters/picolisp/default.nix
index cc9cac3a47fb..0e003af3aff1 100644
--- a/pkgs/development/interpreters/picolisp/default.nix
+++ b/pkgs/development/interpreters/picolisp/default.nix
@@ -3,10 +3,10 @@ with stdenv.lib;
 
 stdenv.mkDerivation rec {
   name = "picoLisp-${version}";
-  version = "3.1.11";
+  version = "15.11";
   src = fetchurl {
     url = "http://www.software-lab.de/${name}.tgz";
-    sha256 = "01kgyz0lkz36lxvibv07qd06gwdxvvbain9f9cnya7a12kq3009i";
+    sha256 = "0gi1n7gl786wbz6sn0f0002h49f0zvfrzxlhabkghwlbva1rwp58";
   };
   buildInputs = optional stdenv.is64bit jdk;
   patchPhase = optionalString stdenv.isArm ''
@@ -42,7 +42,7 @@ stdenv.mkDerivation rec {
     homepage = http://picolisp.com/;
     license = licenses.mit;
     platform = platforms.all;
-    maintainers = with maintainers; [ raskin ];
+    maintainers = with maintainers; [ raskin tohl ];
   };
 
   passthru = {