about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/documentation/mdsh/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/tools/documentation/mdsh/default.nix b/pkgs/development/tools/documentation/mdsh/default.nix
new file mode 100644
index 000000000000..74cde43440be
--- /dev/null
+++ b/pkgs/development/tools/documentation/mdsh/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchFromGitHub, rustPlatform }:
+
+rustPlatform.buildRustPackage rec {
+  name = "mdsh-${version}";
+  version = "0.1.2";
+
+  src = fetchFromGitHub {
+    owner = "zimbatm";
+    repo = "mdsh";
+    rev = "v${version}";
+    sha256 = "0sggclzghm54g4wnbab00qw4ry49min4zyw3hjwi0v741aa51xb2";
+  };
+
+  cargoSha256 = "1hsnz4sj8kff9azcbw9pkr2ipxlymz4zcm4vhfwydfkdlvdncpxm";
+
+  meta = with stdenv.lib; {
+    description = "Markdown shell pre-processor";
+    homepage = https://github.com/zimbatm/mdsh;
+    license = with licenses; [ mit ];
+    maintainers = with maintainers; [ zimbatm ];
+    platforms = platforms.all;
+  };
+}