about summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/hmmlearn/default.nix23
-rw-r--r--pkgs/development/python-modules/pychromecast/default.nix21
-rw-r--r--pkgs/development/python-modules/sphfile/default.nix23
3 files changed, 67 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/hmmlearn/default.nix b/pkgs/development/python-modules/hmmlearn/default.nix
new file mode 100644
index 000000000000..eeb042452155
--- /dev/null
+++ b/pkgs/development/python-modules/hmmlearn/default.nix
@@ -0,0 +1,23 @@
+{ lib, fetchurl, buildPythonPackage, numpy }:
+
+buildPythonPackage rec {
+  name = "hmmlearn-${version}";
+  version = "0.2.0";
+
+  src = fetchurl {
+    url = "mirror://pypi/h/hmmlearn/${name}.tar.gz";
+    sha256 = "0qc3fkdyrgfg31y1a8jzs83dxkjw78pqkdm44lll1iib63w4cik9";
+  };
+
+  propagatedBuildInputs = [ numpy ];
+
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Hidden Markov Models in Python with scikit-learn like API";
+    homepage    = "https://github.com/hmmlearn/hmmlearn";
+    license     = licenses.bsd3;
+    maintainers = with maintainers; [ abbradar ];
+    platforms   = platforms.unix;
+  };
+}
diff --git a/pkgs/development/python-modules/pychromecast/default.nix b/pkgs/development/python-modules/pychromecast/default.nix
new file mode 100644
index 000000000000..440a1aa7785e
--- /dev/null
+++ b/pkgs/development/python-modules/pychromecast/default.nix
@@ -0,0 +1,21 @@
+{ lib, fetchurl, buildPythonPackage, requests, six, zeroconf, protobuf }:
+
+buildPythonPackage rec {
+  name    = "PyChromecast-${version}";
+  version = "0.8.1";
+
+  src = fetchurl {
+    url    = "mirror://pypi/p/pychromecast/${name}.tar.gz";
+    sha256 = "05rlr2hjng0xg2a9k9vwmrlvd7vy9sjhxxfl96kx25xynlkq6yq6";
+  };
+
+  propagatedBuildInputs = [ requests six zeroconf protobuf ];
+
+  meta = with lib; {
+    description = "Library for Python 2 and 3 to communicate with the Google Chromecast";
+    homepage    = "https://github.com/balloob/pychromecast";
+    license     = licenses.mit;
+    maintainers = with maintainers; [ abbradar ];
+    platforms   = platforms.linux;
+  };
+}
diff --git a/pkgs/development/python-modules/sphfile/default.nix b/pkgs/development/python-modules/sphfile/default.nix
new file mode 100644
index 000000000000..8c2351c981e9
--- /dev/null
+++ b/pkgs/development/python-modules/sphfile/default.nix
@@ -0,0 +1,23 @@
+{ lib, fetchurl, buildPythonPackage, numpy }:
+
+buildPythonPackage rec {
+  name = "sphfile-${version}";
+  version = "1.0.0";
+
+  src = fetchurl {
+    url = "mirror://pypi/s/sphfile/${name}.tar.gz";
+    sha256 = "1ly9746xrzbiax9cxr5sxlg0wvf6fdxcrgwsqqxckk3wnqfypfrd";
+  };
+
+  propagatedBuildInputs = [ numpy ];
+
+  doCheck = false;
+
+  meta = with lib; {
+    description = "Numpy-based NIST SPH audio-file reader";
+    homepage    = "https://github.com/mcfletch/sphfile";
+    license     = licenses.mit;
+    maintainers = with maintainers; [ abbradar ];
+    platforms   = platforms.unix;
+  };
+}